Jump to content

Too Many Redirects error when enabling HTTPS


BuffaloR
 Share

Go to solution Solved by BuffaloR,

Recommended Posts

I actually saw this behavior when you shared your link to ask about the mobile hamburger menu.  (I was at first going to say your site did not even work on mobile, but saw you fixed it.)

While I could not load it at all on my phone, on my laptop I was able to grab the console output by turning on developer mode.  In the console, it was showing: 

931895597_ScreenShot2022-01-22at8_39_34PM.png.b817b4e49bb7f4db43d077fc80dfeaa6.png

Try disabling chatbox and then turning on HTTPS mode.  If that works, most likely your chatbox is calling something incorrectly over http and forcing the loop.  

Also...  once you turn on HTTPS, you might need to rebuild your system cache in the Admin CP.  Click on the support link inside of your ACP and then find the clear cache option on the right hand side of the page.  

Finally...  I see you're using GCP for hosting.  Are you by any chance using their CDN as well?  If so, you need to clear the cache in ACP and then clear it also on the Google side.  

Link to comment
Share on other sites

1 hour ago, Randy Calvert said:

I actually saw this behavior when you shared your link to ask about the mobile hamburger menu.  (I was at first going to say your site did not even work on mobile, but saw you fixed it.)

While I could not load it at all on my phone, on my laptop I was able to grab the console output by turning on developer mode.  In the console, it was showing: 

931895597_ScreenShot2022-01-22at8_39_34PM.png.b817b4e49bb7f4db43d077fc80dfeaa6.png

Try disabling chatbox and then turning on HTTPS mode.  If that works, most likely your chatbox is calling something incorrectly over http and forcing the loop.  

Also...  once you turn on HTTPS, you might need to rebuild your system cache in the Admin CP.  Click on the support link inside of your ACP and then find the clear cache option on the right hand side of the page.  

Finally...  I see you're using GCP for hosting.  Are you by any chance using their CDN as well?  If so, you need to clear the cache in ACP and then clear it also on the Google side.  

 

Thank you for the awesome suggestions and help! I’ll give that a try. I just noticed that the forum can’t start new threads now either - maybe it’s the same issue.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...