Jump to content

Issues related to IPBOARD Migration toward subdomain


Go to solution Solved by Aurélie Grignard,

Recommended Posts

Hello,

for pratical reason, I have decided to migrate my IPBOARD forum to my subdomain (instead of my main domain).

My  assistant was able to migrate my Ipboard integration, however the application is using some hardcoded URLS and some of the fonts are no loading due to:
 

Access to font at 'https://aromaquantisme.com/communaute/applications/core/interface/font/fontawesome-webfont.ttf?v=4.7.0' from origin 'https://champ.aromaquantisme.com' has been blocked by CORS policy: No 'Access-Control-Allow-Origin' header is present on the requested resource.



He has already updated the main application's config file to work with the URL of https://champ.aromaquantisme.com/communaute/, however he suspects that the font URLs needs to be updated manually or you will need to re-build the application's cache (if any).

 

Please could you tell me how to proceed to solve this fonts issues?

 

best regards,

 

 

Link to comment
Share on other sites

If you’re typing in the admin CP address and it’s forwarding you to the old address one of two situations is happening:

- Your conf_global.php was not updated correctly. (You need to update both the server path AND the domain address in the file)

- You have a server/network level redirect in place. Your hosting provider would have to change that if it’s used. 

Link to comment
Share on other sites

Thank you @Randy Calvert,

When checking the advice  you provided both conf_global.php files for the main and sub domain are migrated properly and updated to point towards their respective database and URL.

I also made sure that there isn't any server side redirections occurring for your domain or subdomain and I temporarily disabled the static caching provided by Nginx direct delivery from SiteTools -> Speed -> Caching to make sure no .htaccess rules are affected or have cache served for them.

After additionnal research, I have managed to log in the AdminCP for the subdomain.. and I may have found the main issue : on my dashboard I have a big read warning saying "Invalid licence Key".

Do you know how I can valid my IPBOARD licence key for my subdomain instead of my main domain?

Thank you for your help.

 

Link to comment
Share on other sites

To fix your license key, login to the IPB Client Area and choose Manage Purchases. Find your instance and there should be a section there to change your address. 

Also… here’s a dumb idea. It’s possible your browser cache is still calling some old URLs. Have you also flushed your browser’s cache?  

Link to comment
Share on other sites

As mentioned aboce, you can change the URL within your client area. That however would not in any way cause the issue you are having. Check any caching you have running on  your server, clear your browser cache, and double check for any redirects you may have set up. Also ensure you have edited your htaccess file if you have anything in there related directly to the URL. 

Link to comment
Share on other sites

  • 2 weeks later...

thank @Randy Calvert I have updated the key licence.

 

Hello @marc stridgen, not yet, I did not.

The config file contains:

  'base_url' => 'https://champ.aromaquantisme.com/communaute/',


This is the correct path.

When I try accessing:
https://champ.aromaquantisme.com/communaute/index.php?/

Everything works fine. However whenever I try accessing https://champ.aromaquantisme.com/communaute/index.php?/login/, I am redirected to the old main domain, which is the problem.

I will check the htaccess file and see if it helps.

 

I have also noticed that when I am connected to the admin panel, I am not allow to custom the layout/desing of the forum (like changing color). It doesn't consider myself as "log-in".

Just now, Aurélie Grignard said:

thank @Randy Calvert I have updated the key licence.

 

Hello @marc stridgen, not yet, I did not.

The config file contains:

  'base_url' => 'https://champ.aromaquantisme.com/communaute/',


This is the correct path.

When I try accessing:
https://champ.aromaquantisme.com/communaute/index.php?/

Everything works fine. However whenever I try accessing https://champ.aromaquantisme.com/communaute/index.php?/login/, I am redirected to the old main domain, which is the problem.

I will check the htaccess file and see if it helps.

 

I have also noticed that when I am connected to the admin panel, I am not allow to custom the layout/desing of the forum (like changing color). It doesn't consider myself as "log-in".

Hello @Marc Stridgen you were not tagged proprely so I add you here 😉

Hello @Marc Stridgen

 

The .htaccess in the upper folder contains no domain specific elements:

 cat .htaccess 

# SGS XMLRPC Disable Service

<Files xmlrpc.php>

	order deny,allow

	deny from all

</Files>

# SGS XMLRPC Disable Service END

# SGS XSS Header Service

<IfModule mod_headers.c>

    # SGS XSS

     Header always set X-Content-Type-Options "nosniff"

     Header set X-XSS-Protection "1; mode=block"

    # SGS XSS END

</IfModule>

# SGS XSS Header Service END







# BEGIN WordPress

# Les directives (lignes) entre « BEGIN WordPress » et « END WordPress » sont générées

# dynamiquement, et doivent être modifiées uniquement via les filtres WordPress.

# Toute modification des directives situées entre ces marqueurs sera surchargée.

<IfModule mod_rewrite.c>

RewriteEngine On

RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

RewriteBase 
RewriteRule ^index\.php$ - [L]

RewriteCond %{REQUEST_FILENAME} !-f

RewriteCond %{REQUEST_FILENAME} !-d

RewriteRule . /index.php [L]

</IfModule>



# END WordPress



# SGO Unset Vary

  Header unset Vary

# SGO Unset Vary ENDbaseos



There is no htaccess in the communaute folder.

 

could tell me where I could find this htaccess folder in order to update it ?

 

Edited by Aurélie Grignard
tag
Link to comment
Share on other sites

Make sure when you upload the file, you rename it to ".htaccess" with the period up front.  I know when I download by default, it saves as htaccess with no extension.  

Also...  if that does not work, edit the path to reflect your subfolder.  

You might need something like:

<IfModule mod_rewrite.c>
Options -MultiViews
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule \.(js|css|jpeg|jpg|gif|png|ico|map|webp)(\?|$) /404error.php [L,NC]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /communaute/index.php [L]
</IfModule>

 

Link to comment
Share on other sites

Thanks, @Randy Calvert

we did that. Now, it brings me back to my subdomain log-in page.

It is a good news in the sense that I doesn't send us to the main domain...

However, it brings me to the general log-in page for my membership so people ends up on the course portal instead of the forum.

 

Futher, I am still unable to edit the forum. The forum still consider myself as "log out" and when I try to log-in, it sends me back to the course portal... even if I am log-in there. It doesn't give me access to the forum.. I really don't understand.

Link to comment
Share on other sites

2 hours ago, Aurélie Grignard said:

SOLVED

so, the final problem was that I had to reset my wordpress SSO which I used to bridge WP and the IPBOARD.

it is all good now.

thank you @Randy Calvert for your time and advice 🙂

have a great day

Ah, you are using an external login method, that would explain it. Very glad to hear you found the problem there

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...