Jump to content

Cloudflare blocks login to Marketplace


evcom
 Share

Go to solution Solved by evcom,

Recommended Posts

My community is self-hosted and I use the free Cloudflare plan together with IC. Works quite well!
One problem though I have, is that Cloudflare seems to block login to the Marketplace and the error below is shown. 

image.png.07c8c2d3eafafe8666ae1ea9cb504ff1.png

In Cloudflare I whitelisted the URL as follows:
Firewall > Firewall Rules:

image.png.d8809a60e4a45d05f7e9f0f437b49ba7.png

image.png.fd157bb1b99d847f860b5ac8cdcda99d.png

This unfortunatey does not resolve the issue. I am aware that this is an issue around the configuration of Cloudflare, but I hope since many IC installations use Cloudflare, someone might be able to help how to whitelist the marketplace URL.

Thanks!

Edited by evcom
typo
Link to comment
Share on other sites

29 minutes ago, AlexWebsites said:

Must be a hosted issued because I'm self-hosted and use cloudflare with no issues accessing the marketplace within the ACP. No whitelist needed.

Its actually more likely to be an issue with the way they have cloudflare set up. The issue is that its not getting back to their hosting

Link to comment
Share on other sites

Hi all, thanks for your suggestions. just tried a few things: Cleared caches, tested live website, adjusted settings in CF. 
It is still the same. Found a quick fix:
1. Pause Cloudflare temporarily
2. Login to Marketplace
3. Activate Cloudflare again
At least this way it's possible to continue with upgrading etc..This also confirms that it seems to be a Cloudflare setting. Guess I will need to reach out to their support. 

Link to comment
Share on other sites

  • Solution

The Cloudflare Community came to the rescue with the right pointer. The 'activity log' of the firewall rules shows the details of the triggered event. What I now did, is to allow the Invision Community user agent...This resolved the issue and login to the marketplace is no longer blocked. 

There might be better solutions. Suggestions are welcome 🙂

Edited by evcom
Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...