Jump to content

Locked Task: viewupdates


Christ30
 Share

Go to solution Solved by Stuart Silvester,

Recommended Posts

After upgrade, i have this error:

Quote

Locked Task: viewupdates

One of the routine maintenance tasks which run in the background has failed several times, which may indicate a configuration issue.

  • Application/Plugin
    System
  • Task
    viewupdates
  • Last Run
    6 hours ago

When i run the task:

 

Quote

Sorry, you do not have permission for that!

2C124/2 The task is already running and cannot be ran until it has finished or the lock is removed.

 

The System logs:

Quote

TypeError: array_keys(): Argument #1 ($array) must be of type array, null given (0)
#0 /home/c/public_html/applications/core/tasks/viewupdates.php(85): array_keys()
#1 /home/c/public_html/system/Task/Task.php(367): IPS\core\tasks\_viewupdates->IPS\core\tasks\{closure}()
#2 /home/c/public_html/applications/core/tasks/viewupdates.php(120): IPS\_Task->runUntilTimeout()
#3 /home/c/public_html/system/Task/Task.php(266): IPS\core\tasks\_viewupdates->execute()
#4 /home/c/public_html/system/Task/Task.php(229): IPS\_Task->run()
#5 /home/c/public_html/applications/core/interface/task/task.php(58): IPS\_Task->runAndLog()
#6 {main}

 

Quote

#0 /home/c/public_html/init.php(1005): IPS\_Log::log()
#1 [internal function]: IPS\IPS::exceptionHandler()
#2 {main}

 

Link to comment
Share on other sites

  • Solution

It sounds like PHPRedis may be returning an unexpected value on your server (this value should always be an array, whether it's empty or not).

We'll make some minor robustness changes in a future release to handle this situation though.

Edit: A workaround in the meantime would be to disable the 'Use Redis to reduce MySQL overhead' setting in your data storage configuration

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...