Jump to content

Doesn't upload large files


INDIG0
 Share

Go to solution Solved by Stuart Silvester,

Recommended Posts

Hello.

Why can't I upload large files >200 MB?

[Thu Dec 02 18:36:05.815738 2021] [fcgid:warn] [pid 30965] [client xx.xx.xxx.xx:xxxxx] mod_fcgid: stderr: PHP Fatal error:  Allowed memory size of 3246391296 bytes exhausted (tried to allocate 1063040304 bytes) in /var/www/site/data/www/site.ru/system/Http/Request/Sockets.php on line 269, referer: https://site.ru/topic/4447-test/

There are maximum limits everywhere

php.ini

max_input_vars = "10000"
opcache.max_accelerated_files = "100000"
output_buffering = "4096"
session.save_path = "/var/www/site/data/tmp"
upload_max_filesize = "3000M"
log_errors = "On"
mail.add_x_header = "On"
max_execution_time = "1800"
memory_limit = "3096M"
sendmail_path = "/usr/sbin/sendmail -t -i -f 'admin@site.ru'"
upload_tmp_dir = "/var/www/site/data/tmp"
date.timezone = "Europe/Moscow"
post_max_size = "3000M"
opcache.blacklist_filename = "/opt/opcache-blacklists/opcache-*.blacklist"
short_open_tag = "On"
display_errors = "off"

Edited by INDIG0
Link to comment
Share on other sites

1 minute ago, Marc Stridgen said:

That message being logged is being logged by your PHP instances limits unfortunately, and isnt being returned by the software

Maybe there is a problem with the cloud? Because s3 is connected to store files.

Link to comment
Share on other sites

  • Solution

Your upload_max_size, post_max_size and memory_limit are way too large.

Having these huge values (especially the post/upload) is actually counter-intuitive. When you have these set to such large values, the files being uploaded won't be processed in chunks.

If you set upload_max_size/post_max_size to something like 10M, you will have a much better chance of your upload succeeding.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...