Jump to content

Users unable to like/navigate page numbers


Jon Sutton
 Share

Go to solution Solved by Jon Sutton,

Recommended Posts

Unfortunately, I am not able to reproduce any issues on your community with that particular user. Have a few questions:

  1. Is this happening everywhere for that user or is it a specific topic? Either way, could you please have the user supply the URL they are accessing at the time of encountering this?
  2. Are other users encountering this?
  3. Is the user using an anti-virus or other extension which is requiring HTTPS? As your community is setup for HTTP, it would not work over HTTPS unless changed to do so.
Link to comment
Share on other sites

  • Solution

Sorry for the delay, all - thought I turned on notifications for this thread, turns out I didn't.

Super smart idea to impersonate the user - I did that and didn't notice any of the errors he was saying he was finding, so I am surmising that this is indeed on his end.  He is the only user posting this, so I'll work with him on javascript.  He said he cleared the cache, but I can walk him through that to ensure he actually did.

Link to comment
Share on other sites

  • 5 months later...

Hello all - I wanted to bring up an old topic in the hopes you all could help me again.

We've been able to determine that it is, indeed, related to javascript.  Users are mentioning again that there are problems.

@Jim M- in an earlier reply you mentioned HTTP vs HTTPS.  We just updated our SSL on our site right around the time folks started mentioning these problems again.  Could that be causing some javascript issues and, if so, do you have a suggested solution?  Thanks so much for any wisdom.

Link to comment
Share on other sites

Have you made sure HTTPS is actually installed and working?  (Can you load an image via HTTPS?)

If so, after editing conf_global.php you need to make sure you rebuild the system cache in the ACP so that any cached references to HTTP get updated as well. 

Link to comment
Share on other sites

32 minutes ago, Jon Sutton said:

When we change the HTPP settings as shown in this guide, we run into redirect issues that cause the site to be inaccessible.  Any idea what might be causing our errors?

You'll want to remove any server-based redirects of HTTP to HTTPS. Then ensure that you update the guide fully as Randy mentioned.

Link to comment
Share on other sites

Does anyone have a good idea why when navigating to a thread one particular way (for example, clicking the most recent thread in a forum via the forum homepage) or navigating a different way (e.g. clicking forum -> subforum -> thread from front page of thread links in subforum) would produce different SSL responses?  The former is not SSL while the latter is and I can't articulate why.

Link to comment
Share on other sites

Posted (edited)

Could you give us an example?  Specifically one where it's good and one where it's not working?  

My GUESS is your server has both HTTP and HTTPS support enabled.  If you had old links posted that had the HTTP version, those would try to go to the non-secure version and could result in a mix-mode issue

So you MIGHT need to put in a redirect to send anything directed to HTTP to HTTPS transparently.

This can be done via your .htaccess file...  

Find 

RewriteEngine On

Under it add:

RewriteCond %{HTTPS} !=on
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301,NE]

That will tell your server if it receives any connection on port 80 (HTTP) to automatically direct the request to your HTTPS version of your URL and keep the rest of the path/URL in place.  (http://www.domain.com/path/to/logo.jpg would redirect automatically to https://www.domain.com/path/to/logo.jpg)

Edited by Randy Calvert
Link to comment
Share on other sites

Yup...  new links from the IPB software are showing up as HTTPS.   

https://www.hoosiersportsnation.com/index.php?/topic/10442-i-promise-that-wasnt-a-crash/

However you can still access that URL via HTTP if someone had pasted a link to it for example, I can manually change that link above to: 

http://www.hoosiersportsnation.com/index.php?/topic/10442-i-promise-that-wasnt-a-crash/

Any links posted by members or links indexed by Google over HTTP are not being forced to HTTPS.  You just need to enforce your site redirecting HTTP requests to HTTPS.  If you're using cPanel, you can check out the following blog post:

https://blog.cpanel.com/force-https-redirection/

Otherwise you can just modify your .htaccess file in your main website folder to add the HTTPS redirect to it.  (See my earlier post.)

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...