Jump to content

Server guru help re: failed uploads?

Recommended Posts

OK, sooooo, wondering if any of you server gurus have any insights on this?

Long story short: I am unable to upload the large files (~600MB and even up to 1GB) I need to work with clients on my production site.  The uploads inevitably fail (no progress meters at all, although I know this is a known issue Invision is fixing) with an Invision error -200, and the server error I always get is:

[Thu Sep 09 21:17:32.111198 2021] [proxy_fcgi:error] [pid 22642:tid 140608424314624] (103)Software caused connection abort: [client] AH01075: Error dispatching request to : (reading input brigade), referer: https://XXX.XXX/index.php?/files/submit/&do=submit&category=1

Now, there's a wrinkle to this story.

To troubleshoot this issue I've tried test installs on several different accounts on my VPS, on both top-level and in subfolders.  Every single one of them fails the same way with the exception of my original test installation, which was in a subfolder.  That installation works perfectly, and I even get the upload progress meter!

Added wrinkle: when I tried a clean, brand spanking-new test install in the top level of the same domain as my original test install, it failed.  Only when I restored my original test installation from a backup file did I get the working version back.

My VPS provider is currently troubleshooting the issue, which (pardon my layperson language) seems to have something to do with server timeouts or something.  Yet my existing test install works just fine (and all of these accounts are on the same VPS).  This would seem to rule out the Invision software, and would mean there is some config anomaly in my test install separate to the other sites.

Anyone familiar with this error?



Edited by liquidfractal
Link to comment
Share on other sites

15 hours ago, Jimi Wikman said:

Could be a FastCGI issue...

Are you uploading through a form I assume, so then it could be mod_reqtimeout if you are on Apache, or the php.ini need to be adjusted (can be in root or per accoount, or both).


Thanks for the response @Jimi Wikman.  I'm uploading through Invision's Add File page from the Downloads module.

The added twist: a colleague of mine in Toronto has been able to successfully upload a 1.2GB file (without progress meter).  I can also download it without issues.  So I'm wondering if it's a combination of the lack of a progress meter with whatever effects that might have on my throughput/timeout (I'm in Australia; my server is on the US West Coast).

Link to comment
Share on other sites

  • 1 month later...

Firstly check is SElinux is running - if it is kill and disable it - it sucks

Then check the logs - in particular 

PHP-FPM log (default: /var/log/php-fpm.log)

This may give more information

You could also look at 


located normally in 


To see what its currently set at 

This relates to an Apache server......

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...