Jump to content

There's something wrong with .mov files embedding


Ramsesx
 Share

Go to solution Solved by Daniel F,

Recommended Posts

7 hours ago, Jim M said:

What browser are you using? Only Safari AFAIK fully supports MOV. Whereas, MP4 is widely supported. If your browser does not support the video file, it will show as a downloadable attachment. 

It's not a browser issue, I did a test on another forum platform (Xenforo) with the same browser and it works:

477550522_2021-08-2712_23.44xenforo.come2766641faed.png.ee72c7c73b254f100036f0b6d55e844e.png

Link to comment
Share on other sites

1 hour ago, Ramsesx said:

It's not a browser issue, I did a test on another forum platform (Xenforo) with the same browser and it works:

477550522_2021-08-2712_23.44xenforo.come2766641faed.png.ee72c7c73b254f100036f0b6d55e844e.png

I’m afraid, I can only tell you why it isn’t working on our software. That forum may be using a custom player (or other behind-the-scenes conversions) rather than a native HTML5 player like we do. 

Link to comment
Share on other sites

  • 2 weeks later...
On 9/8/2021 at 3:05 PM, pequeno said:

Thnks.

Same problem here! I can´t view MOV video in post.

I think you still won't be able to except on Safari?

This is also a big issue on my site where some iPhone users submit MOVs and android users can view them.  Need a better automated solution, not feasible to download, convert and reupload them 

Link to comment
Share on other sites

On 9/11/2021 at 3:21 PM, Clover13 said:

I think you still won't be able to except on Safari?

This is also a big issue on my site where some iPhone users submit MOVs and android users can view them.  Need a better automated solution, not feasible to download, convert and reupload them 

Videos being playable are actually dependent upon the browser and OS. MOV files are an apple format, so indeed only play on apple devices natively

Link to comment
Share on other sites

7 hours ago, Marc Stridgen said:

Videos being playable are actually dependent upon the browser and OS. MOV files are an apple format, so indeed only play on apple devices natively

Understood, however from the site owner perspective, we want tooling that automates making videos device and browser agnostic.  We can't control what our members use to take videos, but given Invision Community's use of HTML5's video rendering, can we not control some automated conversion of uploaded files to an HTML5 compatible format for all browsers?

Link to comment
Share on other sites

2 minutes ago, Clover13 said:

Understood, however from the site owner perspective, we want tooling that automates making videos device and browser agnostic.  We can't control what our members use to take videos, but given Invision Community's use of HTML5's video rendering, can we not control some automated conversion of uploaded files to an HTML5 compatible format for all browsers?

That isnt something that the software provides at present time, and I believe it would require 3rd party item to do so, even with html5.

Link to comment
Share on other sites

  • 2 weeks later...
14 minutes ago, Clover13 said:

Hi @Daniel F, is there a bug tracker or anything we can subscribe to so we can track these updates/changes?  

This issue was fixed in 4.6.6 as detailed in the release notes - https://invisioncommunity.com/release-notes/

Fixed an issue where videos attachments that are not supported by a browser may not be downloadable.

 

Link to comment
Share on other sites

23 minutes ago, Stuart Silvester said:

This issue was fixed in 4.6.6 as detailed in the release notes - https://invisioncommunity.com/release-notes/

Fixed an issue where videos attachments that are not supported by a browser may not be downloadable.

 

OK, I'm on 4.6.6 and still seeing the download issue where I get an error "Sorry! We could not locate the item you are trying to view." in browsers that can't natively embed/display the MOV file.

 

Link to comment
Share on other sites

6 minutes ago, Clover13 said:

OK, I'm on 4.6.6 and still seeing the download issue where I get an error "Sorry! We could not locate the item you are trying to view." in browsers that can't natively embed/display the MOV file.

 

I'm sorry, I could have made this clearer. It isn't a retroactive fix, it will only apply to content posted after you upgrade.

Link to comment
Share on other sites

4 minutes ago, Stuart Silvester said:

I'm sorry, I could have made this clearer. It isn't a retroactive fix, it will only apply to content posted after you upgrade.

Ah, OK that part I did not know.  So all existing attachments will just be broken for devices that can't play them natively?  Is there an automated method to fix this retroactively (I'm assuming maybe not, otherwise it would have been part of the upgrade script), and if not this is quite a stickler for user experience as I'm getting a lot of PMs and posts on broken attachments? 

Link to comment
Share on other sites

  • 2 weeks later...
On 9/22/2021 at 5:50 PM, Stuart Silvester said:

I'm sorry, I could have made this clearer. It isn't a retroactive fix, it will only apply to content posted after you upgrade.

Sorry but for me don´t solve the problem in 4.6.6. in new MOV videos. 🤔

 

On 9/11/2021 at 4:21 PM, Clover13 said:

I think you still won't be able to except on Safari?

Yes. In IPS 4.6.6 works only in Safari.

On 9/23/2021 at 8:50 AM, Marc Stridgen said:

There is nothing in which will fix content that has already been posted unfortunately

Hello.

I check upload new MOV files to the invision test forum and doesn´t work!

In my 4.6.6. forum, it doesn't work either

Edited by pequeno
Link to comment
Share on other sites

On 10/2/2021 at 9:05 AM, pequeno said:

Sorry but for me don´t solve the problem in 4.6.6. in new MOV videos. 🤔

 

Yes. In IPS 4.6.6 works only in Safari.

Hello.

I check upload new MOV files to the invision test forum and doesn´t work!

In my 4.6.6. forum, it doesn't work either

When you say it doesnt work, what exactly isnt working? Are you referring to automatically embedding? If so, that is actually correct. It will only play in safari as its an apple movie standard. The issue however was that it wouldnt download in other browsers instead of embedding. That is what was resolved. Please could you clarify?

Link to comment
Share on other sites

  • 1 month later...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...