Jump to content

Two Factor Authentication not working?


Giray
 Share

Recommended Posts

Hi.

Anyone having trouble with two factor authentication? I'm on 4.6.4 and when the authentication window comes up (on the admin side) when I type in the response, it won't let me through. I had to authenticate via email. It has done this consistently since yesterday.

Thoughts anyone?

Thx!!

Link to comment
Share on other sites

3 hours ago, Giray said:

Hi.

Anyone having trouble with two factor authentication? I'm on 4.6.4 and when the authentication window comes up (on the admin side) when I type in the response, it won't let me through. I had to authenticate via email. It has done this consistently since yesterday.

Thoughts anyone?

Thx!!

Don't press the enter/return key after typing your code - click the 'Verify Code' button instead.

No idea if it's an intentional change, but the addition of the X to close the box makes me think it is 'working as intended' in its current state.

Ignore, I see it's been patched.

Edited by Nathan Explosion
Link to comment
Share on other sites

5 minutes ago, Adriano Faria said:

The patch? Nothing appears to me beyond “Running latest version”.

I jus login to the ACP and find a patch, so I update, maybe it take time or something for location (ISP update as example).

Edited by abobader
Link to comment
Share on other sites

Hi Adriano,

Before figuring out that the TFA problem was on Invision's side, I made the stupid mistake of trying to debug and uninstalled your TFA masking plugin. The problem is that now when I go to install it again, IPS asks for version and when I say 4.6 it won't let me 😞 Not sure if you have to simply add something on the ips side? Definitely not urgent!!

Link to comment
Share on other sites

9 minutes ago, Giray said:

Hi Adriano,

Before figuring out that the TFA problem was on Invision's side, I made the stupid mistake of trying to debug and uninstalled your TFA masking plugin. The problem is that now when I go to install it again, IPS asks for version and when I say 4.6 it won't let me 😞 Not sure if you have to simply add something on the ips side? Definitely not urgent!!

Sorry @Giray, I don't have any of my free plugins, as I didn't keep them. As we, as developers, can't download not even our own files, this (and all other free or paid from TheJackal84) are now unsupported.

Link to comment
Share on other sites

@Giray, you can make a template edit to accomplish that. Edit your theme and open the core -> global -> login -> securityQuestionsAuth template and find:

<input type="text" name="security_answer" autocomplete="off" {{if request.security_answer}}class="ipsField_error"{{endif}}>

And change to:

<input type="password" name="security_answer" autocomplete="off" {{if request.security_answer}}class="ipsField_error"{{endif}}>

 

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...