Jump to content

Community

Navigation issues using 4.6 PWA on iPhone


Recommended Posts

I tried using the PWA for this site (running the latest 4.6 beta) on my iPhone.

The biggest issue is no BACK button is available in the PWA.

Please consider adding a true BACK button in the navigation header that returns to the same position in the topic listing that you used to view the topic.

The current navigation header "back" button simply goes to the first page of the topic listing (even if the topic being viewed is in the second or subsequent pages of the topic listing).

Another related problem is that when you read a long topic, you have to scroll either all the way back to the top or use the link to the topic listing all the way to the bottom of the page. Even then, it always takes you back to the first page of the topic listing so you have to find your position in the topic listing again (maybe by navigating to subsequent pages in the topic listing).

The browser's BACK button is what is really needed in the PWA. Since Safari doesn't add BACK/FORWARD buttons when in a PWA, it is up to the PWA to have a true BACK button on the page being viewed.

I suggest changing the current navigation header back button into a true BACK button in the PWA (at least for iOS) and pinning the navigation header bar to the top of the viewport (using "absolute" CSS positioning). This would allow easy navigation regardless of how far down in the page you have scrolled.

If the HTTP_REFERER is not the topic listing page, change the current navigation header button to go to the first page of the topic listing.

If you choose to not make the navigation header button a true BACK button outside the PWA (for iOS), you should make sure the navigation header button has the correct page # in the link so you at least return to the page that contains the topic shown in the viewport. Would be nice to scroll to the topic in the topic list by using #topicid in the link (or other way to simulate the effects of not using the browser's BACK button.

Anyway, this is the biggest problem I see in encouraging my users to "Add to Home Screen" and visiting my site in the PWA. This issue should be fairly easy to fix in the 4.6 default theme.

Link to comment
Share on other sites

Posted (edited)

For me, the "Back" button works the same as before.

Try to change display mode to "Full screen"

ACP > Customization > Icons & Logos > Display mode

Edited by SeNioR-
Link to comment
Share on other sites

On 6/5/2021 at 10:57 AM, SeNioR- said:

For me, the "Back" button works the same as before.

Try to change display mode to "Full screen"

ACP > Customization > Icons & Logos > Display mode

I am using the PWA on this site. Apple does not support a back button when in a PWA. So the app must provide this navigation control on each page in the PWA. 

I don’t have Android to test, but it is my understanding that Google supports back button in PWAs. 
 

So It is up to IPS to provide a back button in IC if the PWA is to be as good as when in Safari on iOS. 

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy