Jump to content

Community

Error code: EX0 when trying to upload a file in a club


USS
 Share

Recommended Posts

Hi there,

we're having an issue where when users try to upload a file in a club using the files feature, they receive this nondescript message:

image.png.1452edbf9dced8366376dfb5885ee0f9.png

Looking at the system log, it tells us:

InvalidArgumentException:  (0)
#0 /var/www/html/applications/downloads/modules/front/downloads/submit.php(147): IPS\Helpers\Form\_Upload->__construct()
#1 /var/www/html/system/Helpers/Wizard/Wizard.php(181): IPS\downloads\modules\front\downloads\_submit->IPS\downloads\modules\front\downloads\{closure}()
#2 /var/www/html/applications/downloads/modules/front/downloads/submit.php(681): IPS\Helpers\_Wizard->__toString()
#3 /var/www/html/system/Dispatcher/Controller.php(90): IPS\downloads\modules\front\downloads\_submit->submit()
#4 /var/www/html/applications/downloads/modules/front/downloads/submit.php(35): IPS\Dispatcher\_Controller->execute()
#5 /var/www/html/system/Dispatcher/Dispatcher.php(152): IPS\downloads\modules\front\downloads\_submit->execute()
#6 /var/www/html/index.php(13): IPS\_Dispatcher->run()
#7 {main}

Uploading in the regular files categories outside the clubs works fine for the users.

Uploading inside the club as an Admin also works - just not as the users.

Any ideas?

Thank you.

Link to comment
Share on other sites

Does anyone have a hint as to where to look? Why can't users upload files in clubs but in regular downloads categories?

Thank you.

Link to comment
Share on other sites

Is this 4.6 or 4.5? I remember that I fixed here few bugs for 4.6.
Could you please review ALL your groups and ensure that they have valid max.upload file size values. This MAY help, if not you'll have to wait for 4.6

Link to comment
Share on other sites

Thank you @Daniel F. It is 4.5.

Looking at one of the users who receive this error, the attachment quote looks good.

image.png.b666579c07dcb81e4cf196740f802ed8.png

And within the group settings for uploads, it's not limited. All set to "unlimited" or "no restriction". So it doesn't seem to be a quote issue.

Can you guys maybe provide a hotfix as we are using it in a production environment? Thank you.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy