Jump to content

File upload problem with a DomainException (6)

Go to solution Solved by Stuart Silvester,

Recommended Posts


we have a self-hosted Invision Community that is not yet publicly available. At first glance, everything is working just fine there are no visible errors. We can add users, create posts and install plugins from the marketplace. Both system and error logs are not showing any exceptions. The problem is that, there is no way to upload any file, for example with the AdminCP, on the Appearance customization (Icons & Logos /admin/?app=core&module=customization&controller=icons) or Site promotion (Edit Advertisement admin/?app=core&module=promotion&controller=advertisements&do=form&id=1) or just when user is trying to upload file to his post - for any type (.jpg, .png, .zip), size (for example 5 KB logo) or dimension of graphic there is an error of:


Sorry, an unknown server error occurred when uploading this file. Please contact us for assistance.

In the System log, there is an entry with a type of upload_failure, a message of DomainException (6) SERVER_CONFIGURATION and a backtrace of:

#0 /srv/www/ispforum/wwwroot/system/File/File.php(404): IPS\_File::validateUpload(Array, Array, NULL)
#1 /srv/www/ispforum/wwwroot/system/Helpers/Form/Upload.php(751): IPS\_File::createFromUploads('core_Icons', NULL, Array, NULL, NULL, 0, Object(Closure), NULL, true)
#2 /srv/www/ispforum/wwwroot/system/Helpers/Form/Upload.php(311): IPS\Helpers\Form\_Upload->processUploads()
#3 /srv/www/ispforum/wwwroot/applications/core/modules/admin/customization/icons.php(55): IPS\Helpers\Form\_Upload->__construct('icons_sharer_lo...', Array, false, Array)
#4 /srv/www/ispforum/wwwroot/system/Dispatcher/Controller.php(101): IPS\core\modules\admin\customization\_icons->manage()
#5 /srv/www/ispforum/wwwroot/applications/core/modules/admin/customization/icons.php(38): IPS\Dispatcher\_Controller->execute()
#6 /srv/www/ispforum/wwwroot/system/Dispatcher/Dispatcher.php(152): IPS\core\modules\admin\customization\_icons->execute()
#7 /srv/www/ispforum/wwwroot/admin/index.php(14): IPS\_Dispatcher->run()
#8 {main}

We used to have an older version of Invision Community (from like a year ago), but recently we made an update for the newest one - v4.5.4.2. On both versions, there is the same problem. We thought that it somehow might be a permission problem, and we even tried to give recursively full 777 permissions in the folder of Invision Community, but it changed nothing.

Our System check is also all green with:

PHP Requirements

•  PHP version 7.3.27-1~deb10u1.

•  cURL extension loaded.

•  Multibyte String extension loaded

•  DOM extension loaded

•  GD extension loaded

•  MySQLi extension loaded

•  OpenSSL extension loaded

•  Session extension loaded

•  SimpleXML extension loaded

•  XML extension loaded

•  XMLReader extension loaded

•  XMLWriter extension loaded

•  Phar extension loaded

•  Zip extension loaded

•  Exif extension loaded

•  128 MB memory limit.

File System Requirements

•  /srv/www/ispforum/wwwroot/applications is writable

•  /srv/www/ispforum/wwwroot/datastore is writable

•  /srv/www/ispforum/wwwroot/plugins is writable

•  /srv/www/ispforum/wwwroot/uploads is writable

•  /srv/www/ispforum/wwwroot/uploads/logs is writable

MySQL Requirements

•  MySQL version 5.5.5-10.3.27-MariaDB-0+deb10u1.


Is there any setting on the server or directly in the Invision Community application that we could check?

Link to comment
Share on other sites

  • Solution

A SERVER_CONFIGURATION error suggests that PHP is triggering the error because of a PHP extension issue:


Value: 8; A PHP extension stopped the file upload. PHP does not provide a way to ascertain which extension caused the file upload to stop; examining the list of loaded extensions with phpinfo() may help. Introduced in PHP 5.2.0.


Link to comment
Share on other sites

  • 10 months later...
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...