Jump to content

Community

Better Forum Icons


Recommended Posts

Can we get support for Font Awesome instead of png/jpg graphics for forum icons? 

If not, can we get support for SVG to upload Font Awesome icons instead of  solely raster graphics?

There is one mod out there do this, but it only supports up to FA4. 

Edited by kotaco
Link to comment
Share on other sites

It is ridiculous to give 15 euros for something that should have been part of the basic installation a long time ago.

 

For me, this plugin is one of the another one. Which are expensive, even if would by are free.

 

Edited by Zdeněk Tůma
Link to comment
Share on other sites

Posted (edited)
2 hours ago, Morrigan said:

 

Or use CSS to change out the font awesome Icons.

 

I already mentioned that mod in the OP. That mod doesn't work well anymore. It only supports Font Awesome 4, and isn't guaranteed to work if the mod is used on a custom themed forum. 

The goal is user friendly switches. Not custom CSS fixes. I am capable of doing a lot of things with CSS, but for user experience, this shouldn't be one of them. 

Edited by kotaco
Link to comment
Share on other sites

On 3/14/2021 at 4:40 AM, kotaco said:

I already mentioned that mod in the OP. That mod doesn't work well anymore. It only supports Font Awesome 4, and isn't guaranteed to work if the mod is used on a custom themed forum. 

The goal is user friendly switches. Not custom CSS fixes. I am capable of doing a lot of things with CSS, but for user experience, this shouldn't be one of them. 

Hey there. What kind of icons would you like to incorporate? 

Link to comment
Share on other sites

Posted (edited)
2 hours ago, Jordan Invision said:

Hey there. What kind of icons would you like to incorporate? 

I'm rooting for Font Awesome 5 integration.

For example:

  • fa-comments (as seen here)
  • fa-tools
  • fa-cog or fa-fogs
  • fa-question / fa-question-circle
  • fa-life-ring

But there are too many to list and every community is different in their selections. If it is too difficult to integrate something that would allow us to select an icon, enabling .svg uploads of icons (which are provided by Font Awesome for free) would allow for an easy compromise. 

Edited by kotaco
Link to comment
Share on other sites

On 3/14/2021 at 7:40 AM, kotaco said:

I already mentioned that mod in the OP. That mod doesn't work well anymore. It only supports Font Awesome 4, and isn't guaranteed to work if the mod is used on a custom themed forum. 

The goal is user friendly switches. Not custom CSS fixes. I am capable of doing a lot of things with CSS, but for user experience, this shouldn't be one of them. 

While I can't guarantee the mod will work on all third-party themes, it should work without issue on most themes that do not significantly modify the core layout of the forum index, and it is fully compatible with the latest IPS release.

Any themes that drastically alter the way templates are structured risk breaking compatibility with not only my plugin but others as well. That's unfortunately not something I can control.

Regarding support for newer versions of Font Awesome, the reason it only supports FA4 is because that is the version currently bundled with IPS. Generally, I'd prefer waiting for IPS to update this library themselves, but I can look into providing an option to replace FA4 with newer versions.

Edited by Makoto
Link to comment
Share on other sites

On 3/14/2021 at 7:32 AM, Zdeněk Tůma said:

It is ridiculous to give 15 euros for something that should have been part of the basic installation a long time ago.

 

For me, this plugin is one of the another one. Which are expensive, even if would by are free.

 

Add this to your custom.css replacing forumid with the ID of the category, and content with the unicode value of the icon you want. You can find the ID by hovering over the link:

ScreenShot_20210316050237.thumb.png.850651569b3ea3684e6959f159e0a7b5.png

ScreenShot_20210316050443.thumb.png.003cc4850d3b030ecc4432aefb8f7a1d.png

 

[data-forumid="12"] .fa-comments:before {
  content: "\f3ed";
  font-family: 'FONT AWESOME 5 FREE';
}

^ Copy and paste the block per category replacing the forumid

 

@Makoto's plugin will make this a lot simpler if you're willing to spend the $15 for it, which honestly isn't that bad.

Edited by Deathicated
Link to comment
Share on other sites

5 hours ago, Deathicated said:

Add this to your custom.css replacing forumid with the ID of the category, and content with the unicode value of the icon you want. You can find the ID by hovering over the link:

ScreenShot_20210316050237.thumb.png.850651569b3ea3684e6959f159e0a7b5.png

ScreenShot_20210316050443.thumb.png.003cc4850d3b030ecc4432aefb8f7a1d.png

 


[data-forumid="12"] .fa-comments:before {
  content: "\f3ed";
  font-family: 'FONT AWESOME 5 FREE';
}

^ Copy and paste the block per category replacing the forumid

 

@Makoto's plugin will make this a lot simpler if you're willing to spend the $15 for it, which honestly isn't that bad.

Ahh you know what I remember doing this a year or two ago on my own forums - totally forgot about it! I remember at the time I could only use font awesome codes that started with "f0" for some reason. 

Link to comment
Share on other sites

5 hours ago, Jordan Invision said:

Ahh you know what I remember doing this a year or two ago on my own forums - totally forgot about it! I remember at the time I could only use font awesome codes that started with "f0" for some reason. 

You can change the font-family to use newer or older versions of font awesome 😛

Link to comment
Share on other sites

20 hours ago, Makoto said:

While I can't guarantee the mod will work on all third-party themes, it should work without issue on most themes that do not significantly modify the core layout of the forum index, and it is fully compatible with the latest IPS release.

Any themes that drastically alter the way templates are structured risk breaking compatibility with not only my plugin but others as well. That's unfortunately not something I can control.

Regarding support for newer versions of Font Awesome, the reason it only supports FA4 is because that is the version currently bundled with IPS. Generally, I'd prefer waiting for IPS to update this library themselves, but I can look into providing an option to replace FA4 with newer versions.

I appreciate your work on that, and my issue isn't with your mod at all. It's more so that I really believe that this is something that should natively be a part of the IPS forum settings without requiring custom CSS replacements or a third-party modification.  🙂

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy