Jump to content

Must Read Topics - a.k.a Force Members/Guests to Read Topics


Miss_B
 Share

Recommended Posts

Thanks for creating such a nice application. I was wondering whether the error style that forces the user to read a specific post could be customized.

I mean, the error looks like an error and not a suggestion prompting the user gently to read a specific post. Both the error and the link to the post to be read are the same, and it looks like an error and not a suggestion. I've not purchased it because of that, I saw the screenshots and the suggestions to force read the post looks like an error and it's confusing. I hope you understand what I am trying to say.

Look at the attachment. 1 is the title of the post I have to read I guess, it's the same style as "You must read this topic".... error. same color, same font size, it's not hyperlinked. To me it's very very confusing.

Thanks

image.thumb.png.ee4b2478bd88fb3cf1843feb82e097e4.png

Link to comment
Share on other sites

21 minutes ago, Alfonso Moreno said:

Thanks for creating such a nice application. I was wondering whether the error style that forces the user to read a specific post could be customized.

I mean, the error looks like an error and not a suggestion prompting the user gently to read a specific post. Both the error and the link to the post to be read are the same, and it looks like an error and not a suggestion. I've not purchased it because of that, I saw the screenshots and the suggestions to force read the post looks like an error and it's confusing. I hope you understand what I am trying to say.

Look at the attachment. 1 is the title of the post I have to read I guess, it's the same style as "You must read this topic".... error. same color, same font size, it's not hyperlinked. To me it's very very confusing.

Thanks

image.thumb.png.ee4b2478bd88fb3cf1843feb82e097e4.png

 

Hi. This app does not suggest to members to read a topic, but instead it sets a topic as must read and members will get an error when trying to enter the forums and the other topics informing them of that fact. i.e. it will force your members to read the topic set by the amdin as must read.

The error message you see is the standard one added by the app. It can be customized. You can use html should you wish to do so. Please see the attached screenshot. (The field that says: Error Message).

4acp.thumb.png.f7469acd6c0b1c0c55bdc4b1ee41ce55.png

Link to comment
Share on other sites

Good day,

I've just purchased the plugin and I'm experiencing a problem with the guests options.

I do not want to force Guests to read any topic. But the application is forcing me to force Guests to read a topic and won’t let me save settings. See attachment. How can this be fixed? I do not want to force guests to read any topic, just a certain group under certain circumstances. The Force Guests toggle is off and the must read topic is required, that shouldn't happen. 

Can you please help? Thanks a lot

image.thumb.png.311228b600f656342c42b08c1ed7b1a8.png 

Link to comment
Share on other sites

8 minutes ago, Alfonso Moreno said:

Good day,

I've just purchased the plugin and I'm experiencing a problem with the guests options.

I do not want to force Guests to read any topic. But the application is forcing me to force Guests to read a topic and won’t let me save settings. See attachment. How can this be fixed? I do not want to force guests to read any topic, just a certain group under certain circumstances. The Force Guests toggle is off and the must read topic is required, that shouldn't happen. 

Can you please help? Thanks a lot

image.thumb.png.311228b600f656342c42b08c1ed7b1a8.png 

Thank you for reporting it. I will make that option as not required and release a new version soon. In meanwhile, you can enter a topic name for guests, it will not run as long as Force Topic Reading for Guests option is disabled.

Edited by Miss_B
Link to comment
Share on other sites

2 minutes ago, Miss_B said:

Thank you for reporting it. I will make that option as not require and release a new version soon. In meanwhile, you can enter a topic name for guests, it will not run as long as Force Topic Reading for Guests is disabled.

Thanks a lot. I've done what you have suggested and the settings were saved, but the plugin will not work.

I am the administrator, so I’ve not excluded myself to see if I am forced to read the must-read post that I've selected. Nothing happens. I can browse the site. I have logged out and in and I can move around the site without being forced to read the post I selected.

I understand that if I force to read a post, anything I do on the site will redirect me to that post and won't let me do anything else until I read it, doesn't it? If that is so, then it doesn't work for me because I was not forced to do anything 😞 😞

image.thumb.png.71b33ff4c6527ff6dcbf24007127e82d.png

Link to comment
Share on other sites

5 minutes ago, Alfonso Moreno said:

Thanks a lot. I've done what you have suggested and the settings were saved, but the plugin will not work.

I am the administrator, so I’ve not excluded myself to see if I am forced to read the must-read post that I've selected. Nothing happens. I can browse the site. I have logged out and in and I can move around the site without being forced to read the post I selected.

I understand that if I force to read a post, anything I do on the site will redirect me to that post and won't let me do anything else until I read it, doesn't it? If that is so, then it doesn't work for me because I was not forced to do anything 😞 😞

image.thumb.png.71b33ff4c6527ff6dcbf24007127e82d.png

 

Are you the topic starter of the topic that you have set as must read? Because if you are, you are excluded automatically as there is no point to force members to read their own topics. 

Link to comment
Share on other sites

4 minutes ago, Miss_B said:

Are you the topic starter of the topic that you have set as must read? Because if you are, you are excluded automatically as there is no point to force members to read their own topics. 

Yes, I actually am the topic starter. I am the only one in the forum right now as I am configuring everything before it's launched. I will log in with a dummy user and see if it works. It would help to add a tooltip in the settings that say something like "Topic starters will not be excluded."

Link to comment
Share on other sites

1 hour ago, Alfonso Moreno said:

Now it works. I tried it with a normal user and I'm forced to read the post. Thanks a lot. Look forward to seeing the fix for the guest users whenever you have the time. Thanks for such a great plugin. 

You are very welcome :) I just submited a new version with the fix btw. I have also implemented your suggestion about adding in the settings the text that the topic authors will be excluded automatically from being forced to read their own topics. 

Link to comment
Share on other sites

3 minutes ago, Miss_B said:

You are very welcome 🙂I just submited a new version with the fix btw. I have also implemented your suggestion about adding in the settings the text that the topic authors will be excluded automatically from being forced to read their own topics. 

Awesome! Thanks so much! Hope others will download this great plugin of yours! Have a nice weekend! 

Link to comment
Share on other sites

  • 2 months later...
On 2/6/2021 at 3:16 PM, OptimusBain said:

Now it works. I tried it with a normal user and I'm forced to read the post.

It's wise for an Administrator to have a dummy account as a normal member.

It helps me, when members report a problem, to log in with that account so I can check what they reported.

Link to comment
Share on other sites

  • 3 months later...
  • 1 month later...

Not working for me. On 4.6, installed it twice. Anytime I activate it, everyone gets a page error that states "Oops something went wrong, please try again"
It is not the message to read a post, as no post is even set yet. It just gives an error for every post they visit, except anyone excluded in the settings.
Any idea why they are getting this error even without a post set yet until I deactivate the plugin?

Link to comment
Share on other sites

  • 1 month later...
2 hours ago, livegames.co.il said:

Hello, 

Imminently After installing the app, my main forum crashed. please advise. @Miss_B 

The issue is that My main forum showed this message:

image.png.dc323be20b294ac803b2267f04fe6a47.png

Using Invision Community v4.6.7 and 1.0.2 (10002)

Can you please pm me your forum url with an account login info and I will look into this a.s.a.p.

Link to comment
Share on other sites

  • 3 weeks later...
On 10/30/2021 at 10:04 AM, livegames.co.il said:

Imminently After installing the app, my main forum crashed.

The same thing happened on my forum last night after updating to the newest 1.0.2 version.
Only the main page was showing all section pages returned the following error:
OutOfRangeException:  (0)
#0 C:\inetpub\vhosts\forum-andr.net\httpdocs\init.php(902) : eval()'d code(31): IPS\Patterns\_ActiveRecord::load()
#1 C:\inetpub\vhosts\forum-andr.net\httpdocs\system\Dispatcher\Controller.php(101): IPS\forums\modules\front\forums\readthistopic_hook_forcetopicforums->manage()
#2 C:\inetpub\vhosts\forum-andr.net\httpdocs\system\Dispatcher\Dispatcher.php(153): IPS\Dispatcher\_Controller->execute()
#3 C:\inetpub\vhosts\forum-andr.net\httpdocs\index.php(13): IPS\_Dispatcher->run()
#4 {main}

Strange is that the personal message was still functioning.
After disabling the plugin, all returned to normal. Could you please check it? Your login and PWD remained the same.
I'm on v4.6.8 of the forum software.

Edited by Eric BXL
Link to comment
Share on other sites

On 11/18/2021 at 10:01 AM, Eric BXL said:

The same thing happened on my forum last night after updating to the newest 1.0.2 version.
Only the main page was showing all section pages returned the following error:
OutOfRangeException:  (0)
#0 C:\inetpub\vhosts\forum-andr.net\httpdocs\init.php(902) : eval()'d code(31): IPS\Patterns\_ActiveRecord::load()
#1 C:\inetpub\vhosts\forum-andr.net\httpdocs\system\Dispatcher\Controller.php(101): IPS\forums\modules\front\forums\readthistopic_hook_forcetopicforums->manage()
#2 C:\inetpub\vhosts\forum-andr.net\httpdocs\system\Dispatcher\Dispatcher.php(153): IPS\Dispatcher\_Controller->execute()
#3 C:\inetpub\vhosts\forum-andr.net\httpdocs\index.php(13): IPS\_Dispatcher->run()
#4 {main}

Strange is that the personal message was still functioning.
After disabling the plugin, all returned to normal. Could you please check it? Your login and PWD remained the same.
I'm on v4.6.8 of the forum software.

Yup same happened to me as well.

Link to comment
Share on other sites

On 11/19/2021 at 9:24 PM, Iyda said:

Yup same happened to me as well.

 

On 11/19/2021 at 10:17 PM, livegames.co.il said:

 @Miss_B we all need a fix for it. 

 

On 11/18/2021 at 11:01 AM, Eric BXL said:

The same thing happened on my forum last night after updating to the newest 1.0.2 version.
Only the main page was showing all section pages returned the following error:
OutOfRangeException:  (0)
#0 C:\inetpub\vhosts\forum-andr.net\httpdocs\init.php(902) : eval()'d code(31): IPS\Patterns\_ActiveRecord::load()
#1 C:\inetpub\vhosts\forum-andr.net\httpdocs\system\Dispatcher\Controller.php(101): IPS\forums\modules\front\forums\readthistopic_hook_forcetopicforums->manage()
#2 C:\inetpub\vhosts\forum-andr.net\httpdocs\system\Dispatcher\Dispatcher.php(153): IPS\Dispatcher\_Controller->execute()
#3 C:\inetpub\vhosts\forum-andr.net\httpdocs\index.php(13): IPS\_Dispatcher->run()
#4 {main}

Strange is that the personal message was still functioning.
After disabling the plugin, all returned to normal. Could you please check it? Your login and PWD remained the same.
I'm on v4.6.8 of the forum software.

The issue has been fixed and a new version has been uploaded. Thank you for reporting the issue. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...