Jump to content

Code doesn't execute if I turn off dev mode

Go to solution Solved by bfarber,

Recommended Posts

Here is my problem. sitemap generator task for IPS execute this function.


This function has this statement $extension->getFilenames(). which points to applications\cms\extensions\core\Sitemap\Databases.php:getFilenames()

But the problem is this function (Databases.php:getFilenames()) never executes (I tried adding breakpoint), and IPS instead returns a old cached result of the function. As soon as I turn on dev mode, this function start executing and uncached result returns.

How do I clear all the caching or regenerate the cache so that returned output of the function is latest.

IPS version:  v4.5.4.2

Caching method: Filesystem only (I already deleted datastore directory as well as rebooting the system, and also clearing cache in support page several times)

Edited by VarunAgw
Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...