Jump to content

Forbidden You don't have permission to access this resource.


SC36DC
 Share

Go to solution Solved by bfarber,

Recommended Posts

On my forum, when I or any other member clicks on the Downloads item in the menu, the following message comes up,

 

Forbidden

You don't have permission to access this resource.
Apache/2.4.25 (Debian) Server at www.(site name).com Port 80

Would anyone know what would cause this to show up? 

Thanks.

Link to comment
Share on other sites

10 minutes ago, Jock3r said:

What Adriano sent above is most probably what is wrong. Do you mind sending us your apache config?

Where is this file located?

I just contacted Cloudways support, thought it was a htaccess file issue, they had this to say:
 

Quote

It seems like there is some application level restriction set from somewhere within the file, Please note that this is something beyond our standard support scope and reason behind is that we are not familiar with your application functionality at all, I would suggest you to contact your developer and ask him to check it for you, I hope you understand it.

The only thing I did yesterday to my overall forum, as far as changes, was enable 'Rewrite URLs'. I had add the '.htaccess' file that is there to download, and added it to my forum on the server, is it possible I placed the file in the wrong location? Where should it be placed?

The rewrite of the urls did work though.

 


 

Link to comment
Share on other sites

Your apache config is probably located here /etc/apache2/apache2.conf

Was downloads application working fine prior to you enabling rewrite urls? The .htaccess file must be placed on the main directory of the forum

Link to comment
Share on other sites

2 minutes ago, Jock3r said:

Your apache config is probably located here /etc/apache2/apache2.conf

Was downloads application working fine prior to you enabling rewrite urls? The .htaccess file must be placed on the main directory of the forum

I placed the file in the main directory of my forum, not the main directory of the server, my website.

Link to comment
Share on other sites

Just now, SC36DC said:

I placed the file in the main directory of my forum, not the main directory of the server, my website.

Yeah, that was precisely what I meant. Please provide the apache config whenever you can as well so we can assist you further.

Link to comment
Share on other sites

4 minutes ago, Jock3r said:

Uhm, is it a managed server or do you do everything on your own? Managed means that the VPS/Dedicated Server you have is managed by employees of your hosting.

Cloudways is managed, yes. 

https://www.cloudways.com/en/apache-hosting.php

The thing is, my Downloads section was working just fine, until someone today messaged to let me know they couldn't access it.



 

Link to comment
Share on other sites

19 minutes ago, Morrigan said:

You enabled re-write URLS and that's what caused this?

If you remove the htaccess and turn it off does it work again?

I tried it, and no, it does not work again.

Link to comment
Share on other sites

  • Solution

Downloads uses the friendly URL path of "/files". Do you happen to have an actual folder on your server named "files"? If so, Apache would route the request to that folder and the request would never make it to our software - the solution would be to rename that folder to something else.

Link to comment
Share on other sites

9 hours ago, bfarber said:

Downloads uses the friendly URL path of "/files". Do you happen to have an actual folder on your server named "files"? If so, Apache would route the request to that folder and the request would never make it to our software - the solution would be to rename that folder to something else.

Yes, the folder on my server was named 'files', I changed it to 'downloads', it is working again. Thanks @bfarber for the help.

Link to comment
Share on other sites

  • 7 months later...
On 1/5/2021 at 9:20 AM, bfarber said:

Downloads uses the friendly URL path of "/files". Do you happen to have an actual folder on your server named "files"? If so, Apache would route the request to that folder and the request would never make it to our software - the solution would be to rename that folder to something else.

Bingo! I had a related issue with an old app that I moved out of the folder as a copy. I would have never figured this out.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy