Jump to content

Community

ipad still supported ?


bearback
 Share

Recommended Posts

Hi

since upgrading my forum to 4.5.4 the forum on ipad no longer works correctly and cannot post replies  or create new topics.  

Testing on invisioncommunity  forum has the same results, tried with safari, chrome, edge but all the same.

Top right menu does not work, reply to this topic - you cannot get the editor to work (expand or open)

Reply at the bottom of the posts, editor will not expand or open. 

Quote button is missing aswell

Is there any fix for the issue as users cannot use the forum using ipad ☹️

1009.thumb.png.8a34cdbbdf9b5475aa52161c3101246d.png1008.thumb.png.950402796962d2e6f2402fab7420685b.png

 

Edited by bearback
Link to comment
Share on other sites

6 minutes ago, Morrigan said:

Try clearing your site cache. Most issues like that are resolved by doing so:

Support > Something isn't working correctly

@bearback

I did that when i first noticed the problem but Its the same on this forum so will make no difference.

cleared browser cache also

Thank you for your reply though

Link to comment
Share on other sites

3 hours ago, bearback said:

Tried with safari, chrome, edge and firefox all the same. would have thought edge would have worked.

FYI, on iOS (iPhone, iPad), all web browsers use Apple's WebKit as the rendering engine. See 2.5.6: https://developer.apple.com/app-store/review/guidelines/#software-requirements

Quote

2.5.6 Apps that browse the web must use the appropriate WebKit framework and WebKit Javascript.

 

Link to comment
Share on other sites

We have this problem at my forum, too.  Multiple users are reporting it on desktop and mobile. 

I've had it happen to me in both Safari 14.0.1 and Firefox 83.0 on macOS 10.15.7.  Sometimes reloading the page helps.  Often, not.

My users tell me it also happens in Chrome on Windows, but I don't have specific version numbers for those.

It's not confined to the forum.  The problem crops up in the ACP, too.  

While I don't know anything about how IPS works, it looks to me like sometimes clicking on a text field fails to load the rich text editor.

Here you can see the text box has been clicked because Safari highlights it, but the text editor does't load:

1680030104_ScreenShot2020-12-19at1_30.15PMPacificStandardTime.png.17284a5be075041917ea729dfc0833d4.png

Here's what the console log shows:

87078986_ScreenShot2020-12-19at1_30.58PMPacificStandardTime.thumb.png.b8c9e42fca1ad7e3665d95b50c4fe0da.png

Link to comment
Share on other sites

That 404 error in your screenshot is just for a favicon.ico call. You can ignore that. Presumably you don't have a favicon.ico in the root of your domain, which is only used for an icon when saving as a bookmark, etc.

That would not impact the editor from loading.

Now the undefined method two lines above on commonEmbedHandler.js might be something else.

Link to comment
Share on other sites

On 12/17/2020 at 3:44 AM, bearback said:

not sure on my other users but mine is 9.3.5 which i know is old but worked fine before the update.

just summited a support ticket

Going to be an issue if iOS9 is the latest the device supports. Your users are on nearly decade old hardware at this point

 

Link to comment
Share on other sites

I have just purchased a new ipad pro and run the latest pc and laptop, so no problem for my self.

From feedback i receive, not everyone has the funding to replace old devices and are stuck with there outdated devices.  i have no answers for these users.

Understandably software developers have got to draw the line somewhere and cannot be expected to support old devices.

 

Link to comment
Share on other sites

On 12/19/2020 at 4:32 PM, HAIF said:

We have this problem at my forum, too.  Multiple users are reporting it on desktop and mobile. 

I've had it happen to me in both Safari 14.0.1 and Firefox 83.0 on macOS 10.15.7.  Sometimes reloading the page helps.  Often, not.

My users tell me it also happens in Chrome on Windows, but I don't have specific version numbers for those.

It's not confined to the forum.  The problem crops up in the ACP, too.  

While I don't know anything about how IPS works, it looks to me like sometimes clicking on a text field fails to load the rich text editor.

Here you can see the text box has been clicked because Safari highlights it, but the text editor does't load:

1680030104_ScreenShot2020-12-19at1_30.15PMPacificStandardTime.png.17284a5be075041917ea729dfc0833d4.png

Here's what the console log shows:

87078986_ScreenShot2020-12-19at1_30.58PMPacificStandardTime.thumb.png.b8c9e42fca1ad7e3665d95b50c4fe0da.png

You are experiencing a different issue than the one reported here and I would encourage you to submit a ticket for support.

Link to comment
Share on other sites

18 hours ago, bearback said:

I have just purchased a new ipad pro and run the latest pc and laptop, so no problem for my self.

From feedback i receive, not everyone has the funding to replace old devices and are stuck with there outdated devices.  i have no answers for these users.

Understandably software developers have got to draw the line somewhere and cannot be expected to support old devices.

 

I mean I have an old iPad. I think its about 6+ years old. I don't have the problem on my sites. I know because I was using my iPad exclusively for the past two weeks.

I use Chrome and all of my sites are on 4.5.

If this worked:

On 12/18/2020 at 2:12 AM, bearback said:

yes it does,  Think its more of a JavaScript problem.

Thank you   

Like you said it did then the problem isn't the iPad but the site in question isn't loading something properly.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy