Jump to content

Need help configured Redis extension (Centos Web Panel)


Cach Doan
 Share

Recommended Posts

Hi

I've done every step needed to be done in order to enable Redis server and Redis PHP extension on my server. However, the option is still grey-out. I am not sure what's I am missing?
I am using Centos Web Panel to host this.

I am using nginx -> apache -> php-fpm (version 7.4) as my web server.
I have set my Php-fpm 7.4 settings to enable redis extension.  

I have already restarted the redis service and also restart PHP. yet this option is still grey-out.

Screenshot of grey-out Redis option:

chrome-12-14-2020-HN8.thumb.png.75e7489d0092b5b65c2f1760fcd3b51e.png

 


 

 

 

 

chrome-12-14-2020-q9f.png

Edited by Cach Doan
Link to comment
Share on other sites

3 minutes ago, Edjazoli said:

Have you added constant.php to your public.HTML. everytime you changing anything you need to update them.

I need first to select the Redis Cache option first , then I click save, then it ask me to download constant.php, 

However, if I don't select Redis first, and just click save, and download the constant.php and upload it to the root directory of IPB, then nothing really happens.

I can't click on the Redis option because it's grey-out.

Link to comment
Share on other sites

2 minutes ago, Cach Doan said:

I need first to select the Redis Cache option first , then I click save, then it ask me to download constant.php, 

However, if I don't select Redis first, and just click save, and download the constant.php and upload it to the root directory of IPB, then nothing really happens.

I can't click on the Redis option because it's grey-out.

Reboot your server and check again, sometimes ips does not see it till after reboot.

Link to comment
Share on other sites

You have to install Redis on the server, then the Redis PHP extension into PHP, and then depending upon your server setup you may need to restart your webserver service (commonly Apache, although there are others). How you do this can vary depending upon the OS you are using and other factors.

You shouldn't need to reboot the physical server hardware though.

Link to comment
Share on other sites

The screenshot you provided seems to be a configuration sort of thing for php extensions. It looks like you selected the php extension for redis. As others remarked, you'll likely need to restart php-fpm and/or your web server process (i.e. apache/nginx/whatever it is you're using--probably apache).

You will also need to also install redis server. This is a separate install. The php-redis extension simply enables php to talk to redis, but doesn't put redis on your server. That's another step.

The way the text on the web page that you included in your screenshot is written is confusing. I had to read it a few times before realizing it didn't say it was also installing redis server. I would understand if you thought otherwise.

Link to comment
Share on other sites

  • 3 weeks later...
On 12/17/2020 at 7:44 PM, Paul E. said:

The screenshot you provided seems to be a configuration sort of thing for php extensions. It looks like you selected the php extension for redis. As others remarked, you'll likely need to restart php-fpm and/or your web server process (i.e. apache/nginx/whatever it is you're using--probably apache).

You will also need to also install redis server. This is a separate install. The php-redis extension simply enables php to talk to redis, but doesn't put redis on your server. That's another step.

The way the text on the web page that you included in your screenshot is written is confusing. I had to read it a few times before realizing it didn't say it was also installing redis server. I would understand if you thought otherwise.

Yeah I did installed the Redis server directly from SSH. - And I also enable it and verified it being active.

I guess I will just have to restart APACHE/NGINX once my site's traffic becomes lower at night time. Thank you for your help.

I would update in this topic again once it's resolved.

 

 

On 12/19/2020 at 2:11 PM, Jock3r said:

Also a friendly advise would be to try not to share your cpanel/admincp URLs publicly.

Thank you. I didn't realize this one is exposed. I will definitely delete the screenshot once the problem is resolve or not resolve within a few days right now.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...