Jump to content

Community

SSO Setup not working


Rhonda Britten
 Share

Go to solution Solved by Lucas James,

Recommended Posts

Our team is trying to set up Single Sign On (SSO) between WordPress LearnDash and Invision Community. We hired the Invision team to create the SSO, which they said they did. However it is not working and we are not able to get an answer on why from Support.

HAS ANYONE HAD INVISION SUCCESSFULLY SET UP SSO FOR THEM?

Maybe someone in this community can help a resolution.

Here is a video explaining how the site is not working and how we would like it to work - https://app.box.com/s/5ceoy2byf2yp36f268zeicok5foo7bfs 
We know that our example site uses a WordPress plug-in to accomplish SSO. We have been in other sites that do not use the WordPress plug-in and do work with SSO.

 

Link to comment
Share on other sites

On 11/11/2020 at 8:09 AM, Rhonda Britten said:

We hired the Invision team to create the SSO, which they said they did. However it is not working and we are not able to get an answer on why from Support.

I'd encourage you to escalate this with Invision, and review the Scope of Work for your engagement to see what the responsibilities of the developer were to complete the project. @Lindy or @Matt may be good people to ping to ensure your issue is not being missed. It may be that they delivered to you a working solution, yet you or your team have changed something outside of the agreed scope, or the environment was not configured per specifications. It may be that you agreed to this whole thing using a series of emojis scrawled on napkins for all I know though. Let's hope that's not the case.

As to why it's not working, it would only be stabs in the dark to try and sort that out. Invision should be able to point you as to where their responsibilities end, and with more information on what's left, you may be able to get someone to help sort out the remaining pieces. If it's an issue with your Wordpress installation, for example, or an issue at the web server or cookie domain level, that may be something that Invision can't or won't sort out and you'd need an expert in those domains to come and assist.

From your video, I see that you're expecting the SSO to work across various subdomains. you.fearlessliving.org vs. community.fearlessliving.org. If the login session is being set in a cookie at the subdomain level rather than at fearlessliving.org, that's a possible explanation for why things aren't working. Was that expectation communicated from the beginning of the engagement?

I imagine Invision has a good reputation with regard to custom work. We haven't personally engaged them, yet I'd be surprised if that weren't the case.

Link to comment
Share on other sites

I have WP SSO working on my WordPress site and it did involve setup assistance from my LiquidWeb Host support.

My Self-Hosted setup includes using the WP plugin User Role Manager to connect Registered WP users to the Invision WP SSO plugin.

You set up groups in User Role Manager based on the access or product you offer, also create those groups in the WP SSO plugin, and when WP gives access to the WP content, it also grants access and auto logs in the user to your community.

Link to comment
Share on other sites

  • 5 months later...

Does anyone know if the native SSO from WordPress to IPS will allow someone to login one time (to WP) and not have to login again to get to IPS?

If yes... will it work with IPS being on a subdomain?

 
Edited by David Sims
Link to comment
Share on other sites

7 minutes ago, David Sims said:

Does anyone know if the native SSO from WordPress to IPS will allow someone to login one time (to WP) and not have to login again to get to IPS?

If yes... will it work with IPS being on a subdomain?

Link to comment
Share on other sites

7 hours ago, David Sims said:

Does anyone know if the native SSO from WordPress to IPS will allow someone to login one time (to WP) and not have to login again to get to IPS?

If yes... will it work with IPS being on a subdomain?

 

I think, but am not sure, that you need a plugin.

Fortunately, there's one here:

From the description, it works so long as you use one domain (with subdomains). It also prevents duplicate logins. I've never used it, but it seems rather popular.

Apologies though... I see that it is only compatible up until 4.4. @stoo2000 may be able to assist.

Edited by CoffeeCake
Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy