Jump to content

Community

Anyone else scolded for using Plugins, Themes, etc?


Recommended Posts

I love Invision and their support is top-notch and I have been with them for years, but almost every time there is an issue, I am scolded and sometimes shamed for using plugins, applications, and themes. Almost always. There is rarely a reply of support that doesn't include a comment that is basically, "well, what did you expect since you are using plugins, applications, themes?" And often the support takes longer because the issue is immediately dismissed as a third-party issue. The irony is that in almost every case, it turns out it was not an issue with an application, plugin, or theme. I totally get that we have to troubleshoot and that it is practical to start with the assumption that it might be a third-party issue, but why are we even using these third-party resources if we are just going to be scolded for using them? I've asked the team the same question and they assure me that they are not scolding me, lol, but blaming third-parties over and over and telling me that I wouldn't have issues if I didn't use them, etc. just makes me wonder why we even have them. I am on the brink of disabling all themes and third party resources. 

Link to post
Share on other sites

I'm working on the ticket right now, but to be fair, according to your system log it's def. a 3rd party issue:

ArgumentCountError: Too few arguments to function IPS\core\modules\front\system\_register::_createMember(), 2 passed in /var/www/html/105119/init.php(893) : eval()'d code on line 26 and exactly 4 expected (0)
#0 /var/www/html/105119/init.php(893) : eval()'d code(26): IPS\core\modules\front\system\_register::_createMember(Array, Array)
#1 /var/www/html/105119/init.php(893) : eval()'d code(90): IPS\core\modules\front\system\hook1905::_createMember(Array, Array, NULL, Object(IPS\Helpers\Form))
#2 /var/www/html/105119/init.php(893) : eval()'d code(15): IPS\core\modules\front\system\hook2764::_createMember(Array, Array, NULL, Object(IPS\Helpers\Form))
#3 /var/www/html/105119/applications/core/modules/front/system/register.php(240): IPS\core\modules\front\system\hook2898::_createMember(Array, Array, NULL, Object(IPS\Helpers\Form))
#4 /var/www/html/105119/applications/core/modules/front/system/register.php(174): IPS\core\modules\front\system\_register->_registrationForm(NULL)
#5 /var/www/html/105119/system/Helpers/Wizard/Wizard.php(181): IPS\core\modules\front\system\_register->IPS\core\modules\front\system\{closure}(Array)
#6 /var/www/html/105119/applications/core/modules/front/system/register.php(181): IPS\Helpers\_Wizard->__toString()
#7 /var/www/html/105119/init.php(893) : eval()'d code(27): IPS\core\modules\front\system\_register->manage()
#8 /var/www/html/105119/system/Dispatcher/Controller.php(101): IPS\core\modules\front\system\nexus_hook_register->manage()
#9 /var/www/html/105119/system/Dispatcher/Dispatcher.php(152): IPS\Dispatcher\_Controller->execute()
#10 /var/www/html/105119/index.php(13): IPS\_Dispatcher->run()
#11 {main}

This error means literally that a plugin or application hooking the register::_createMember method is failing because it isn't compatible with IPS 4.5

Link to post
Share on other sites

If it's only passing two variables I'd be looking for a REALLY out of date plugin. Like a year or two at least. That third var (out of four) is the post before registering flag and that's been a thing for awhile now.

Also, to be fair, there are occasions where something breaks and hooks are in the error stack but it's not actually the hook that's the problem. In this case though, yes, a function is expecting four variables and it's getting only two, so it breaks.

Link to post
Share on other sites

To be fair, I am not talking about the current ticket. We were still troubleshooting. I was talking about a general tone and discouragement from using third-party resources. My main question is: should we consider disabling and removing all of them to avoid issues?

1 hour ago, Daniel F said:

I'm working on the ticket right now, but to be fair, according to your system log it's def. a 3rd party issue:


ArgumentCountError: Too few arguments to function IPS\core\modules\front\system\_register::_createMember(), 2 passed in /var/www/html/105119/init.php(893) : eval()'d code on line 26 and exactly 4 expected (0)
#0 /var/www/html/105119/init.php(893) : eval()'d code(26): IPS\core\modules\front\system\_register::_createMember(Array, Array)
#1 /var/www/html/105119/init.php(893) : eval()'d code(90): IPS\core\modules\front\system\hook1905::_createMember(Array, Array, NULL, Object(IPS\Helpers\Form))
#2 /var/www/html/105119/init.php(893) : eval()'d code(15): IPS\core\modules\front\system\hook2764::_createMember(Array, Array, NULL, Object(IPS\Helpers\Form))
#3 /var/www/html/105119/applications/core/modules/front/system/register.php(240): IPS\core\modules\front\system\hook2898::_createMember(Array, Array, NULL, Object(IPS\Helpers\Form))
#4 /var/www/html/105119/applications/core/modules/front/system/register.php(174): IPS\core\modules\front\system\_register->_registrationForm(NULL)
#5 /var/www/html/105119/system/Helpers/Wizard/Wizard.php(181): IPS\core\modules\front\system\_register->IPS\core\modules\front\system\{closure}(Array)
#6 /var/www/html/105119/applications/core/modules/front/system/register.php(181): IPS\Helpers\_Wizard->__toString()
#7 /var/www/html/105119/init.php(893) : eval()'d code(27): IPS\core\modules\front\system\_register->manage()
#8 /var/www/html/105119/system/Dispatcher/Controller.php(101): IPS\core\modules\front\system\nexus_hook_register->manage()
#9 /var/www/html/105119/system/Dispatcher/Dispatcher.php(152): IPS\Dispatcher\_Controller->execute()
#10 /var/www/html/105119/index.php(13): IPS\_Dispatcher->run()
#11 {main}

This error means literally that a plugin or application hooking the register::_createMember method is failing because it isn't compatible with IPS 4.5

Not to bring discussion of this ticket to this thread, but since it's here... why does the issue remain even with all plugins/applications disabled?

Link to post
Share on other sites

Maybe what they mean with that is before you try to contact them disable or update your third-parties apps, plugins, hooks, etc. and see if you can reproduce the problem, sometimes might be the cache that is causing the problem. As a developer it is frustrating to find a problem being caused by a third-party library that was not updated.

I cannot say about "scolding" but this is what I would interpret it, I have no idea about what was discussed privately so I cannot say more. I didn't have this kind of problem with the support.

Link to post
Share on other sites
22 minutes ago, Octavian Dima said:

Maybe what they mean with that is before you try to contact them disable or update your third-parties apps, plugins, hooks, etc. and see if you can reproduce the problem, sometimes might be the cache that is causing the problem. As a developer it is frustrating to find a problem being caused by a third-party library that was not updated.

I cannot say about "scolding" but this is what I would interpret it, I have no idea about what was discussed privately so I cannot say more. I didn't have this kind of problem with the support.

I always disable and update before asking for support. I always expect that this will be their first assumption. I always tell them I did so, but I often get a canned response that asks me to do exactly what I already explained I did. Often the issue remains even after everything is disabled. We continue troubleshooting and find the issue. Support is fantastic!

But... there is ALWAYS a comment of discouragement and scolding for using third-party resources, so that's what this post is asking: 1. I wonder if others are as discouraged from using them as I have experienced, and 2. if we are going to be discouraged from using third-party tools, it seems like a good idea to stop buying them and using them.

I am always up to date based on what information is available to me, and I always reach out to the developers for support if it's related to their application and everyone responds with amazing support. Many of the plugins, themes, and applications are just incredibly useful things that make our communities so much better. I really don't like that I may have to remove all of them.

Link to post
Share on other sites

Don't remove them. The plugins and apps that I personally use are what make my community viable for the community I want to build

I don't think I've ever been discouraged from any of the apps or plugins that I use. At least never from IPS themselves but I can see how it can be daunting to get the canned answer (I have gotten it a few times myself even though I've described that I already ran through those troubleshooting steps too). 

If I didn't have, say my character manager, I'd move to a different software that could accommodate what that app can do.

Link to post
Share on other sites
9 minutes ago, Dean_ said:

This is why the Marketplace has gone in the direction that it is has. This is to eliminate such issues as there is more scrutiny over what is published and up to date.

The problem here seems to be user using a 4.3 plugin version on 4.5 board. I don’t see where this can be dev’s fault.

He probably updated from 4.3 to 4.5 and broke it. But the upgrade to 4.5 should disable 3rd-party resources so I’m not sure that’s the case.

Link to post
Share on other sites
1 hour ago, Adriano Faria said:

The problem here seems to be user using a 4.3 plugin version on 4.5 board. I don’t see where this can be dev’s fault.

He probably updated from 4.3 to 4.5 and broke it. But the upgrade to 4.5 should disable 3rd-party resources so I’m not sure that’s the case.

This seems most likely. 😬

Link to post
Share on other sites
3 hours ago, Adriano Faria said:

The problem here seems to be user using a 4.3 plugin version on 4.5 board. I don’t see where this can be dev’s fault.

He probably updated from 4.3 to 4.5 and broke it. But the upgrade to 4.5 should disable 3rd-party resources so I’m not sure that’s the case.

Yeah, if there was an update to something and it broke and no indication that it was broken during the upgrade, I don't know what I'm expected to do. I'm not a developer and when the issue remains after disabling all plugins and applications, it seems like something more is involved than third-party, no?

Link to post
Share on other sites
3 hours ago, Morrigan said:

Don't remove them. The plugins and apps that I personally use are what make my community viable for the community I want to build

I don't think I've ever been discouraged from any of the apps or plugins that I use. At least never from IPS themselves but I can see how it can be daunting to get the canned answer (I have gotten it a few times myself even though I've described that I already ran through those troubleshooting steps too). 

If I didn't have, say my character manager, I'd move to a different software that could accommodate what that app can do.

Thanks for the response and encouragement. Yes, my community would suffer a blow if we remove some of these vital additions. Plus, I love supporting developers and creators. And The canned responses are expected. They are annoying, but expected. It's the additional commentary along the way that tells me that using plugins and applications will always be a problem (even though they rarely have been).

My community hasn't been able to register any new members for about a month. The blame has been on an application that I disabled. I disabled all plugins, all applications, and the issue remains, yet it is somehow still third-party to blame, so I am just left with nothing but a broken site. I don't know what to do. For now, I'm patiently waiting for a solution.

3 hours ago, Dean_ said:

This is why the Marketplace has gone in the direction that it is has. This is to eliminate such issues as there is more scrutiny over what is published and up to date.

I am very excited about this and I hope it works soon. So far, I've had more issues than ever recently. I've been with invision for years, so I trust all of this will be sorted out.

Link to post
Share on other sites

Just a quick update that after a month of third-party resources being blamed, it turns out (yet again) that it was an Invision issue. That's okay. I don't have any problem with any bugs or issues discovered in any application or Invision, but I have to say that I think this could have been resolved much sooner if there wasn't this uncomfortable bias against 3rd Party resources. I am just happy that the issue is being resolved, but after going through this so many times, it can get very frustrating. I say that with great affection because I am in awe of all of you who do this kind of work. I just don't want to go through this again.

Link to post
Share on other sites

Glad to hear you got it resolved. Problems like this can lead to a lot of anxiety.

The Support Team do indeed do a great job, sometimes you can get the pointy end of the stick and because you are paying for support it smarts. Sometimes I'm sure they get it from the behaviour of the client, as recently demonstrated elsewhere. Sometimes I feel like in most corporate environments it's the system they have to comply with that can create or amplify issues, like aspects of the new 4.5 Marketplace paradigm, it must seem like a thankless task at times for the approval queue staff, but if someone stepped in to take ownership and polish off the rough edges, things could be smoother for everyone on both sides of the IPS castle walls.

Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy