Jump to content

Kitchen Sink


All Astronauts
 Share

Recommended Posts

On 10/30/2020 at 12:25 PM, All Astronauts said:
  • NEW BY REQUEST! Posts numbered in Forum Topics. Either the actual universal post number or numerically 1-2-3 per-topic. Those aren't linked. You can get the post link in the three-dot dropdown via the Share option.

I sent you a PM, but basically… posts are numbered (I have them starting at 1 for each topic)… but every page starts over at 1. 18 posts per page, no AJAX, and on page 11, the first post still says #1 and the last on the page says #18.

Link to comment
Share on other sites

Ignoring the fact that I have to re-submit this update because I forgot to increment a number on the submission form which makes your ACP MP entry tell you that there is an update available, you have a new KS inbound. Soon...

KS 1.2.0

  • UPDATE! Altered the breadcrumb hook. Home icon now inserted without replacing elements, home text removed via JS.
  • UPDATE! Review stars now use the complete half-star icon instead of the default half and half-flipped approach.
  • NEW! FA5 Pro licensed icons supported. 
  • FIX! Reverse Post Order in Topics setting when set to apply to all forums.
  • FIX! Some sites do not ajax-load new pages of Forum topics, so I had to fix up the topic post numbering feature to account for that.

I believe that takes care of any requested fixes/hitches lingering about.

EDIT: My MP idiocy has been reverted and now KS 1.2.0 has been successfully submitted. Approved, and available for upgrading to, whenever whenevers (holiday hours for IPS so prob the new year sometime)

Edited by All Astronauts
Link to comment
Share on other sites

On 12/29/2020 at 4:49 PM, All Astronauts said:

Ignoring the fact that I have to re-submit this update because I forgot to increment a number on the submission form which makes your ACP MP entry tell you that there is an update available, you have a new KS inbound. Soon...

KS 1.2.0

Hoping this gets approved soon. C’mon, IPS!

Link to comment
Share on other sites

Posted (edited)

Be a bit more. Since it had been five days already I figured it was behind in the queue and asked for it to be pulled os I could re-submit with some more tweaks. Was just submitted again now. It was that or another derpy update immediately afterward and that seemed silly - both for end users and the reviewers.

  • UPDATE! Altered the breadcrumb hook. Home icon now inserted without replacing elements, home text removed via JS.
  • UPDATE! Review stars now use the complete half-star icon instead of the default half and half-flipped approach.
  • NEW! FA5 Pro licensed icons supported. 
  • FIX! Reverse Post Order in Topics setting when set to apply to all forums.
  • FIX! Some sites do not ajax-load new pages of Forum topics, so I had to fix up the topic post numbering feature to account for that.
  • UPDATE! Also improved the page numbering feature to work better with custom themes that have moved the .ipsComment_tools structure to the postContainer template instead of the post template

Only new thing (minus the obligatory code tweaks here and there) is that last one. 

Unrelated note: Those of you using the Who Viewed the Topic plugin, the Viewers app should be submitted today. That will be the upgrade path for 4.5. The plugin works fine as-is now but will not be submitted to the new ACP MP so you are on your own there. It needed to get re-written to deal with GDPR and honestly, lots of other reasons.

Edited by All Astronauts
Link to comment
Share on other sites

Good catch. I made a tiny copy/paste error. If I want to output any KS settings to be available for javascript purposes, I have to manually insert them into the output array, which is all well and good until you output the value of one setting for a different one.

That's how things end up not working.

Patched, submitted, 1.2.1

Link to comment
Share on other sites

  • 1 month later...

1.3.0 submitted 2/7/2021 - available when you see it in the ACP, should be a day or two from now

  • NEW! Core - Lazy-load option for userphotos
  • NEW! Forums - Index - Option to hide the circle-dot unread marker on sub-forums (sub-forum titles remain bolded when unread)
  • NEW! Forums - Topics - append topic author's user group after author's name. Plain or formatted.
  • ADD! A few new language strings to replace hard-coded text in settings.

The lazy load is the newer browser-based lazy flag. That's all. IPS will eventually be removing all their own javascript lazy load stuff in a later version of Invision Community in favor of the new browser standards - this just jumps ahead of the line for userphotos - mainly due to all the noise from that topic a week or two ago. This is like a two second hook to make so figured I'd throw it in. This will, naturally, get yanked when IPS eventually flips stuff over...

The rest should be self-explanatory

Link to comment
Share on other sites

1 hour ago, bearback said:

i just checked my admin cp and the update is available.

login to admin cp and go to applications and click check for updates button, should appear

I did that right before posting. But yeah, it's updated now.

Thank you.

Link to comment
Share on other sites

  • 2 weeks later...

Is possible add settings to handle waste space problem of ips default theme? 

Example :IMG_20210218_090301.thumb.jpg.dc51688bfd1085b42b6bcf94129084ef.jpg

Orange: so spaces nothing to do... 

Red: at least in mobile, I would like hide it, because the title is duplicated, is enough the club tabs title. 

The screenshot is in guest view. 

Link to comment
Share on other sites

  • 2 weeks later...
  • 3 months later...

2.0.0 submitted. Avail when it's approved. For 4.6 and up, not for y'all lingering on 4.5.x

  • REMOVED! Lazy Load on userphoto template - IPS has included same natively with 4.6
  • FIX! Limiting attachments in forum posts was either slightly broke or just slightly broke on 4.6; patched.
  • NEW! Recent Status Updates widget now with three possible views AND you can customize the number of lines output per update - no more three line limit!
  • TWEAK! for when displaying both topic and post count stats together to add more room for larger counts
  • NEW! Remove the icon area from Forum index displays.
  • NEW! Append <new> badges at the end of forum titles when new content is within in index view - combine with removed icon area for a clean lean look.
  • NEW! Above also does the same for link forums and password-protected forums.
  • And the usual etc... and 4.6 compatibility yada yada

minimalplus.PNG.614d941572a706e38e8c16fb215b994f.PNG

New options to go ambient with forum views (on index, and forum blocks within forums). Remove the icon area, append badges instead of those dot when there is new content, matching badges for password and link forums, yes, on click, they will mark the respective forums read and so on. I do this on my sites and customs and got tired of hacking themes all the time so jammed it in here.

status1.PNG.aca9bfc510487e84034c3ee30cfce4db.PNG     status2.PNG.39b204298cbe5a0f5ceb626d5ec60cdc.PNG

Two new status update widget views. Expands the content to fill the block which is so much better and, because I wanted it and no longer could wait for it, you can customize the number of lines displayed per-update beyond the default three. I sound like a broken record but it is so much better being able to read most if not all of the usual updates people post without it getting severely truncated.

For those tracking my updating for 4.6, Spacious ACP is probably next, then Viewers, then I need to look at some older plugins that had some problems officially coming up to the 4.5 line.

Toodles. 👩‍🚀

Link to comment
Share on other sites

  • 2 weeks later...

I've just updated kitchen sink on 4.6.3 and I have started to see a template error on all topics. It started to happen after updating it. I disabled it and all seems to be ok.

See screenshot. It appears on all topics if KC is enabled. What is the problem? Thanks. 

[[Template core/global/forms/editorAttachments is throwing an error. This theme may be out of date. Run the support tool in the AdminCP to restore the default theme.]]

 

image.png

Link to comment
Share on other sites

Posted (edited)

Got a patch inbound. This is the limit the # of attachments bit which I *DID* fix (see posts further above) but apparently clipped a leading \ off at some point when calling \IPS\.... No idea...

Taking a moment to also double secret verify this is all good.

EDIT: Submitted and support ticket opened to push it to the front of the pile.

Edited by All Astronauts
Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy