Jump to content

Community

Error while downloading plugin with widget


DreamOn
 Share

Recommended Posts

Hello,

Since IPS 4.5, I can not anymore download my plugin containing a widget.

When clicking on download button, this error appears:
 

OverflowException thrown with message ""

Stacktrace:
#6 OverflowException in /srv/www/community.site.com/current/web/ips/system/Theme/Theme.php:5038
#5 IPS\_Theme:addTemplate in /srv/www/community.site.com/current/web/ips/applications/core/modules/admin/applications/plugins.php:1995
#4 IPS\core\modules\admin\applications\_plugins:download in /srv/www/community.site.com/current/web/ips/system/Dispatcher/Controller.php:90
#3 IPS\Dispatcher\_Controller:execute in /srv/www/community.site.com/current/web/ips/system/Node/Controller.php:62
#2 IPS\Node\_Controller:execute in /srv/www/community.site.com/current/web/ips/applications/core/modules/admin/applications/plugins.php:48
#1 IPS\core\modules\admin\applications\_plugins:execute in /srv/www/community.site.com/current/web/ips/system/Dispatcher/Dispatcher.php:152
#0 IPS\_Dispatcher:run in /srv/www/community.site.com/current/web/ips/admin/index.php:14

The problem comes from the template file: my-plugin/dev/html/widgetName.phtml.

When I delete this widgetName.phtml file, download is OK.

Can you help?

Thanks!

Edited by DreamOn
Link to comment
Share on other sites

I can't reproduce - this looks like a problem with your install, specifically. I expect it's a legacy thing where the template was inserted but stored differently than it would now.

You may be able to fix the issue by removing the plugin completely and re-adding it. Alternatively you may be able to fix the issue by removing the template row from core_theme_templates manually in phpmyadmin.

I just created a new plugin with a widget and a template and can export it as many times as I want without issue.

Link to comment
Share on other sites

  • 3 weeks later...
On 9/23/2020 at 4:17 PM, bfarber said:

I can't reproduce - this looks like a problem with your install, specifically. I expect it's a legacy thing where the template was inserted but stored differently than it would now.

You may be able to fix the issue by removing the plugin completely and re-adding it. Alternatively you may be able to fix the issue by removing the template row from core_theme_templates manually in phpmyadmin.

I just created a new plugin with a widget and a template and can export it as many times as I want without issue.

Thanks, just removed the template row in core_theme_templates and it works!

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy