Jump to content

Community Map


Martin A.

Recommended Posts

Another issue.  I haven't really checked that many markers yet but a member messaged to tell me that they had the city right but his marker is showing up in the wrong state.  I checked his profile and it is clearly marked "FL" but the marker is in South Carolina.  

Link to comment
Share on other sites

Just now, Dknelson said:

Another issue.  I haven't really checked that many markers yet but a member messaged to tell me that they had the city right but his marker is showing up in the wrong state.  I checked his profile and it is clearly marked "FL" but the marker is in South Carolina.  

Stuff like that can happen, and not really much can be done about it. If MapQuest thinks the SC location is correct, it will select that. This have been an issue for years. What's the exact location the member have entered?

Link to comment
Share on other sites

6 hours ago, Dknelson said:

Sanford, FL.   It places his marker in Sanford, N.C.

When I use that location I end up in "Sanford, Seminole County, Florida, United States of America".

What do you get when you visit this page? Replace XYZ with your MapQuest API key.

https://open.mapquestapi.com/nominatim/v1/search.php?format=xml&q=Sanford,%20FL&key=XYZ

 

Link to comment
Share on other sites

Hi Martin, thanks a lot for upgrading this to the new IPB. I upgraded it but I'm getting an error when trying to add a custom marker:

 

code edited

and also when trying to access in ACP to the Map Manager menu:

code edited

Any idea what could be happening here?

Thanks a lot!

JB

Edited by joaocb
removal of the code
Link to comment
Share on other sites

24 minutes ago, Dknelson said:

I've got quiet a lot of markers that are incorrectly placed.  Don't understand why.  Here is one example.  At the top, it shows where the marker is actually place.  His profile fields are listed in the bottom part.

And there you have the root of your issue; The state is in its own field. Community Map will just use one of those fields.
When I search for just "Sanford", without the state, the location in NC is the top result.

I would advice you to have the entire location in one field. There is an alternative, but it would require a custom plugin to merge these three fields into a fourth field that's not editable by the member.

Link to comment
Share on other sites

38 minutes ago, Dknelson said:

Thanks.  My site is a recent changeover from VBulletin and they used two fields for that info.  

So, the answer is to create a new field and have all my members update their profiles?  A location field that asks for city, state?  

Yes. contact me in a PM if you want me to help you construct a query that'll automatically populate that field for you.

Link to comment
Share on other sites

Hello @Martin A. I have a couple of questions before I purchase....

  1. Will a person be able to search by zip code, city, state or zip? For example can I search 5 or 10 miles from where I live to see if a member is in that area? I'm guessing I might have to pair your plugin with this one to pull this off?
  2. What happens if a member cancels or pauses (we use Memberpress along with the SSO plugin to sync up their Memberpress account to their IC account) their account? Is there a way to make sure they're no longer included in the map and results?
  3. Do I have to manually add members (or have them add themselves?) or can it happen automatically? We have over 1,100 current members and don't want to have to add them all manually myself.

Thank you!

Justin

Edited by Justin Stellman
Link to comment
Share on other sites

18 hours ago, Martin A. said:

Yes. contact me in a PM if you want me to help you construct a query that'll automatically populate that field for you.

I've sent you a couple of PMs but haven't heard back.

Also, the last couple of days, I get the following error in the morning.

Exception:
RuntimeException Object
(
   [message:protected] => Only subclasses of Dispatcher can be instantiated
   [string:Exception:private] => 
   [code:protected] => 0
   [file:protected] => /home/dknelson/public_html/forum/system/Dispatcher/Dispatcher.php
   [line:protected] => 54
   [trace:Exception:private] => Array
       (
           [0] => Array
               (
                   [file] => /home/dknelson/public_html/forum/applications/communitymap/Application.php
                   [line] => 73
                   [function] => i
                   [class] => IPS\_Dispatcher
                   [type] => ::
                   [args] => Array
                       (
                       )

               )

           [1] => Array
               (
                   [file] => /home/dknelson/public_html/forum/applications/communitymap/sources/Map/Map.php
                   [line] => 244
                   [function] => getApiKeys
                   [class] => IPS\communitymap\_Application
                   [type] => ::
                   [args] => Array
                       (
                           [0] => mapquest
                       )

               )

           [2] => Array
               (
                   [file] => /home/dknelson/public_html/forum/applications/communitymap/tasks/locationSync.php
                   [line] => 215
                   [function] => getLatLng
                   [class] => IPS\communitymap\_Map
                   [type] => ->
                   [args] => Array
                       (
                           [0] => Fayetteville
                           [1] => 1
                       )

               )

           [3] => Array
               (
                   [file] => /home/dknelson/public_html/forum/system/Task/Task.php
                   [line] => 266
                   [function] => execute
                   [class] => IPS\communitymap\tasks\_locationSync
                   [type] => ->
                   [args] => Array
                       (
                       )

               )

           [4] => Array
               (
                   [file] => /home/dknelson/public_html/forum/system/Task/Task.php
                   [line] => 229
                   [function] => run
                   [class] => IPS\_Task
                   [type] => ->
                   [args] => Array
                       (
                       )

               )

           [5] => Array
               (
                   [file] => /home/dknelson/public_html/forum/applications/core/interface/task/task.php
                   [line] => 56
                   [function] => runAndLog
                   [class] => IPS\_Task
                   [type] => ->
                   [args] => Array
                       (
                       )

               )

       )

   [previous:Exception:private] => 
)

 

 

Link to comment
Share on other sites

On 10/28/2020 at 12:52 AM, Justin Stellman said:

Hello @Martin A. I have a couple of questions before I purchase....

  1. Will a person be able to search by zip code, city, state or zip? For example can I search 5 or 10 miles from where I live to see if a member is in that area? I'm guessing I might have to pair your plugin with this one to pull this off?
  2. What happens if a member cancels or pauses (we use Memberpress along with the SSO plugin to sync up their Memberpress account to their IC account) their account? Is there a way to make sure they're no longer included in the map and results?
  3. Do I have to manually add members (or have them add themselves?) or can it happen automatically? We have over 1,100 current members and don't want to have to add them all manually myself.

Thank you!

Justin

  1. Currently no. I have it on the road map for when I re-do the sidebar marker list.
  2. I answered this the last time you asked me these questions
  3. You can not add the markers on behalf of the member. They would either do it manually, or have it imported if you have the info available in a profile field. Due to all the privacy laws hanging around us these days, I'm not going to add anything that would automatically add them based on their IP.

 

On 10/28/2020 at 1:56 PM, Dknelson said:

Also, the last couple of days, I get the following error in the morning.

Thanks. This issue will be fixed in the next release.

Link to comment
Share on other sites

v1.1.0 have been submitted, and here's a list of what you can expect in that version

  • Custom fields
    • You're finally able to add your own fields to the markers. These can be all the kinds of fields you're used to in both profiles and in Pages databases.
    • There is a group setting to define the fields that is available for the group
    • There is also a group setting where you choose the fields that's visible in the marker popup.
      • This replaces the global setting where you could select member profile fields.
      • This will also replace the "privacy setting" where you could choose to not show any information in the popup
  • Grid layout in marker listing
    • You can not show your markers in a grid pattern instead of the default list. This is a group setting
    • You can define a "grid card image", similar to forums. This can be from a custom field. If a custom field isn't selected, or the field is empty, the authors cover photo will be used.
  • Fixed bugs
    • Fixed a bug where the marker pin color for member groups wasn't honored.
    • Fixed more bugs with PHP 7.1
    • Fixed a bug where the marker popup wouldn't open in MacOS Safari.
    • Fixed an issue with the location import task.
    • The location import task could try to import the same members over and over again.
    • Fixed an issue with the .kml/.kmz importer. Markers inside a nested folder with other folders was not imported.

gridLayout.thumb.png.7d5fe42885ae940455199997503c623a.png

image.png.9ea406eb097e277c3867219c7095db2e.png image.png.5db0a900cb5ca982c9c536113eeb7f8f.png image.png.1d0baccc6488c4edefff9b23c7361592.png

Edited by Martin A.
Link to comment
Share on other sites

5 hours ago, svit said:

When I add blocks to the Communitymap application and then chose it as the 'Default' suite application, then the hooks don't show up when clicking on the suite logo. Is it an issue of the app or of the suite?

I would say it's a suite issue, but I can't be sure as I'm unable to reproduce this myself. The blocks are outside of the scope of the application. I can't control what's shown or where it shows. Could be an issue with the theme too.

image.png.075aa9cd3b452ad111ee7e83f5da0927.png

Link to comment
Share on other sites

Just tried installing it again, and got this error:

Quote

An application is already installed that uses the same Application Key, this application cannot be installed unless the other is removed

btw, I've been using this for years, so this is an upgrade.

Edited by bassangler
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...