Jump to content
You're invited! Join our 4.6 Live Event on ZOOM 6/24 ×

Community

Movies


Adriano Faria
 Share

Recommended Posts

Agreed the template is nice - just waiting for any clean up @Jimi Wikman performs to see how things change.

One question to ask Jimi - the rating circle, is that your own rating or is it the rating taken from TMDB?  If it's your own, is there a way in your template that it could be pulled from TMDB?

I reckon you could work well with @Adriano Faria in terms of styling.

Great work @Adriano Faria for making such a sweet app and to @Jimi Wikman for doing some restyling for those of us who like movies and want to share with others 🙂

 

Edited by Davyc
Link to comment
Share on other sites

@Davyc it is my own rating. You can use that for the official rating if you like as well as it has a field connected to it that you can put the value from the ratings instead. If we get the official rating as a field later I might add a second circle to show my rating and the official ratings.

...and I updated my article this morning with a cleaned up code, so you can check it out if you like 🙂

Link to comment
Share on other sites

Hello Adriano,

I am checking with you to see if there is anything that can be done on your end of how the plugin displays the movie data that is imported.

For example, on the TMDB page for this particular movie, Legend of the Ancient Sword, it shows the Language as Chinese, and it displays it in English.
movies-tmdb-language.thumb.png.7795a9fae3a25824a6ff40d4ea9069b4.png



When I import this movie, it displays the language like so:

movies-language.png.0b31687f62a7eb3cc0f427b29c630c1c.png


Please let me know if there is anything that can be done about this, Thank you!!!

 

Link to comment
Share on other sites

9 hours ago, SC36DC said:

Please let me know if there is anything that can be done about this, Thank you!!!

When I hit that little niggle I found out that despite your language choice, TMDB always asks for the language that a movie is created in first when it's added to their database.  To overcome this search for your movie and when you 'Add this movie' (you must add first) you can manually change the title into English or any other language that you use.  I get this a lot with martial arts movies, but it's easily remedied 🙂

 

Edited by Davyc
Link to comment
Share on other sites

1 hour ago, Davyc said:

When I hit that little niggle I found out that despite your language choice, TMDB always asks for the language that a movie is created in first when it's added to their database.  To overcome this search for your movie and when you 'Add this movie' (you must add first) you can manually change the title into English or any other language that you use.  I get this a lot with martial arts movies, but it's easily remedied 🙂

 

I appreciate your reply. In fact, just about every movie I add  it shows the title in Chinese, and I always change it to the English title before saving the page. But in the sidebar for 'Language', it still shows it in Chinese, as you can see from my screenshot. So instead of it saying Mandarin, Cantonese or even Chinese, it shows the language in Chinese characters and not in English. There is no way to edit this. 

Edited by SC36DC
Link to comment
Share on other sites

9 minutes ago, SC36DC said:

I appreciate your reply. In fact, just about every movie I add  it shows the title in Chinese, and I always change it to the English title before saving the page. But in the sidebar for 'Language', it still shows it in Chinese, as you can see from my screenshot. So instead of it saying Mandarin, Cantonese or even Chinese, it shows the language in Chinese characters and not in English. There is no way to edit this.

Unfortunately, that's the way the API draws the data from TMDB and there's nothing that can be done.  When a movie is added, the first language is always required and if the submitter adds it as Chinese, Spanish, German or whatever then the API will draw that data into the app.  The upside is that the Invision system allows us to change that in the title, but that's down to the Invision app and not the API.  Sometimes it takes a while to get to grips with what the API can draw and the limitations it imposes.  I've looked at the API info on the TMDB site and it's less than clear to the uninitiated.  However, when you delve deeper into it, certain things become clearer over time - it's getting your mindset into what developers see and not we, as end users, see it and that's not always easy lol.  I would just ignore it, as I'm sure your users will - the uptick is that if you have Chinese visitors and users, they will be very pleased to see the title in its original language 🙂

 

Link to comment
Share on other sites

@Adriano Faria I am noticing something missing from my setup. On @Davyc and @Jimi Wikman Movies pages, they have the 'Share' button next to their 'Follow', is there a setting somewhere I am missing? The only 'Share' setting I see in the Movies app, is in Category Settings, at the bottom in the Category Display section there is an option that says 'Enable sharing', which I do have on. Right underneath that there is a link that says 'Sharing Settings', when I click this it opens a white page and in the url field it says, 'about:blank#blocked'.

movies-davyc-share.png.5805ac8ba328d649d5970b5733208c2c.pngmovies-jimi-share.png.697f2c0bd8f84b2a219934dc38cdd399.png

 

 

 

 

 

Thank you for your help with this.
 

 

Edited by SC36DC
Link to comment
Share on other sites

Just now, Adriano Faria said:

On IPS4, share button will only show if guests can view the content.

Let me try that. Thanks.

4 minutes ago, Adriano Faria said:

On IPS4, share button will only show if guests can view the content.

It worked. I currently have it set for only Admin to view while I am still setting it up.
 
I really appreciate the quick reply and easy fix. 😉

Link to comment
Share on other sites

Posted (edited)
On 1/5/2021 at 7:29 PM, SC36DC said:

Hello Adriano,

I am checking with you to see if there is anything that can be done on your end of how the plugin displays the movie data that is imported.

For example, on the TMDB page for this particular movie, Legend of the Ancient Sword, it shows the Language as Chinese, and it displays it in English.
movies-tmdb-language.thumb.png.7795a9fae3a25824a6ff40d4ea9069b4.png



When I import this movie, it displays the language like so:

movies-language.png.0b31687f62a7eb3cc0f427b29c630c1c.png


Please let me know if there is anything that can be done about this, Thank you!!!

 

Just took a look in the API and it can return the English name of the language:

AnFLlXZ.png

I'll add a setting. Probably this will not the ideal for everyone.

-----------------

EDIT:

Something like that:

Pn2fO3U.png

It's enough just to run the support tool to rebuild the language data store file after update.

 

9AgRvVf.png

Unfortunately GENRES do not provide an English name.

Edited by Adriano Faria
Link to comment
Share on other sites

3 hours ago, Adriano Faria said:

Just took a look in the API and it can return the English name of the language:

AnFLlXZ.png

I'll add a setting. Probably this will not the ideal for everyone.

-----------------

EDIT:

Something like that:

Pn2fO3U.png

It's enough just to run the support tool to rebuild the language data store file after update.

 

9AgRvVf.png

Unfortunately GENRES do not provide an English name.

That's incredible. Thank you for working this out. Looking forward to the update. 

Link to comment
Share on other sites

  • 3 weeks later...
  • 2 months later...
39 minutes ago, Adriano Faria said:

Can you reproduce on default theme? Last time I checked it was ok.

That is how it should be:

Screenshot9.jpg.ded33d544249bb8787570036

Yours is weird; title is below the image. 

Test in the default theme.

You're right. I should have checked that first. Thanks!

Edited by Michael R
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy