Jump to content

Community

Recommended Posts

Just for presentation on what you can do with some tweaks on design. @Adriano Faria took care for the quality of code (still didn't found even a single bug), so the only that left out is some design work to make it more beautiful. Currently I'm working on the movie page and when finish I'll work on listing page.

Please note that mobile is not yet ready, so I suggest to test it in desktop view. The only that I added is a custom field (upload type) for the Cover Photo.

image.thumb.png.2bff80f7126e33a812610e333d3be215.png

The listing page should look like this one:

image.thumb.png.c2d5a477a68a9b5de8a20e951d5cf1ed.png

and the categories (homepage) something like this

image.png.97b6124861ae0fcefd0da0f655a12ea3.png

Edited by ChrisTERiS
Link to post
Share on other sites
  • Replies 159
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

New vesion submitted. List of features: Follow the file to get notified when IPS reviews and approves it. 👍

Just for presentation on what you can do with some tweaks on design. @Adriano Faria took care for the quality of code (still didn't found even a single bug), so the only that left out is some design w

Yes, I worked a lot with @McAtze in the app design. He's helping a lot. 🙂 New verison should be out next week.

Posted Images

1 minute ago, ChrisTERiS said:

Suggestion: In Extra Fields add a 3nd option to Display Location-> 'Manual'. This way it will not appears in the predefined positions but only where the webmaster wants to show it.

Just like a magic trick? 🤣

You know that’s not how it works. You would need to edit a template and add it where you want. 

28 minutes ago, ChrisTERiS said:

Just for presentation on what you can do with some tweaks on design

...and that’s where lies the beauty of the template system. I will certainly do some improvements, but we already talked via PM. You can do whatever you want in your install and share with others, just in case they want to use it too.

Link to post
Share on other sites
1 hour ago, Adriano Faria said:

Just for others understand, I have right now, 3 “suggestions” of layout for this app. So what should I do? Add the three options and add settings to choose? Nooooooo!!!! That would make the whole thing impracticable. So, people are free to change at their wish in their own install.

The only suggestion from my side, is one. All others are just sharing thoughts. Add support for Persons, even as a separate plugin (meaning extra price). Just try to adapt it on the same module. Plugin for the Movies Module 🙂

And yes, I'm planing to share my design with anyone you may like it.

 

 

Edited by ChrisTERiS
Link to post
Share on other sites

My only suggestion would be to, perhaps, move one of the trailers to the information tab as it often looks very bare - a lot of white space.  I'm not sure if it's possible to just have one trailer on that tab and the others in the main trailer tab, but it would fill some of that white space.  Other than that, I'm very happy with the layout 🙂

 

Link to post
Share on other sites
6 minutes ago, Davyc said:

My only suggestion would be to, perhaps, move one of the trailers to the information tab as it often looks very bare - a lot of white space.  I'm not sure if it's possible to just have one trailer on that tab and the others in the main trailer tab, but it would fill some of that white space.  Other than that, I'm very happy with the layout 🙂

 

Hard to do as it can have more than one and it would require an extra API call in the movie page load, which would make it slower for sure. 

Link to post
Share on other sites
1 hour ago, Adriano Faria said:

Hard to do as it can have more than one and it would require an extra API call in the movie page load, which would make it slower for sure. 

I get that, it's always a trade-off between speed and UX experience. Perhaps combining one of the other tabs with the information tab just to fill that space, which can be vast lol.  Perhaps the cast combined and remove the cast tab?  I understand that it's easy for us armchair critics, but the actual doing of it may not be as simple as the suggestion sounds lol 🙂

 

Link to post
Share on other sites
8 minutes ago, Duken said:

Question: What does the Use a Feature Color do?

I'll show you an example in Forums app, as I don't have Movies installed right now.

- It will colorize the icons:

1HyAHJa.png

- Will add the color in category view:

vphQNF7.png

 

- And Activity Streams too:

IWmdShQ.png

It will also show in the sidebar categories block.

It's just a visual effect for "special" categories.

Link to post
Share on other sites

After working a full day, just got a cold bath 🙂 If I understood well, custom fields are not available in category listing (movies list).

https://www.diziask.com/movies/category/3-running/

Before wasting more time, a short No/Yes answer please. At least when in templates-> variables shows $movies this means that all fields of table movies_movies are available? As I said just a Yes/No 🙂

Thank you

Link to post
Share on other sites

What can cause this issue? It does not takes the movie_type . It exists in the actions button down-left. Other details are ok.

EDITED: Just a notice. This issue is not in all movies. Actually among 80, I noticed it only in one

image.png.58880352dbb8fa18b07db648aa6eac3e.png

Edited by ChrisTERiS
Link to post
Share on other sites
35 minutes ago, ChrisTERiS said:

If I understood well, custom fields are not available in category listing (movies list).

No, just like all apps, it shows in the item view only.

39 minutes ago, ChrisTERiS said:

Before wasting more time, a short No/Yes answer please. At least when in templates-> variables shows $movies this means that all fields of table movies_movies are available? As I said just a Yes/No 🙂

$movies will probably be an array so you will need a foreach to break in each movie. 

15 minutes ago, ChrisTERiS said:

What can cause this issue? It does not takes the movie_type . It exists in the actions button down-left. Other details are ok.

image.png.58880352dbb8fa18b07db648aa6eac3e.png

Probably the API didn’t return the type (movie or TV) so the lang bit isn’t showing. You can browse the table and add the proper value in the movie_type column, if I’m not mistaken. You will see values from others so it will be easy to identify. 

Link to post
Share on other sites

Got an error trying to add a movie:

Error code: EX1048

I understood what it says, most probably API didn't return movie_runtime value, but I don't know how to fix it.

INSERT INTO `ips45_movies_movies` ( `movie_submitted`, `movie_updated`, `movie_mid`, `movie_ipaddress`, `movie_last_comment`, `movie_last_review`, `movie_cat`, `movie_open`, `movie_locked`, `movie_views`, `movie_pinned`, `movie_featured`, `movie_comments`, `movie_reviews`, `movie_unapproved_comments`, `movie_hidden_comments`, `movie_unapproved_reviews`, `movie_hidden_reviews`, `movie_title`, `movie_title_seo`, `movie_subtitle`, `movie_description`, `movie_tmdb_id`, `movie_imdb_id`, `movie_homepage`, `movie_runtime`, `movie_original_language`, `movie_revenue`, `movie_budget`, `movie_release_date`, `movie_status`, `movie_seasons`, `movie_episodes`, `movie_type`, `movie_genres` ) VALUES ( 1602234697, 1602234697, 1, '37.98.196.145', 1602234697, 1602234697, 4, 1, false, 0, 0, 0, 0, 0, 0, 0, 0, 0, 'Merhamet', 'merhamet', NULL, '', 53677, NULL, '', NULL, NULL, 0, 0, NULL, 'Ended', 2, 44, 'tv', NULL )
IPS\Db\Exception: Column 'movie_runtime' cannot be null (1048)
#0 /home/diziask/public_html/system/Db/Db.php(948): IPS\_Db->preparedQuery()
#1 /home/diziask/public_html/system/Patterns/ActiveRecord.php(487): IPS\_Db->insert()
#2 /home/diziask/public_html/applications/movies/modules/front/movies/view.php(315): IPS\Patterns\_ActiveRecord->save()
#3 /home/diziask/public_html/system/Dispatcher/Controller.php(90): IPS\movies\modules\front\movies\_view->addMovie()
#4 /home/diziask/public_html/system/Content/Controller.php(50): IPS\Dispatcher\_Controller->execute()
#5 /home/diziask/public_html/applications/movies/modules/front/movies/view.php(37): IPS\Content\_Controller->execute()
#6 /home/diziask/public_html/system/Dispatcher/Dispatcher.php(152): IPS\movies\modules\front\movies\_view->execute()
#7 /home/diziask/public_html/index.php(13): IPS\_Dispatcher->run()
#8 {main}

 

Edited by ChrisTERiS
Link to post
Share on other sites

..hmmmmmm..... seems that most probably database messed. I tried with another one and I got the same error

INSERT INTO `ips45_movies_movies` ( `movie_submitted`, `movie_updated`, `movie_mid`, `movie_ipaddress`, `movie_last_comment`, `movie_last_review`, `movie_cat`, `movie_open`, `movie_locked`, `movie_views`, `movie_pinned`, `movie_featured`, `movie_comments`, `movie_reviews`, `movie_unapproved_comments`, `movie_hidden_comments`, `movie_unapproved_reviews`, `movie_hidden_reviews`, `movie_title`, `movie_title_seo`, `movie_subtitle`, `movie_description`, `movie_tmdb_id`, `movie_imdb_id`, `movie_homepage`, `movie_runtime`, `movie_original_language`, `movie_revenue`, `movie_budget`, `movie_release_date`, `movie_status`, `movie_seasons`, `movie_episodes`, `movie_type`, `movie_genres` ) VALUES ( 1602235046, 1602235046, 1, '37.98.196.145', 1602235046, 1602235046, 4, 1, false, 0, 0, 0, 0, 0, 0, 0, 0, 0, 'Poyraz Karayel', 'poyraz-karayel', NULL, '', 65163, NULL, 'https://www.kanald.com.tr/poyraz-karayel', NULL, NULL, 0, 0, '2015-01-07', 'Ended', 3, 190, 'tv', '18,10759' )
IPS\Db\Exception: Column 'movie_runtime' cannot be null (1048)
#0 /home/diziask/public_html/system/Db/Db.php(948): IPS\_Db->preparedQuery()
#1 /home/diziask/public_html/system/Patterns/ActiveRecord.php(487): IPS\_Db->insert()
#2 /home/diziask/public_html/applications/movies/modules/front/movies/view.php(315): IPS\Patterns\_ActiveRecord->save()
#3 /home/diziask/public_html/system/Dispatcher/Controller.php(90): IPS\movies\modules\front\movies\_view->addMovie()
#4 /home/diziask/public_html/system/Content/Controller.php(50): IPS\Dispatcher\_Controller->execute()
#5 /home/diziask/public_html/applications/movies/modules/front/movies/view.php(37): IPS\Content\_Controller->execute()
#6 /home/diziask/public_html/system/Dispatcher/Dispatcher.php(152): IPS\movies\modules\front\movies\_view->execute()
#7 /home/diziask/public_html/index.php(13): IPS\_Dispatcher->run()
#8 {main}

 

And now seems that I messed everything. I tried from Admincp-> Support-> Something is not going well, and it found some database errors. Choosing "Fix Automatically", i redirected to a messed screen like below. Any time and with any browser I'm visiting admin area I'm getting the same:

image.png.74f7679b69369b2bf0be54f945cb5493.png

Public area works fine.

 

Edited by ChrisTERiS
Link to post
Share on other sites

movie_runtime has 0 as default value. Not sure why NULL is passing for it. I’ll check it out and fix for next version. I’ll provide the fix as file edit as I’m not planning a new version for now.

Regarding the CSS, that happens everyday with a lot of people and a MySQL error on front end won’t strip all your CSS from the Admin CP. The only solution IPS provides is run the support tool. If it’s not solving, then I suggest you to submit a ticket. 

Link to post
Share on other sites
4 minutes ago, Adriano Faria said:

movie_runtime has 0 as default value. Not sure why NULL is passing for it. I’ll check it out and fix for next version. I’ll provide the fix as file edit as I’m not planning a new version for now.

Regarding the CSS, that happens everyday with a lot of people and a MySQL error on front end won’t strip all your CSS from the Admin CP. The only solution IPS provides is run the support tool. If it’s not solving, then I suggest you to submit a ticket. 

From what you're saying, this issue must be relevant to MySQL strict_mode. Don't know if it makes any sense but this was an insert from the "Add Movie" feature seeing the Crew tab of another movie. First 5-6 imports saved without any issue. For a moment I thought that maybe I had any custom field required. But checked in database and no one was required.

Link to post
Share on other sites
Just now, ChrisTERiS said:

From what you're saying, this issue must be relevant to MySQL strict_mode. Don't know if it makes any sense but this was an insert from the "Add Movie" feature seeing the Crew tab of another movie. First 5-6 imports saved without any issue. For a moment I thought that maybe I had any custom field required. But checked in database and no one was required.

Thanks. This app adds records in 3 different places. Knowing where it is will help. I’ll check all of them anyway.

Stuart mentioned a fix in the Community Map about the CSS issue. I mean, I think he’s talking about it and not about the app. 
 

Make sure you have this patch.

Link to post
Share on other sites
4 minutes ago, Adriano Faria said:

Thanks. This app adds records in 3 different places. Knowing where it is will help. I’ll check all of them anyway.

Stuart mentioned a fix in the Community Map about the CSS issue. I mean, I think he’s talking about it and not about the app. 
 

Make sure you have this patch.

Yes I know....... I had such issues years ago. Actually, if I remember well, always was after running that "Support" option and selecting to Auto fix the problems.

 

Link to post
Share on other sites
Posted (edited)

@ChrisTERiS, can you tell me the name of the tv show and the language used so I can try the fix?

------------------

EDIT: Got it from your error. The fix is simple. Via FTP, download and open the file applications\movies\modules\front\movies\view.php and find:

$movie->runtime = $time;

Change to:

$movie->runtime = $time ?: 0;

Save and upload.

Edited by Adriano Faria
Link to post
Share on other sites

Data are updating periodically from TMDB, or they stay as is after the initial save? Actually I want to update number of episodes as many of them are wrong. I can do it directly to database, but I'm wondering if I'll loose these changes in a future data update from TMDB.

PS: Fix works fine. Thank you.

Link to post
Share on other sites
17 minutes ago, ChrisTERiS said:

Data are updating periodically from TMDB, or they stay as is after the initial save? Actually I want to update number of episodes as many of them are wrong. I can do it directly to database, but I'm wondering if I'll loose these changes in a future data update from TMDB.

PS: Fix works fine. Thank you.

There’s a reimport data in Movie Actions menu. It will update all data saved, which is everything except the tabs content. 

Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy