Jump to content
Announcing Achievements! ×

Community

No such file or directory - migration


Ohanzee
 Share

Recommended Posts

Hello!

We have migrated our forum to the new server.

Database was transferred with mysqldump. Files were transferred with scp (zipped). Our wordpress site working good, but when we try to access forum it says: No such file or directory

Screenshot_1.png.2b1b19d0d25e7b78dbb4e6dc5f4f04b7.png

 

What can be a problem? 

I can't find any log with more information.

 

Note: Directory path was changed. From: .../balkans1/.../forum to .../admin/.../forum

 

Thank you!

Edited by Marko Krunic
Link to comment
Share on other sites

20 hours ago, Morrigan said:

Did you update the conf.global file? As well 500 errors normally mean configuration issues too. This could be that the folder is at 777 and the folder can only be 755 (suPHP).

Thank you for your answer! Mysql details? Yes, everything is fine there. Which folder? I didn't changed permission of any folder, it is the same as on old server.

 

17 hours ago, Miss_B said:

Have a look at this link as well. 

 

Thank you for your answer! Already checked, nothing for help there...

Link to comment
Share on other sites

2 minutes ago, Morrigan said:

While they may be the same on the last server, doesn't mean they are correct. suPHP, for example doesn't like 777 folder permissions (that could be a difference). You don't have a standard server log of what's happening?

I checked right now, only folder 'themes' have 777 permission, all other folders in forum directory have 755. Some files have less than 755.

I can't find any log about this problem... Im using debian 9, can that be a problem?

 

Link to comment
Share on other sites

@Marko Krunic since you've just migrated to a new server, and as @Daniel F said above your problem is with SQL connection. You must setup the same username and password form the SQL connection you were using on old server, and it must have permission to the same database name you are using. 

You can get those information from conf_global.php

 

$INFO = array (
  'sql_host' => 'localhost',
  'sql_database' => 'databasename',
  'sql_user' => 'username',
  'sql_pass' => 'password',

 

Link to comment
Share on other sites

4 minutes ago, Marko Krunic said:

Hmm, im 100% sure that credentials are correct.

But, i have same problem with roundcube, credentials in config files are okay but it can't connect to DB.

 

If you have a MySQL socket path defined in your conf_global.php, it's worth checking that the path is still correct for your new server.

Link to comment
Share on other sites

Yeah, that was a problem! Anyway, i changed system to CentOS, everything works perfect now!

 

I have one more question, what exactly do i need to do to enable this cURL? PHP version is 7.4 but it still saying this: You do not have the cURL PHP extension loaded or it is running a version less than 7.36. Enabling the cURL module provides a more efficient and reliable library for making connections from your website to other websites.

 

I can't find any theme on forum for this.

Link to comment
Share on other sites

40 minutes ago, Marko Krunic said:

Yeah, that was a problem! Anyway, i changed system to CentOS, everything works perfect now!

 

I have one more question, what exactly do i need to do to enable this cURL? PHP version is 7.4 but it still saying this: You do not have the cURL PHP extension loaded or it is running a version less than 7.36. Enabling the cURL module provides a more efficient and reliable library for making connections from your website to other websites.

 

I can't find any theme on forum for this.

Are you managing the server yourself? If so you can enable it at the php.ini. Otherwise contact your host and ask them to enable it.

Link to comment
Share on other sites

1 hour ago, Marko Krunic said:

Yeah, that was a problem! Anyway, i changed system to CentOS, everything works perfect now!

 

I have one more question, what exactly do i need to do to enable this cURL? PHP version is 7.4 but it still saying this: You do not have the cURL PHP extension loaded or it is running a version less than 7.36. Enabling the cURL module provides a more efficient and reliable library for making connections from your website to other websites.

 

I can't find any theme on forum for this.

 

Which Centos version you are using ?

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy