Jump to content
You're invited! Join our 4.6 Live Event on ZOOM 6/24 ×

Community

Member Map


Martin A.

Recommended Posts

How do I do that.  I clicked on the link you provided.  It took me to a topic about Zoom levels and API codes and a bunch of other stuff that does not apply to my question.  I saw no place to start a topic or ask a question. 

MemberMapNoPlaceToPost.thumb.jpg.e6d4d0a7186cc7c6f4165d3e468b170e.jpg

Please keep in mind.  I do not understand how this whole place works.  I am just trying to get an answer to my question.  Please be moderate with your disgust for my lack of knowledge on how this place works.  It is set up way different then my community.  If you wish to have a look go to HotAirBalloonist.com.

Please do not tell me what I am doing wrong.  Tell me HOW to get my issue fixed.

Jeff

Link to comment
Share on other sites

HI Everyone,

I do not know how to start a topic in this forum so I must simply post a reply.  I have some issues with the Member Map program on my site.  I made a short video to show what I am having issues with.

My site is www.hotairballoonist.com.

The video can be found at https://www.hotairballoonist.com/Video/MemberMapNOSync.mp4

 

I thank you for any advice.  Please take into consideration I am not a developer.  I fly balloons.  I understand just enough to get by and now and then a stroke of brilliance and I really screw things up.

Thank you.

Capt Jeff.

 

Link to comment
Share on other sites

@Lindy @Mark @Morrigan

Could we get this topic/posts moved to the MemberMap support topic please?

16 hours ago, CaptJeff said:

How do I do that.  I clicked on the link you provided.  It took me to a topic about Zoom levels and API codes and a bunch of other stuff that does not apply to my question.  I saw no place to start a topic or ask a question. 

MemberMapNoPlaceToPost.thumb.jpg.e6d4d0a7186cc7c6f4165d3e468b170e.jpg

Please keep in mind.  I do not understand how this whole place works.  I am just trying to get an answer to my question.  Please be moderate with your disgust for my lack of knowledge on how this place works.  It is set up way different then my community.  If you wish to have a look go to HotAirBalloonist.com.

Please do not tell me what I am doing wrong.  Tell me HOW to get my issue fixed.

Jeff

As you have done here Jeff, within that topic there is a reply button or if you scroll down you’ll see the reply box. Just simply type your question as a normal post.

Link to comment
Share on other sites

On 4/15/2020 at 9:19 PM, CaptJeff said:

 

Hi Jeff,

The list on the right hand side will only show your members, grouped by the member group they belong in. The Ride Operators marker you use as an example is what would be named a "custom marker", or a "non-member marker", these do not show up on that list.

The reason you don't see category for Registered guests when you go do Browse Markers is because all markers that are "member markers" is placed inside the Members category. A member can only have one "member marker", and having all those located in the same category is the easiest way (from a programming point of view) to ensure they can only have one.

Hope this made sense to you 🙂 

Edited by Martin A.
Link to comment
Share on other sites

  • 3 weeks later...

Unless I am missing something, i do not see a way to have a map block on a page. It would be great as the Member Map supports addresses from Pages. The map that can contain those exists, so i would love to be able to embed it. If not possible and no plan for it, can a link be generated to only show one group of markers?

 

And one more feature request: Ability to set different markers for different Databases/Categories in Pages

thank you!

Steve K.

Link to comment
Share on other sites

  • 1 month later...

@Martin A., how can I mark all the markers as "read" for a specific user (me)? Can I run a MySQL script? Can I visit a page and "mark all read" or something?

https://thesandtrap.com/membermap/markers/group/1-members/

That's a page with a bunch of markers listed, and many/most of them are "unread." I'd like to clear them all out as "read." I can select them all, but can't mark them as read. I can feature them, hide them, etc.

Link to comment
Share on other sites

You can only have one member marker

Is possible create more than one marker?

I would like create a stores directory of my city...or this app is just for one marker by member?

I can see the MapQuest video showing the Partial Search tool and alternative route tool, how can I apply these features in my members map?

Link to comment
Share on other sites

9 hours ago, kmk said:

You can only have one member marker

 

I think I understand that just is limit setting for Members Markers category.

 

Someone can explain a little more below option?

---Group member markers by member group?

---Hide location for member markers

Link to comment
Share on other sites

On 6/22/2020 at 1:53 AM, iacas said:

@Martin A., how can I mark all the markers as "read" for a specific user (me)? Can I run a MySQL script? Can I visit a page and "mark all read" or something?

https://thesandtrap.com/membermap/markers/group/1-members/

That's a page with a bunch of markers listed, and many/most of them are "unread." I'd like to clear them all out as "read." I can select them all, but can't mark them as read. I can feature them, hide them, etc.

Hi. I added this to the feature list for the next update. It should have behaved like the forums does, where you can click the icon on the category listing. I'll have to see why it's not doing that.

The safest way to make it as read would be to mark your entire community as read.

 

16 hours ago, kmk said:

I am considering spend time to play this app, I have a question, what happen with this app if one day @Martin A. Can't continue support more? 

Given the number of downloads and active users this app have, I'm fairly certain the rights to it will be given to someone else.

14 hours ago, kmk said:

You can only have one member marker

Is possible create more than one marker?

I would like create a stores directory of my city...or this app is just for one marker by member?

I can see the MapQuest video showing the Partial Search tool and alternative route tool, how can I apply these features in my members map?

You answered the first one on your next post. The limit is there since the marker in the "Member Markers" category is used other places on the site, such as the mini map in your profile.

4 hours ago, kmk said:

I think I understand that just is limit setting for Members Markers category.

 

Someone can explain a little more below option?

---Group member markers by member group?

---Hide location for member markers

The first one is for the list of markers in the sidebar. That list will only list markers from the member markers category, and you can have that list combined into groups defined by the member group. With that setting off you the list will be grouped by staff, following/friends and other members.

For the second one I can't really explain it better than the settings description already does.
"Some markers reveal the exact address for some members. Enable this to hide this information from all member markers. Markers in other groups are not affected"
This affects both the marker popup and the marker page itself.

Link to comment
Share on other sites

I have created some Marker Groups, in desktop version can see the button Add Marker, but in mobile version the button Add Marker is missing. This is urgent for me, I have planned request my customers set their delivery address in the Marker, but most of my users (99.9%) use smartphone... 

Link to comment
Share on other sites

Is it normal that my main map and mini-profile map show full hover cards in the marker pop-ups but the map view from the activity notification that is created when a member adds a marker is a plain white popup with just a username?

 

ScreenHunter_705 Jul. 01 10.26.jpg

ScreenHunter_706 Jul. 01 10.27.jpg

Edited by RocketStang
Link to comment
Share on other sites

  • 4 weeks later...

Is there an example kml or kmz file somewhere in this 125 page thread? I’m trying to import markers and I keep getting errors. 
 

I’d also like to give members the option to add location but restricted to “closest major city”, disabling the street address. Is that possible?

cool mod!!!

Link to comment
Share on other sites

I have upgraded to 4.5B10 and while the application works on the front end, I have noticed few glitches in the ACP - inability to add font awesome new icons from the offered list + a few other ones. Would it be possible to share any plans regarding upgrade of the application? Many thanks in advance.

PS. I am receiving similar error message to this one:
image.png.518194166b126a74784dd850cabdf58e.png

Edited by svit
Link to comment
Share on other sites

On 7/31/2020 at 5:55 PM, Adam.M said:

Is there an example kml or kmz file somewhere in this 125 page thread? I’m trying to import markers and I keep getting errors. 

It should work if the kml/kmz is exported from Google Earth. Google may have changed the format without me knowing. Send me the file and I'll see what I can do to fix it.

On 7/31/2020 at 5:55 PM, Adam.M said:

I’d also like to give members the option to add location but restricted to “closest major city”, disabling the street address. Is that possible?

cool mod!!!

I'll look into this when the time comes to update this app.

19 hours ago, Adam.M said:

Or, is there a way to download the current markers? I've tried multiple formats of kml and kmz and I keep getting errors.

@Martin A. , just an FYI there is no link to this support topic on the download page. At least not that I could see.

There is currently no way to export the markers for use in other programs. Your only option is to export the database tables starting with "membermap_". 

I'll fix the link to the support topic when the 4.5 update is uploaded.

14 hours ago, svit said:

I have upgraded to 4.5B10 and while the application works on the front end, I have noticed few glitches in the ACP - inability to add font awsome new icons from the offered list + a few other ones. Would it be possible to share any plans regarding upgrade of the application? Many thanks in advance.

I'll start the work on the 4.5 compatibility update when they're done with the beta phase.

On 7/2/2020 at 9:27 PM, RocketStang said:

Can anyone tell me how to set the default map view to the USA and Europe?  I can figure out how to set the bounding box and all that??

You want both the US and Europe to be in the same view? My first thought was to set the bounding box to "Santa Cruz das Flores", which is an island in the middle of the Atlantic. But since the zoom level setting is a maximum setting, and not a minimum, it would only focus on that island regardless. What does it look like it you don't define the bounding box at all?

On 7/1/2020 at 1:17 PM, RocketStang said:

Is it normal that my main map and mini-profile map show full hover cards in the marker pop-ups but the map view from the activity notification that is created when a member adds a marker is a plain white popup with just a username?

 

ScreenHunter_705 Jul. 01 10.26.jpg

ScreenHunter_706 Jul. 01 10.27.jpg

It was normal. Mainly because all the other information in the popup was available in the rest of the page. I have changed this in the 4.5 update to show the same popup content.

On 6/27/2020 at 4:48 AM, kmk said:

I have created some Marker Groups, in desktop version can see the button Add Marker, but in mobile version the button Add Marker is missing. This is urgent for me, I have planned request my customers set their delivery address in the Marker, but most of my users (99.9%) use smartphone... 

Thank you for letting me know, I'll get this fixed for the upcoming version.

On 6/27/2020 at 1:48 AM, kmk said:

1. Is possible add notification for comments and reviews?

2. Is possible add more Direct Access to the Marker Message Box? example, I would like place there my Store link, my clubs list...

 

1. I'll get that fixed.

2. For member markers you can select profile fields that are shown in the popup, but your request might be fore other markers? 

 

 

Sorry for the late response, people. After IPS updates this forum to 4.5 I were no longer following this topic, and as a result I never got any notifications about your questions.

Link to comment
Share on other sites

1 hour ago, Martin A. said:

I'll start the work on the 4.5 compatibility update when they're done with the beta phase.

Since IPS are already in 4.5B10, some of us have it installed on our live sites (I know it generally was not recommended, but in real world that's what admins were doing after series of Betas released in order to implement or test the new functionality on their sites) Some application authors have already updated their apps and had them approved in the official 4.5 marketplace. I myself have several of the newly approved apps installed on my live sites. I am mentioning this as I think it is really safe to update the apps  being a developer and that the admins/clients would greatly benefit from apps being upgraded. I am afraid that it may more than another month to have the final 4.5 released, which could be far to long for many admins.

 

Thanks for your consideration.

Edited by svit
Link to comment
Share on other sites

1 hour ago, Martin A. said:

It should work if the kml/kmz is exported from Google Earth. Google may have changed the format without me knowing. Send me the file and I'll see what I can do to fix it.

I will attach a sample file that produced the error. I'd like to create multiple marker groups this way, so it wouldn't do any good to send you one file to fix.

 

Test kml downloaded from Google maps. (attached)

 

Error:

TypeError: Argument 2 passed to IPS\membermap\modules\admin\membermap\_markers::_parseKmlPlacemark() must be an instance of IPS\membermap\modules\admin\membermap\object, instance of IPS\Xml\SimpleXML given, called in /home/site/public_html/forums3/applications/membermap/modules/admin/membermap/markers.php on line 302 (0)
#0 /home/site/public_html/forums3/applications/membermap/modules/admin/membermap/markers.php(302): IPS\membermap\modules\admin\membermap\_markers->_parseKmlPlacemark(Array, Object(IPS\Xml\SimpleXML), 'Unbenannte Eben...')
#1 /home/site/public_html/forums3/applications/membermap/modules/admin/membermap/markers.php(177): IPS\membermap\modules\admin\membermap\_markers->_parseKml(Array, Object(IPS\Xml\SimpleXML), 'Unbenannte Eben...')
#2 /home/site/public_html/forums3/system/Dispatcher/Controller.php(85): IPS\membermap\modules\admin\membermap\_markers->import()
#3 /home/site/public_html/forums3/system/Node/Controller.php(62): IPS\Dispatcher\_Controller->execute()
#4 /home/site/public_html/forums3/applications/membermap/modules/admin/membermap/markers.php(40): IPS\Node\_Controller->execute()
#5 /home/site/public_html/forums3/system/Dispatcher/Dispatcher.php(152): IPS\membermap\modules\admin\membermap\_markers->execute()
#6 /home/site/public_html/forums3/admin/index.php(14): IPS\_Dispatcher->run()
#7 {main}

 

Google Earth seems to be a hard way to create a new kml, but I did it for testing anyway. Attached as "test kml.kml", following error occured:

 

TypeError: Argument 2 passed to IPS\membermap\modules\admin\membermap\_markers::_parseKmlPlacemark() must be an instance of IPS\membermap\modules\admin\membermap\object, instance of IPS\Xml\SimpleXML given, called in /home/site/public_html/forums3/applications/membermap/modules/admin/membermap/markers.php on line 309 (0)
#0 /home/site/public_html/forums3/applications/membermap/modules/admin/membermap/markers.php(309): IPS\membermap\modules\admin\membermap\_markers->_parseKmlPlacemark(Array, Object(IPS\Xml\SimpleXML), 'New group')
#1 /home/site/public_html/forums3/applications/membermap/modules/admin/membermap/markers.php(177): IPS\membermap\modules\admin\membermap\_markers->_parseKml(Array, Object(IPS\Xml\SimpleXML), '')
#2 /home/site/public_html/forums3/system/Dispatcher/Controller.php(85): IPS\membermap\modules\admin\membermap\_markers->import()
#3 /home/site/public_html/forums3/system/Node/Controller.php(62): IPS\Dispatcher\_Controller->execute()
#4 /home/site/public_html/forums3/applications/membermap/modules/admin/membermap/markers.php(40): IPS\Node\_Controller->execute()
#5 /home/site/public_html/forums3/system/Dispatcher/Dispatcher.php(152): IPS\membermap\modules\admin\membermap\_markers->execute()
#6 /home/site/public_html/forums3/admin/index.php(14): IPS\_Dispatcher->run()
#7 {main}

 

I was able to import my Google Earth kmz into Google Maps with no problem, so I assume the file is not the issue. Appreciate the help! And happy to donate if you plan to continue supporting this project. 🙂 

Dive Site Collection.kmz.kmz test kml.kml

Link to comment
Share on other sites

9 hours ago, svit said:

Since IPS are already in 4.5B10, some of us have it installed on our live sites (I know it generally was not recommended, but in real world that's what admins were doing after series of Betas released in order to implement or test the new functionality on their sites) Some application authors have already updated their apps and had them approved in the official 4.5 marketplace. I myself have several of the newly approved apps installed on my live sites. I am mentioning this as I think it is really safe to update the apps  being a developer and that the admins/clients would greatly benefit from apps being upgraded. I am afraid that it may more than another month to have the final 4.5 released, which could be far to long for many admins.

 

Thanks for your consideration.

It was also a different way of saying that I wont run through rings of fire to get this free app updated before I have dealt with my private clients 🙂 

If you read between the lines here, you may have noticed that I say that some bugs are fixed. That might be a hint. Maybe. 

9 hours ago, Adam.M said:

I will attach a sample file that produced the error. I'd like to create multiple marker groups this way, so it wouldn't do any good to send you one file to fix.

 

Test kml downloaded from Google maps. (attached)

 

Error:


TypeError: Argument 2 passed to IPS\membermap\modules\admin\membermap\_markers::_parseKmlPlacemark() must be an instance of IPS\membermap\modules\admin\membermap\object, instance of IPS\Xml\SimpleXML given, called in /home/site/public_html/forums3/applications/membermap/modules/admin/membermap/markers.php on line 302 (0)
#0 /home/site/public_html/forums3/applications/membermap/modules/admin/membermap/markers.php(302): IPS\membermap\modules\admin\membermap\_markers->_parseKmlPlacemark(Array, Object(IPS\Xml\SimpleXML), 'Unbenannte Eben...')
#1 /home/site/public_html/forums3/applications/membermap/modules/admin/membermap/markers.php(177): IPS\membermap\modules\admin\membermap\_markers->_parseKml(Array, Object(IPS\Xml\SimpleXML), 'Unbenannte Eben...')
#2 /home/site/public_html/forums3/system/Dispatcher/Controller.php(85): IPS\membermap\modules\admin\membermap\_markers->import()
#3 /home/site/public_html/forums3/system/Node/Controller.php(62): IPS\Dispatcher\_Controller->execute()
#4 /home/site/public_html/forums3/applications/membermap/modules/admin/membermap/markers.php(40): IPS\Node\_Controller->execute()
#5 /home/site/public_html/forums3/system/Dispatcher/Dispatcher.php(152): IPS\membermap\modules\admin\membermap\_markers->execute()
#6 /home/site/public_html/forums3/admin/index.php(14): IPS\_Dispatcher->run()
#7 {main}

 

Google Earth seems to be a hard way to create a new kml, but I did it for testing anyway. Attached as "test kml.kml", following error occured:

 


TypeError: Argument 2 passed to IPS\membermap\modules\admin\membermap\_markers::_parseKmlPlacemark() must be an instance of IPS\membermap\modules\admin\membermap\object, instance of IPS\Xml\SimpleXML given, called in /home/site/public_html/forums3/applications/membermap/modules/admin/membermap/markers.php on line 309 (0)
#0 /home/site/public_html/forums3/applications/membermap/modules/admin/membermap/markers.php(309): IPS\membermap\modules\admin\membermap\_markers->_parseKmlPlacemark(Array, Object(IPS\Xml\SimpleXML), 'New group')
#1 /home/site/public_html/forums3/applications/membermap/modules/admin/membermap/markers.php(177): IPS\membermap\modules\admin\membermap\_markers->_parseKml(Array, Object(IPS\Xml\SimpleXML), '')
#2 /home/site/public_html/forums3/system/Dispatcher/Controller.php(85): IPS\membermap\modules\admin\membermap\_markers->import()
#3 /home/site/public_html/forums3/system/Node/Controller.php(62): IPS\Dispatcher\_Controller->execute()
#4 /home/site/public_html/forums3/applications/membermap/modules/admin/membermap/markers.php(40): IPS\Node\_Controller->execute()
#5 /home/site/public_html/forums3/system/Dispatcher/Dispatcher.php(152): IPS\membermap\modules\admin\membermap\_markers->execute()
#6 /home/site/public_html/forums3/admin/index.php(14): IPS\_Dispatcher->run()
#7 {main}

 

I was able to import my Google Earth kmz into Google Maps with no problem, so I assume the file is not the issue. Appreciate the help! And happy to donate if you plan to continue supporting this project. 🙂 

Dive Site Collection.kmz.kmz 101.07 kB · 0 downloads test kml.kml 2.96 kB · 0 downloads

Thanks. I've fixed this for the upcoming release.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy