Jump to content

Dangerous PHP Functions Enabled


Recommended Posts

image.png.c1b05563102f5e160c429b2efbfa731d.png

Does anyone have any experience getting rid of this message? I tried contacting my host and I can't remember whether they had fixed it or not. I switched to PHP 7.4 on cPanel, but it's not currently supporting ioncube and I noticed this warning again after switching back to PHP 7.3

Link to comment
Share on other sites

You need to add these functions to the disable_functions setting in your php.ini configuration to disable the message.

If you're still seeing the message, that means the change has not yet been applied.

If your host can do this for you themselves, just contact them again and ask them to disable the functions listed here.

Switching PHP versions would mean switching PHP configurations as well, so it makes sense you might see it appear again after switching versions.

Link to comment
Share on other sites

9 minutes ago, Makoto said:

You need to add these functions to the disable_functions setting in your php.ini configuration to disable the message.

I don't fully understand the steps on how to do that, otherwise I'd try it myself.

Where do I go to edit my php.ini configuration? I would think these functions would show on "Select PHP Version" in cPanel where I see others, but these aren't listed there.

Link to comment
Share on other sites

1 minute ago, Pescao6 said:

I don't fully understand the steps on how to do that, otherwise I'd try it myself.

Where do I go to edit my php.ini configuration? I would think these functions would show on "Select PHP Version" in cPanel where I see others, but these aren't listed there.

Do you see anything under WHM >> Home >> Software >> MultiPHP INI Editor ?

If you're running the latest version of cPanel, you should see this available in WHM and you can edit your php.ini configuration here.

Link to comment
Share on other sites

In that case if you're using php-fpm or another CGI manager you'll need to restart that instead of just the web server.

But yeah feel free to contact your host and just forward them the above request, they should be able to do it for you no problem.

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...