Jump to content

Searching not working on all topics after import


PizzaNapo
 Share

Recommended Posts

Hello,

We've migrated successufiily forums_topics; forum_posts; ...etc from another IPS DB (older version), and everything worked fine, except the searching resulats which are giving random results:

 

- for new topics created on the new ips installation, searching works fine

- for old imported topics, searching is totally random, some searchs are working and some are not.

We tried to move, the topics, hoping it will force indexing them, but it worked partially.

If we edit the title of a topic, then change it back to it's original state, then it works. but as you can imagine, we can't do this manually on every single topic.

Could you please tell me how could we fix this problem, or may be how to force re-indexing the topics/posts for getting the search results work again?

 

Thanks in advance

Link to comment
Share on other sites

Go to ACP -> Content Discovery, Search -> click the link in the upper right to "Rebuild Search Index".

If that does not fix the issue, though..... how, exactly, did you "migrate" the posts and topics from an older database? (The only native provision to merge two instances of IPS is to use the converter app, but the two instances must be running the same version of IPS.)

Link to comment
Share on other sites

Many thanks, now that you gave me the answer, I feel stupid, because I could'nt see this menu !

The search function is working perfectly now.

We basically exported the tables forums_forums, forums_topics, forums_posts and core_members. compared the structure of the new DB, ran some scripts for adapting, and imported in the new DB + some additional adjustments. 

Thanks again for your help!

 

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...