Jump to content

Duplicate language string


Sonya*
 Share

Recommended Posts

  • 3 weeks later...
1 hour ago, bfarber said:

Those language strings aren't defined in Pages as far as I can tell.

They are not used, that's right, but they are there and prevent saving the translated string. This is a fresh install:

screenshot-localhost-2020_03.09-21_16_56.png.c5434c39e623d224c335682005e7b966.png

This is another example:

screenshot-2020_03.09-21_14_08.png.97ca6ef7ec34191bc7a8d3665ec9c69d.png

Probably you can run a SQL to get those double keys to eliminate them? 🙄

Link to comment
Share on other sites

If I open applications/cms/data/lang.xml, there are no instances of "r__menu" anywhere. I am unsure how you have those in your database, perhaps this was an issue in a much older version and it has since been corrected, I can't be certain. I would recommend you simply clean them up in your own database if they're present and posing an issue.

I cannot find "read_more_about" or "task__publish" in Blog. Again, those may be older language string entries we've already cleaned up but didn't outright delete. I would recommend cleaning them up yourself in your own database if they're posing an issue.

(It is also possible there are changes in 4.5 that explain the difference, I am checking our working release and not 4.4.10).

Link to comment
Share on other sites

4 hours ago, TheSonic said:

It would be nice to have some tools do show us outdated phrases.... I also have some old ones because i translate since 4.0 alpha....

There are no issues, but some cleanup should be good for all of us 🙂

+1 , this is a pain for non English board . language need to be updated some how when update board , same with plugins . should be translatable same as apps

some cleanup and tools we sure need .... 

Link to comment
Share on other sites

19 hours ago, bfarber said:

I cannot find "read_more_about" or "task__publish" in Blog. Again, those may be older language string entries we've already cleaned up but didn't outright delete. I would recommend cleaning them up yourself in your own database if they're posing an issue.

I have deleted the strings with SQL from MY installations. But this is definitely something that IPS has caused in the previous versions. I have checked some older installations (also those I have not setup or customized but have an admin access to), they all have these strings defined. 😏 

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...