Jump to content

Community

Sign in to follow this  
DesignzShop

Let us keep color changes

Recommended Posts

When creating a theme if we (devs) change one of the pre-defined IPB colors (example: body background) while in designers mode the change stays until the theme is re-installed. After a client re-installs the theme the color doesn't revert back to IPB's however it does show a revert button that will change back to IPB's stock color.

I can't even say how many times I'll get notice from someone asking what color went where in those stock fields after they've changed it or reverted it back thinking it would revert back to my themes stock color.

Please allow themes to keep the new themes colors (changes) and get rid of the revert button

Thank You

Share this post


Link to post
Share on other sites

@Rikki or @Matt or @bfarber

Is this a bug that should be reported or is this WAI? It keeps the custom colors without adding a revert button to the stock colors from IPB after leaving designers mode, just not when it's installed fresh.

Kind Regards

Edited by DesignzShop

Share this post


Link to post
Share on other sites
22 minutes ago, Matt said:

Yeah, I can see how this would be annoying.

So you want it so if you install a theme from an XML file, then the colours are locked and no revert button shown?

I reported a bug that would not allow you to keep custom settings within a theme when installing from the XML file, specifically custom fonts. If I change edit the theme and update the core, these custom settings are removed.

Share this post


Link to post
Share on other sites
28 minutes ago, Matt said:

Yeah, I can see how this would be annoying.

So you want it so if you install a theme from an XML file, then the colours are locked and no revert button shown?

Yes Sir, thank you Matt.

Share this post


Link to post
Share on other sites
2 hours ago, Matt said:

Yeah, I can see how this would be annoying.

So you want it so if you install a theme from an XML file, then the colours are locked and no revert button shown?

I just want to clarify to the word locked here Matt. Not sure how everyone else feels about locked but what I meant was I wanted the colors we put into the stock IPB fields to stay the color we chose to make them then act like the rest of the color fields afterwards. So if someone for example didn't like a button color we created, they could then change that and at that point when they change it then the revert button should show and the revert button should at that point remember the color the developer made it instead of the IPB stock color. Hope that explains it better.

Thank You

Share this post


Link to post
Share on other sites

This would be an interesting as a needed fix to say the least. I have seen this time and time again where a customer can install a customized theme make a few edits - decide these edits are unacceptable hit the revert button. Rather than a template reverting back to its custom settings  of the custom theme it will normally revert back to the IPB default.

In the worse case scenario a customer not thinking will attempt editing on a live board rather than setting up a test board.

Share this post


Link to post
Share on other sites
On 1/18/2020 at 12:16 PM, DesignzShop said:
19 hours ago, DesignzShop said:

No, they can't. Please read the first post.

while in designers mode the change stays until the theme is re-installed.

What I mean is if the theme is reinstalled, it WILL restore the theme settings, so this is potential solution to the issue (although I do see your point about the revert button issue).

Share this post


Link to post
Share on other sites
On 1/28/2020 at 5:40 PM, Matt said:

Good news! This suggestion made it onto our internal list.

Are you going to fix the custom fonts bug which I reported a couple of months ago please? I was told that it had been fixed, but it is still there, even worse, custom settings for themes are removed when the suite is updated.

Share this post


Link to post
Share on other sites
18 minutes ago, TDBF said:

Are you going to fix the custom fonts bug which I reported a couple of months ago please? I was told that it had been fixed, but it is still there, even worse, custom settings for themes are removed when the suite is updated.

There's an internal suggestion for this

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy