Jump to content

Community

Warning newest update 4.4.9.2 contains changes to Stripe.php


SJ77
 Share

Recommended Posts

Hi,

It's not mentioned at all in the release notes but the Stripe.php file has significant changes in the newest release.

These changes totally broke stripe for me and caused me to lose a lot of payments.

Just a heads up if some folks have not upgraded yet and might be impacted by this

 

Thank you 🙂

Link to comment
Share on other sites

9 minutes ago, Christforums said:

What changes were needed in order to make Stripe functional? Last night I added Stripe as a payment gateway. Do I need change anything since I enabled stripe well after the latest Invsion update?

I am not trying to freak you out. Just because it didn't work for me doesn't mean it won't work for you.

I only wanted to give a heads up in case folks who are sensitive to stripe changes can decide if they want to wait or not to install the update.

IF you're not really up and running, just move forward and see how things work.

Edited by SJ77
Link to comment
Share on other sites

Could you say how and what broke for you with stripe? As it's quite a sensitive part of the app, no one should upgrade if they use stripe based on your warning. But I can't judge how serious the warning is from the information you have provided so far.

Maybe someone from IPS can clarify the issue.

Link to comment
Share on other sites

32 minutes ago, opentype said:

No problems over here. 

1656940303_Bildschirmfoto2020-01-07um20_19_55.png.c26abeee68fef30c94043c5667115205.png

I believe the issue is caused by this line

	'confirm'				=> 'true',

Setting it to false would likely fix it for me. I wonder why you are not having similar results.

For now I fixed my entire issue by uploading an old version of Stripe.PHP

I had it backed up.

Edited by SJ77
Link to comment
Share on other sites

20 minutes ago, Martin A. said:

The change was a silent patch in 4.4.9.1, and not part of the 4.4.9.2 release. Probably why it's not mentioned anywhere.

 

Great research!

I am glad you found this because it in part explains why things are being tampered with. However, something is still wonky.

I don't know why it was documented like that because I have the stripe file from 4.4.9.1 and 4.4.9.2 and I can assure you these changes were not applied until this new release. I can clearly see in my Dashboard the exact minute I completed my upgrade this morning is when everything went sideways. All sales started failing.

Perhaps there was a change in 4.4.9.1 and 4.4.9.2 with the latter being what caused issue here.

Thank you 🙂

Edited by SJ77
Link to comment
Share on other sites

The underlying issue is that the required Stripe web hook hasn't been configured, which means that Invision Community isn't being notified about payment events as it is expected to be.

We're looking into making the web hook configuration automatic in future versions, so if it's mis-configured or not configured at all, we'll automatically correct the issue.

Link to comment
Share on other sites

On 1/7/2020 at 7:18 PM, SJ77 said:

Every purchase made using Stripe shows up as uncaptured.  *nightmare for me*

stripe fail.JPG

Did you manage to fix this issue? If not, the solution is to go into Admin CP, Payments, Stipe, and at the bottom you need to add the webhook, there should be a button to add it. Follow the instruction with the link to the end point, and select to 'receive all events' that should hopefully fix it for you. 

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy