Jump to content

Installing Redis PHP 7.3 Extension

Recommended Posts

9 hours ago, Upgradeovec said:

pecl install redis - was enough for my env with php-fpm 7.3.3

The initial instructions required phpize. That continually failed on my environment. From what I understand it was because I did not have php7.3dev installed. Not positive but installing the php module from WHM PECL allowed me to successfully install.

Anyhoot, up and running now!

Thanks to everyone that helped,

Link to comment
Share on other sites

  • 4 months later...
On 7/3/2019 at 3:45 AM, Christforums said:

Thought this may help. I was unable to run the instructions above successfully until the PECL module for PHP 7.3 was made available in WHM: https://www.christforums.com/forums/topic/24818-invision-ips4-install-redis-memory-cache-with-php-73-on-centos-7/?tab=comments#comment-92399


But I have 4 questions/problems:

1) REDIS is not recognisable by AdminCP (not clickable to set as cache system), even if it's running on the server:

[root@dual ~]# redis-cli ping
[root@dual ~]#

2) On EasyApache 4 there is no REDIS phpextension to install. I did only the:

In WHM go to Software>>Module Installers>>PHP PECL and search for Redis under PHP 7.3.
[root@dual ~]# /opt/cpanel/ea-php73/root/usr/bin/pecl install igbinary igbinary-devel redis
Ignoring installed package pecl/igbinary
Ignoring installed package pecl/igbinary
Ignoring installed package pecl/redis
Nothing to install

3) How to setup REDIS password?

4) I have also noticed that following the step by step yum install, it's not installed the latest 5 version of REDIS on server, but the version 3. Is it ok?

Package redis-3.2.12-2.el7.x86_64 already installed and latest version
Nothing to do


Link to comment
Share on other sites



Module Installers -> PHP PECL (Click Manage) --> search for redis and you will get something like:

PHP extension for interfacing with Redis

Just click install

Restart Apache and Php and check...


For the password just edit your redis.conf  and search for:

# requirepass foobared

Then uncomment it and change foobared to your password. Setting a password locally is not really needed...

Restart Redis service.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...