Jump to content

Community

day_

4.4.4 Notification Feedback

Recommended Posts

Having been told this is now working as intended in 4.4.4 I just wanted to give some feedback on the new notification system. It's bizarre, bonkers and a backwards step just like when the popup search menu was refreshed and removed search within this topic on mobile. 

If I receive any notification for a reaction, quote, mention even automatic moderation I must now fully read the topic before it marks as read, and if I receive further notifications for other posts in the same topic, previously read notifications will revert to showing as unread.

For example.

I have a 10 page topic. 

I have only read 6 pages but receive a reaction for a post on page 3. 

On opening the notification and seeing Bob gave me a like, I navigate back to the homepage to view something else. The notification for the reaction is still showing as unread. The only way to dismiss this notification would be to read the remaining 4 pages of the topic.

Even if I do this then make a post on page 10 which I receive a notification of a reaction for later, the earlier notification on page 3 will show as being unread again until I am fully caught up with the topic.

Yes I can understand opening the notification menu marked all notifications as read wasn't great, but this is far worse now and it's confusing my members. I even put a notice up to say notifications are broken, we are aware bare with us whilst we fix because I was getting so many messages. I now have to go back and say guess what, this is working fine.

I'm sorry IPS, you're great and everything you really are, but this, this is terrible. 

Share this post


Link to post
Share on other sites
Posted (edited)

If I'm following a forum and a new topic is made, I get the notification "Member posted a topic in such and such Forum: Things"
Just clicking that link should be enough for the notification to become read. I shouldn't have to read the whole topic as this is just the notification that a new topic was made, so surely should work different to a normal topic link?

Edited by marklcfc

Share this post


Link to post
Share on other sites
Posted (edited)

I had to see it for myself on my site as it wasn't registering with me. So now if I read the full topic and the notification becomes read, if someone then later posts in it, that notification becomes unread again? Thats not good..

Edited by marklcfc

Share this post


Link to post
Share on other sites
Posted (edited)

Not sure if this is advisable but I have reverted the change listed in theme difference from 4.4.3 to 4.4.4 for notificationsAjax and appears to be working as it did before if anyone else is frustrated.

Edit: this only restores the old behaviour in the popup, when opening up the full notification page it's still the new wonky system

280156452_Screenshot2019-06-07at23_57_55.thumb.png.75bff52e8dc355a011935ee7b1ede326.png

FWIW I hope you guys can figure out a way to immediately mark as read once the individual notification has been clicked, and doesn't revert to showing as unread later. Having all notifications mark as read on open was/is a minor frustration. 

 

Edited by day_

Share this post


Link to post
Share on other sites

Reverting the theme change will do no harm. The notifications page itself actually hasn’t changed it has always been this way just you were less likely to notice it as most simply use the pop up.


We are discussing this change internally.

Share this post


Link to post
Share on other sites
3 minutes ago, Andy Millne said:

Reverting the theme change will do no harm. The notifications page itself actually hasn’t changed it has always been this way just you were less likely to notice it as most simply use the pop up.

 

We are discussing this change internally.

Thank you, I did make a change to the notificationsRow template for the main notification page on row 4 replacing

<li class='ipsDataItem {{if $notification['data']['unread']}}ipsDataItem_unread{{endif}} ipsClearfix'>

with

<li class='ipsDataItem {{if !$notification['notification']->read_time}}ipsDataItem_unread{{endif}} ipsClearfix'>

It works. But as you say it's not a page I or expect other members visit that often to notice

Share this post


Link to post
Share on other sites
On 6/8/2019 at 12:08 AM, day_ said:

Not sure if this is advisable but I have reverted the change listed in theme difference from 4.4.3 to 4.4.4 for notificationsAjax and appears to be working as it did before if anyone else is frustrated.

Edit: this only restores the old behaviour in the popup, when opening up the full notification page it's still the new wonky system

280156452_Screenshot2019-06-07at23_57_55.thumb.png.75bff52e8dc355a011935ee7b1ede326.png

Done this now as got a few complaints too

Share this post


Link to post
Share on other sites
Posted (edited)

We got a lot of complains too. The notifications now is a mess.
We also installed the patch and they are even worse now.

Edited by Jirinex

Share this post


Link to post
Share on other sites

Hi, one more here

Members ara confused with the "new system", which seems to be perfect for them prior 4.4.4

Maybe notification behaviour could be a parameter in the PCAdmin ?

Share this post


Link to post
Share on other sites
32 minutes ago, Cybero said:

which seems to be perfect for them prior 4.4.4

Let’s be honest it wasn’t “perfect”, notifications were better pre 4.4.4, but still had room for improvement. 

It would be nice for notifications not to be automatically marked as read just because you open up the notification pop up, and only marked as read when clicked on.

If they can figure that one without this having to load the last page, or reappearing, perfection will be achieved. 

Share this post


Link to post
Share on other sites
41 minutes ago, Milan Mlade said:

The update cost me 500$ in one day by the new email notifications. How can we solve this? 

Screen Shot 2019-06-10 at 15.22.18.png

What you are describing is different from what is being discussed in this topic.

I am unaware of any issues sending email notifications that would explain a sudden jump in sending emails upon upgrading, but if you believe there's an issue I would encourage you to submit a ticket in your client area for official support.

Share this post


Link to post
Share on other sites
3 hours ago, jair101 said:

Kind bump as my users also started to immediately revolt once I upgraded to 4.4.4.

I'm sure we can find a non-dimissable banner to hold back the peasant horde.

Kidding! 

IPS is reviewing the feedback in this topic about notifications, so feel free to share your thoughts and concerns about 4.4's update on notifications. 

Share this post


Link to post
Share on other sites

Yeah, not a fan, I thought there was an issue with my install. I'll be doing the work around mentioned higher up in this thread. 

What was the actual aim of this change? Can't work it out.

Share this post


Link to post
Share on other sites

Clubbing of notification - i.e. if multiple members like same post - notification clubbing would be nice!  But half read and half unread notification is driving nuts to many users on our forums. Thank you

 

 

 

Share this post


Link to post
Share on other sites

Additionally, notifications modal window on this community invisioncommunity.com starts to be very slow. I have to wait 5-10 seconds till the list of notifications is shown (when clicking on the notifications icon in the header).

Share this post


Link to post
Share on other sites
7 hours ago, Sonya* said:

Additionally, notifications modal window on this community invisioncommunity.com starts to be very slow. I have to wait 5-10 seconds till the list of notifications is shown (when clicking on the notifications icon in the header).

You may want to try disabling your ad blocker for this site to see if that potentially is causing the slowness.

Share this post


Link to post
Share on other sites
Posted (edited)
3 hours ago, Joy Rex said:

You may want to try disabling your ad blocker for this site to see if that potentially is causing the slowness.

I do not use ad blocker. Nor for this site neither for others. Nothing installed here.

Edited by Sonya*

Share this post


Link to post
Share on other sites
On 6/28/2019 at 10:04 AM, Sonya* said:

Additionally, notifications modal window on this community invisioncommunity.com starts to be very slow. I have to wait 5-10 seconds till the list of notifications is shown (when clicking on the notifications icon in the header).

I want to +1 that. There has been a delay with notifications with the IPS site for quite a while, now its getting worse. On my own community there are no such issue. 

Share this post


Link to post
Share on other sites
20 hours ago, jair101 said:

I want to +1 that. There has been a delay with notifications with the IPS site for quite a while, now its getting worse. On my own community there are no such issue. 

For me somehow here, it's fast, super fast. 

Share this post


Link to post
Share on other sites
3 hours ago, AlexJ said:

For me somehow here, it's fast, super fast. 

Hmmm, I have issues on the desktop and mobile as well. It seems to be depended on account (settings?). I have 31 pages of notifications. And I have weird behavior:

  • There are no new notifications on the icon, but if I open a list of notifications then I see a lot of unread notifications. So, unread != new?
  • I have "unread" notifications even for the posts where I have left a reaction. That does not make sense, if I have reacted to the post, then I have at least technically read it :biggrin:

 

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...