Jump to content

Community

Cookie Issue


HighlanderICT
 Share

Recommended Posts

I had a user approach me about a problem he and his son encounter on our site. They use a shared computer and have different login accounts. When one is finished he logs out and the other attempts to login. This used to work fine but now fails. After logging out, when the alternative account details are entered  the site does nothing then eventually comes back with a 500 or 524 error via cloudflare.  If the user takes the extra step of clearing cookies from the site after he logs out, the other user can logon as normal. 

I was able to reproduce the issue myself using my admin account and a test account. 

We do have a constants.php but there are no cookie settings in it that I can see ....

define( 'REPORT_EXCEPTIONS', true );
define( 'REDIS_ENABLED', false );
define( 'STORE_METHOD', 'Database' );
define( 'STORE_CONFIG', '[]' );
define( 'CACHE_METHOD', 'None' );
define( 'CACHE_CONFIG', '[]' );
define( 'CACHE_PAGE_TIMEOUT', 600 );
define( 'SUITE_UNIQUE_KEY', '<value>' );

 

In the error logs I do see a timeout which matches the time when the user gets timed out. 

[17-Apr-2019 13:50:55 UTC] PHP Fatal error:  Maximum execution time of 90 seconds exceeded in /home/<site>/public_html/system/Db/Db.php on line 600

 

Its not a huge deal as there is a workaround/solution but it would be nice if we could make it work like it used to where one user logged out and the next user could login without jumping through all sorts of hoops .....   Any suggestions ? 

 

 

 

Link to comment
Share on other sites

 Share

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy