Jump to content

Better SEO and Rewrite URL Troubleshooting


Gaius Kong
 Share

Recommended Posts

Update: this is resolved. 

 

(Arguably, for better SEO results, one can put the installation in a folder rather than use a subdomain. However, Google representatives say they would treat the same.)

So I use the following url: https://www.mydomain.com/bbs (rather than https://bbs.mydomain.com). Rewrite URL doesn't work. "Not Found The requested URL /bbs/store/ was not found on this server."  My .htaccess file reads the following:  

 

<IfModule mod_rewrite.c>

Options -MultiViews

RewriteEngine On

RewriteBase /bbs/

RewriteCond %{REQUEST_FILENAME} !-f

RewriteRule \.(js|css|jpeg|jpg|gif|png|ico|map)(\?|$) /bbs/404error.php [L,NC]

 

RewriteCond %{REQUEST_FILENAME} !-f

RewriteCond %{REQUEST_FILENAME} !-d

RewriteRule . /bbs/index.php [L]

</IfModule>

 

Could anyone troubleshoot which line should be amended, please?  

Edited by Gaius Kong
Link to comment
Share on other sites

It looks more or less correct. I have the following locally (my installation is in a folder named "suite") and it works fine

<IfModule mod_rewrite.c>
Options -MultiViews
RewriteEngine On
RewriteBase /suite/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule \.(js|css|jpeg|jpg|gif|png|ico|map)(\?|$) /suite/404error.php [L,NC]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /suite/index.php [L]
</IfModule>

I would recommend verifying mod_rewrite is enabled, and that you can use .htaccess files (AllowOverrides enabled as I recall in your Apache configuration).

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...