Jump to content

Back up not working


Recommended Posts

I've download everything from my db/hosting


1. Reinstalled my OS


2. Uploaded forum again.
3. Installed all plugins such as ;

PHP Version
cURL extension
Multibyte String
DOM extension
GD extension
MySQLi extension
OpenSLL extension
Session extension
SimpleXML extension
XML extension
XMLReader extension
XMLWritter extension
Phar extension
128 memor limit.

4.  777 permissions to this files.





IPS\File\Exception: CANNOT_WRITE (3) #0 /var/www/html/forum/system/File/File.php(311): IPS\File_FileSystem->save() #1 /var/www/html/forum/system/Theme/Theme.php(5109): IPS_File::create('core_Theme', '05e81b71abe4f22...', ' @media screen ...', 'css_built_1') #2 /var/www/html/forum/system/Theme/Theme.php(2481): IPS_Theme::writeCss(Array) #3 /var/www/html/forum/system/Theme/Theme.php(603): IPS_Theme->compileCss('core', 'global', 'responsive', 'responsive.css') #4 /var/www/html/forum/system/Dispatcher/Standard.php(57): IPS_Theme->css('responsive.css', 'core', 'global') #5 /var/www/html/forum/system/Dispatcher/Admin.php(92): IPS\Dispatcher_Standard::baseCss() #6 /var/www/html/forum/system/Dispatcher/Dispatcher.php(109): IPS\Dispatcher_Admin->init() #7 /var/www/html/forum/admin/index.php(14): IPS_Dispatcher::i() #8 {main}





Link to comment
Share on other sites

Go to the ACP directly via /admin on the URL. Hopefully the ACP will still work.

If it does run the 'Support' tool, only as far as clearing cached data out etc. Then try the front end again.

If this is not possible / does not work please submit a ticket in the Client Area for assistance. :)

Link to comment
Share on other sites

IPS\File\Exception: CANNOT_WRITE

This error implies the software is attempting to write a file (a CSS file) and cannot, likely due to folder or file permissions. You will need to ensure your storage directory (and all files and folders underneath it) are writable - the folder by default is "uploads" in your root community folder. If you are not familiar with how to do this, you can contact your host for assistance.

Link to comment
Share on other sites

I'm not sure if your pathing in the error is correct or not, i.e. that is where you have or expect those files to be stored, but this will at least give you the ability to update Storage Settings configuration if you can get in the unformatted AdminCP.

Last night I ran into issues restoring/importing my live server backup to my local machine to test the upgrade from 4.3.6 to 4.4.1.  My AdminCP loaded without decoration (white and unformatted like you described yours) with the same type of errors trying to save theme files.  However in my case, the Storage Settings directories were still pointing to my live server path and couldn't save files properly locally.  I grabbed the URL for the Storage Settings >> Configuration from my live server and then append the path to my localhost URL to get access to these settings (with the fugly unformatted AdminCP).  Once I got there, I could update the storage paths to my local host file system paths and everything loaded OK.  The links on my local AdminCP to get there just wouldn't work, so I had to create the direct URL to get there and it wouldn't load every time (a lot of times getting that same type of save file error).

  1. Log into your AdminCP in order to get your base URL and adsess session id.
  2. Update the link with your information and enter it in the address bar of your browser:

You may continue to get intermittent errors like you posted (I did too) but eventually with enough reloads/retries of submitting the URL it actually loaded the target URL and AdminCP page where I could edit the pathing.

Alternately I'm guessing these configurations could be changed directly in the DB, although I haven't looked for where that is since the above approach worked out for me.





Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...