Jump to content

Brilliant Discord Integration


SoftwareFactory

Recommended Posts

18 hours ago, AdamBryant95 said:

Hello! I just bought your product today. It's awesome. But i can't disable the Discord login method. Whem i trying off i got this message: "The application settings provided are not correct."

Hello,

Thank you for reaching out! We are glad that you like our app. Please go to https://discord.com/developers/applications and choose the application you have configured in Brilliant Discord Integration. Then open the OAuth2 tab in its Settings, click the "Copy" button below Client secret (not Client ID).

Now open your ACP, and in Brilliant Discord Integration's Configuration page, paste what you have just copied into the "Client secret" field". Click Save, and check again whether you can disable the Discord login method.

If this did not help, please open the Brilliant Discord Integration's Logs page, click "Download Debug Information" and send me that file in a private message, so I can provide further help.

If you ever have any other questions, require assistance in a different matter or just want to share feedback of any kind, please let us know 🙂

Edited by SoftwareFactory
Link to comment
Share on other sites

27 minutes ago, SoftwareFactory said:

Please go to https://discord.com/developers/applications and choose the application you have configured in Brilliant Discord Integration. Then open the OAuth2 tab in its Settings, click the "Copy" button below Client secret (not Client ID).

Now open your ACP, and in Brilliant Discord Integration's Configuration page, paste what you have just copied into the "Client secret" field". Click Save, and check again whether you can disable the Discord login method.

Thank you. It worked! 🙂

Link to comment
Share on other sites

Hi there, having an issue with the Notifications. I created one to test, and it worked.

So I deleted it and created a new notification, but when I click on save I get the following error:
 

Quote

5SBR105/1 Something went wrong. Please try again.

image.png.48d1447e037bc06764aa4c8b7488372e.png

image.thumb.png.333e46894ccb99ca731c1c96b4c8ef28.pngThe logs show a 403 error, but I've re-configured my app and it worked with no errors

Thank you.

Link to comment
Share on other sites

1 hour ago, snags said:

Hi there, having an issue with the Notifications. I created one to test, and it worked.

So I deleted it and created a new notification, but when I click on save I get the following error:
 

image.png.48d1447e037bc06764aa4c8b7488372e.png

image.thumb.png.333e46894ccb99ca731c1c96b4c8ef28.pngThe logs show a 403 error, but I've re-configured my app and it worked with no errors

Thank you.

Hello,

Thank you for reaching out. I am sorry to hear that you experienced issues with Notifications, and glad that you was able to resolve them. Could you please go to Logs again, click Download Debug Information and send me that file in a private message? This would help us to prevent this from happening in the future. Thank you!

Link to comment
Share on other sites

On 9/17/2021 at 12:59 AM, SoftwareFactory said:

Hello,

Thank you for reaching out. I am sorry to hear that you experienced issues with Notifications, and glad that you was able to resolve them. Could you please go to Logs again, click Download Debug Information and send me that file in a private message? This would help us to prevent this from happening in the future. Thank you!

Hey there,

Sorry you may have misunderstood or I have worded that poorly. To clarify, notifications are currently not working.

This is what I did:

  1. Install the app
  2. Set it up with our discord
  3. Linked my discord account
  4. Created a notification and tested it (it worked)
  5. Deleted the previous notification that I created in step 4, and I created another one -> It did not work
  6. Tried to create another notification -> same error message
  7. Tried to create another notification to a different discord channel/webhook -> same error message

I'll send you the logs in a DM 🙂

Thank you

UPDATE: I just realized what the problem was, my discord bot did not have permissions to post or manage webhooks in the channel I was trying to create a webhook/notification in.

I've added the permissions and it's now working - Thanks again.

Edited by snags
Link to comment
Share on other sites

  • 2 weeks later...

Hi there,

I've purchased this plugin., I have to respect how to easy it was to setup though I am currently having some problems with the integration with forum groups and discord roles. I've made it so if someone is assigned Forum Secondary role of Supporter it will give them a supporter role in discord. It will not sync across even when doing a mass synchronisation. 

For the role to sync does it need to be a primary group on forum or can it be a secondary?

Thanks

Link to comment
Share on other sites

17 hours ago, Bailey Hall1 said:

Hi there,

I've purchased this plugin., I have to respect how to easy it was to setup though I am currently having some problems with the integration with forum groups and discord roles. I've made it so if someone is assigned Forum Secondary role of Supporter it will give them a supporter role in discord. It will not sync across even when doing a mass synchronisation. 

For the role to sync does it need to be a primary group on forum or can it be a secondary?

Thanks


If you go to the purchase item and give them the benefit of giving them the said role, then this works out well. If you just assign them a role on the site side, it does not seem to just copy to discord side I noticed. Otherwise when you associate it with a purchase its instant and never fails.

Link to comment
Share on other sites

On 9/26/2021 at 8:09 AM, Bailey Hall1 said:

Hi there,

I've purchased this plugin., I have to respect how to easy it was to setup though I am currently having some problems with the integration with forum groups and discord roles. I've made it so if someone is assigned Forum Secondary role of Supporter it will give them a supporter role in discord. It will not sync across even when doing a mass synchronisation. 

For the role to sync does it need to be a primary group on forum or can it be a secondary?

Thanks

Hello,

Thank you for reaching out. It does not matter if the group is primary or secondary. Please go to the Logs page in your ACP, click Download Debug Information and send me the file in a private message so that I can assist you further. Sorry for this inconvenience.

On 9/27/2021 at 1:17 AM, Schaken said:

If you go to the purchase item and give them the benefit of giving them the said role, then this works out well. If you just assign them a role on the site side, it does not seem to just copy to discord side I noticed. Otherwise when you associate it with a purchase its instant and never fails.

This is interesting. Could you follow the instructions above to download the logs and then send me that file? Thanks.

Link to comment
Share on other sites

Hello,

I'm also encountering the issue where everything seems to be configured correctly (bot at top of the role list, secret/app key in place, redirect link added) but it keeps sending me back to step 1 from step 2. It's even saying in step two that everything is correct.

How do I fix this?

Edited by Ryan Yuan
Link to comment
Share on other sites

Just now, Ryan Yuan said:

Hello,

I'm also encountering the issue where everything seems to be configured correctly (bot at top of the role list, secret/app key in place, redirect link added) but it keeps sending me back to step 1 from step 2. It's even saying in step two that everything is correct.

Hello,

Thank you for reaching out. This is a known issue. If you reopen the Configuration page and start the initial configuration process again, it will most probably work properly.

If you have any further questions, please let me know.

Link to comment
Share on other sites

19 minutes ago, AlexJ said:

I see new version is released but i am on same version already? Yes, I didn't update. Any issues with versioning? 

There is no app update. App’s screenshots needed to be reuploaded, because they suddenly disappeared from its Marketplace page, for an unknown reason. I recognize this may be confusing, but that’s just how Marketplace works.

Link to comment
Share on other sites

1 hour ago, SoftwareFactory said:

Hello,

Thank you for reaching out. This is a known issue. If you reopen the Configuration page and start the initial configuration process again, it will most probably work properly.

If you have any further questions, please let me know.

Thanks for the quick response. Restarting the configuration process completely from a new page did appear to fix the issue.

Link to comment
Share on other sites

Hello again,

I'm trying to integrate this app with a discord server that already has a rather large population of users. I understood that roles would not be brought in from the server to the forum when a user registers, but was unaware that when registering a new user through the discord sign-in that all of their previously set roles would be removed (there's no mention of this happening in the readme).

The community in question has thousands of members and dozens of roles, so you can understand why this interaction is unworkable. Is there any way in-app to disable this? There's an option to disable nickname synchronization, it would be great if you could also disable the role synchronization since not everyone will be operating with the forum being the primary form of a community.

If there's no way in-app to do this, then the second question I would have is: would disabling the Manage Roles permission for the bot be an acceptable workaround? I don't know the inner workings of the code, so I don't know if this would simply have graceful errors during the synchronization or flat out break the application, but it sounds like it could work for the immediate.

Thank you.

Link to comment
Share on other sites

Does using v11 for the bot cause problems? It looks like nobody can use the sign up per Discord button and I have no idea why. They just endlessly load and appear in the member list with no name and marked as to be deleted soon.

Link to comment
Share on other sites

@SoftwareFactory could you please add a new menu item in acp where it says 'Discord Users' then it shows all forum members who have linked their Discord and what their Discord name/id is?

There has been plenty of scenarios where people has linked their account and abused our Discord, we'd like to ban them from our forum as well but that's impossible.

If there was like a new menu item in the Discord addon that allows us to view all members, or even look up Discord ID to find the forum member - that'd be perfect!

 

Edited by OctoDev
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...