Jump to content

Error 500 When Upgrading from 4.3.6 to 4.4


iacas
 Share

Recommended Posts

I have IPS 4.3.6 on two sites.

Today I decided to upgrade my much smaller site to 4.4. I have no plugins and only one application - Auto Welcome - and I upgraded it to a 4.4 compatible version.

Then I uploaded all of the 4.4 files. I hit up /acp_dir/upgrade/. Error 500. I tried /acp_dir/. 500. I tried the site itself: Error 500.

Looking at /uploads/logs/ I see this:

Sun, 24 Feb 2019 19:33:38 +0000
ParseError: syntax error, unexpected '?', expecting variable (T_VARIABLE) (0)
#0 [internal function]: IPS\IPS::autoloader('IPS\\Request')
#1 /var/www/vhosts/evolvr.com/httpdocs/system/Dispatcher/Front.php(394): spl_autoload_call('IPS\\Request')
#2 /var/www/vhosts/evolvr.com/httpdocs/system/Dispatcher/Front.php(38): IPS\Dispatcher\_Front->checkCached()
#3 /var/www/vhosts/evolvr.com/httpdocs/system/Dispatcher/Dispatcher.php(109): IPS\Dispatcher\_Front->init()
#4 /var/www/vhosts/evolvr.com/httpdocs/index.php(13): IPS\_Dispatcher::i()
#5 {main}
#0 /var/www/vhosts/evolvr.com/httpdocs/init.php(656): IPS\_Log::log('ParseError: syn...', 'uncaught_except...')
#1 [internal function]: IPS\IPS::exceptionHandler(Object(ParseError))
#2 {main}

I delete everything in /datastore/. Error 500.

I re-download 4.4 from the site and reinstall, deleting everything first and replacing the entire folder instead of merging. Error 500.

I poke around a few files. Init.php has too many changes from 4.3.6 to try to bother. I restart Apache. Error 500. I restart MySQL. Error 500. I restart the entire server. Error 500.

I even back up and blank out conf_global.php and create a new blank database. I go to /acp_dir/install/ to try to re-install a new version of the site (thinking I could then at least narrow it down to a database issue?). Error 500.

Thankfully, I had a 4.3.6 backup since you can't download it from IPS, so I delete everything but /uploads/ from my site and reinstall my 4.3.6 files.

The site works perfectly well again.

------

This little site doesn't have Blog or Gallery. It has just Forums, Downloads, Commerce, and Pages. Maybe there's something goofy with that configuration. I don't know… but something is off, and I'm going to be VERY hesitant to want to upgrade to 4.4 again on this site, let alone my much, much larger site.

Link to comment
Share on other sites

ParseError: syntax error, unexpected '?', expecting variable (T_VARIABLE) (0)
#0 [internal function]: IPS\IPS::autoloader('IPS\\Request')

Frankly, this sounds like a file wasn't uploaded correctly, or your PHP version is out of date.

PHP 7.1+ is required for 4.4.

This error relates to system/Request/Request.php, so you should be sure that file uploaded completely.

Link to comment
Share on other sites

8 minutes ago, Owdy said:

I think ill waite for 4.4.1

Installing from within the application - rather than doing it manually by uploading the files - worked fine.

On my larger site - https://thesandtrap.com/ - I am getting some warnings about the theme, so I'm going to hold off for a bit until I'm absolutely certain that's fine. I'll also hold off until I have a fresh database backup and a backup of the core files on the site.

Link to comment
Share on other sites

4 hours ago, iacas said:

On my larger site - https://thesandtrap.com/ - I am getting some warnings about the theme, so I'm going to hold off for a bit until I'm absolutely certain that's fine. I'll also hold off until I have a fresh database backup and a backup of the core files on the site.

By that I meant when I went through the first step or two of the process - just to see if it passed some checks and things. I didn't even look at the warnings about the theme, but I'd be surprised if much was required as my theme is a child theme, and I've not made many changes to the files, CSS, etc.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...