Jump to content

Fresh install 500 error


Recommended Posts

I've been trying to do a fresh install of 4.3.6 but have experienced a problem that I hope someone can assist me with.

I ran the requirement checker prior to installation and got a green tick for everything.


Installation went fine and I got to the final page which gave links to the suite and admin.



However, when I try either of these links, I get "An error occurred (500 error)" page.

The admin error page also says "Call to a member function language() on null"


I checked the database, re-uploaded all the files, used the recovery mode file (constants.php) and tried a separate test install - all of which resulted in the same outcome.

Does anyone know what is going on here?
Thanks for any help you can provide.

Link to comment
Share on other sites

10 minutes ago, Bulletbrain said:

Thanks for the suggestion Adlago - I've checked all permissions and they are as you suggested but unfortunately no change.

I have submitted a support ticket, just thought I'd try here first.

You can check the content of your htaccess file for incorrect directives.

PS. Also check errors logs in your Cpanel server

Link to comment
Share on other sites

Got a reply this morning from my web host


We thoroughly investigated the error on the website. No errors are reported to the server error log. ModSecurity rules were not triggered as well.
We tried enabling the debug mode and increasing the logging level. Unfortunately, no errors are being reported to uploads/logs.

We would recommend contacting the Invision support to investigate the issue with the error and with no errors being reported by the website. The server is compatible with the application, you can see it on ips4.php , so the issue is somewhere in the code of the application.


Invision support is looking into my problem - thanks to everyone for your suggestions

Link to comment
Share on other sites

Hey guys

Just updating you to let you know that I managed to find the problem myself 😀

I narrowed the problem down to my hosting accounts default root php.ini file.

When I commented out line 854 the forums worked

; Handler used to store/retrieve data.
session.save_handler = files

Not sure why this is a problem as it should default to "files" anyway.
I checked phpinfo.php and it still sets the local and master values to files even with this line removed - problem solved???

Thanks for all your suggestions - they were much appreciated.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...