Jump to content

Anyone else having a problem installing 4.4?


WOFman
 Share

Recommended Posts

Having big issues also.

I was running PHP 7.0 on my site, so I got that message saying that I needed at least 7.1, so went ahead and upgraded to 7.3, but then I got a message saying that IPB could not connect to the MYSQL Database and nothing worked anymore.

Went back to php 7.0, but still the same problem, the forum no longer worked. 😞

Had to fix mysql tables, optimise them and thankfully that did it. Staying with 4.3 till the smoke clears.

Link to comment
Share on other sites

Well, I guess I won't be upgrading as I need to use 5.x php for my 3.x forum on the same server. Why would you guys do that? Not everyone has the option of 7.x php on their servers. That is just dumb!

Well, I guess this will save me money in the long run since I cannot upgrade I wont need to renew my license.

Link to comment
Share on other sites

7 minutes ago, WOFman said:

Well, I guess I won't be upgrading as I need to use 5.x php for my 3.x forum on the same server. Why would you guys do that? Not everyone has the option of 7.x php on their servers. That is just dumb!

Well, I guess this will save me money in the long run since I cannot upgrade I wont need to renew my license.

FWIW they've had an AdminCP warning about requiring PHP7 in a future release for quite some time now.

Link to comment
Share on other sites

1 hour ago, WOFman said:

Well, I guess I won't be upgrading as I need to use 5.x php for my 3.x forum on the same server. Why would you guys do that? Not everyone has the option of 7.x php on their servers. That is just dumb!

Well, I guess this will save me money in the long run since I cannot upgrade I wont need to renew my license.

PHP 5.6 is no longer supported or receiving security updates from PHP. You may be putting your users and data at risk by continuing to use an unsupported version of PHP.

http://php.net/supported-versions.php

Many platforms do allow multiple PHP versions to function on the same server, it may be worth looking into if that is possible on your server.

Link to comment
Share on other sites

3 hours ago, WOFman said:

Well, I guess I won't be upgrading as I need to use 5.x php for my 3.x forum on the same server. Why would you guys do that? Not everyone has the option of 7.x php on their servers. That is just dumb!

Well, I guess this will save me money in the long run since I cannot upgrade I wont need to renew my license.

Implement multi version php support. If you can’t do it yourself or if your host doesn’t support, use a service like moss.sh, runcloud, Serverpilot if you have a VPS, or find a better host. It’s pretty straightforward these days to run 5.6 alongside 7 series (but you shouldn’t, and you should move off 5.6 ASAP as there are known exploits in the wild now). 

Link to comment
Share on other sites

  • 3 weeks later...

I'm getting the same problem. If I'm in PHP 7.0 then my 4.3.6 site displays but I can't upgrade because I don't meet the minimum requirements. Move it to 7.1, however, and I get a 500. 

[20-Feb-2019 22:24:25 UTC] PHP Fatal error:  Uncaught Error: Call to undefined function IPS\mb_internal_encoding() in /home/esperantoorg/completeesperanto.uk/init.php:142
Stack trace:
#0 /home/xxx/yyy.uk/init.php(890): IPS\IPS::init()
#1 /home/xxx/yyy.uk/index.php(12): require_once('/home/esperanto...')
#2 {main}
  thrown in /home/esperantoorg/completeesperanto.uk/init.php on line 142

I have the same problem with a totally fresh 4.3.6 installation.

I don't get it. How am I supposed to upgrade if the current version won't work with the PHP version that the system demands I have in order to carry out the upgrade routine?

Link to comment
Share on other sites

7 minutes ago, Meddysong said:

I'm getting the same problem. If I'm in PHP 7.0 then my 4.3.6 site displays but I can't upgrade because I don't meet the minimum requirements. Move it to 7.1, however, and I get a 500.  


[20-Feb-2019 22:24:25 UTC] PHP Fatal error:  Uncaught Error: Call to undefined function IPS\mb_internal_encoding() in /home/esperantoorg/completeesperanto.uk/init.php:142
Stack trace:
#0 /home/xxx/yyy.uk/init.php(890): IPS\IPS::init()
#1 /home/xxx/yyy.uk/index.php(12): require_once('/home/esperanto...')
#2 {main}
  thrown in /home/esperantoorg/completeesperanto.uk/init.php on line 142

I have the same problem with a totally fresh 4.3.6 installation.

I don't get it. How am I supposed to upgrade if the current version won't work with the PHP version that the system demands I have in order to carry out the upgrade routine?

Check that mod_security is enable. If yes - disable it

Link to comment
Share on other sites

5 minutes ago, Meddysong said:

I'm getting the same problem. If I'm in PHP 7.0 then my 4.3.6 site displays but I can't upgrade because I don't meet the minimum requirements. Move it to 7.1, however, and I get a 500. 


[20-Feb-2019 22:24:25 UTC] PHP Fatal error:  Uncaught Error: Call to undefined function IPS\mb_internal_encoding() in /home/esperantoorg/completeesperanto.uk/init.php:142
Stack trace:
#0 /home/xxx/yyy.uk/init.php(890): IPS\IPS::init()
#1 /home/xxx/yyy.uk/index.php(12): require_once('/home/esperanto...')
#2 {main}
  thrown in /home/esperantoorg/completeesperanto.uk/init.php on line 142

I have the same problem with a totally fresh 4.3.6 installation.

I don't get it. How am I supposed to upgrade if the current version won't work with the PHP version that the system demands I have in order to carry out the upgrade routine?

This means the mbstring extension isn't installed.

Link to comment
Share on other sites

@Meddysong See this

Quote

I put extension=mbstring.so inside php.ini even though that is no longer the method PHP uses by default to load modules.

From php.ini itself:

Note: packaged extension modules are now loaded via the .ini files found in the directory /etc/php.d; these are loaded by default.

It seemed to fix my problem. I would still be interested to hear if anyone else has a different take on this matter.

From here

https://stackoverflow.com/questions/34471633/cannot-initialize-mbstring-with-php-7

Link to comment
Share on other sites

Yes, but not a white screen. Just downloaded the package from client centre and tried a manual upgrade of my smallest site from 4.3.6 to 4.4.0. Backed up files and DB first.

The installer started but is now stuck displaying a red error box reporting:

/home/mysite/public_html/content/system/Patterns/ActiveRecord.php::142

and options Retry or Continue. Retry does nothing.

PHP7.2.15/MariaDB10.2/CentOS7.

FFS. Gutted. 🤢

It doesn't explain the consequences of selecting Continue or say what the error really means.

Edited by The Old Man
Link to comment
Share on other sites

Thanks, I'm not sure if I need that now but thanks, good to know.

Re plugins, only Headstands Sparkpost app, which I disabled first. It's not 4.4 ready yet.

I tried retry a few times, no joy, then Continue and it gave the same error then on the third attempt it continued on.

It got as far as this:

B269BD31-36F7-499A-9FD0-493B38DF8D90.thumb.jpeg.630d540b88049f1317fcfc7bbf501d89.jpeg

 

It stayed on that for a while then the page page changed to this and carried on...

31352963-ED5B-4331-9B77-0C03D9763A78.thumb.jpeg.76a5a6d7e70b5841ed1d1a48a99dc09b.jpeg

until it eventually completed.

Off to test it.

Link to comment
Share on other sites

I forgot at the time but recently my VPS webhost asked me to remove the "-d memory-limit=-1 " setting from the IPS cronjobs on my server, it has 4 IPS sites on my VPS plus 2 small Wordpress sites and they said the IPS Cron was interfering with CPanel host services by running every minute with the unlimited memory override attribute. So I removed the memory attribute and set the Cron to run every 4 mins.

That may be connected to the upgrade issues I posted above.

So far so good. Few things I noticed...

  • The Support Tool was showing Redis info, but when clicking on Redis Settings, they were all blank, so re-entered them and they saved okay.
  • The default IPS Theme is still called Default IPS 4.3.
2 minutes ago, SJ77 said:

Glad you made it to the end! Click your activity feed. That was giving me a 500 error

Thanks, yep, all of my Activity streams seem okay.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...