Jump to content

Community

PHP 7.3 support


DreamOn
 Share

Recommended Posts

6 minutes ago, DreamOn said:

Hi,

Do you provide PHP 7.3 support soon?

Cause IPS is not compatible with: error code 1S160/2 when trying to browser topics (ex : https://invisioncommunity.com/forums/topic/449276-friendly-reminder-php-56-eol-in-a-month/?tab=comments#comment-2768168).

Thanks.

Invision Community 4.4 will have support for PHP 7.3. Follow our product updates for further information about new features and changes in 4.4.

Link to comment
Share on other sites

  • 9 months later...

I am stuck on 4.2.9 because I rely on a plugin that makes use of IPS Connect which is removed as of 4.3

I just migrated a product to a new server and ran into this issue where I started getting the 1S160/2 error after clearing the topic cache. So I am now forced to leave the forum on an older server that runs PHP 7.2.

I would really like to manually patch my version (4.2.9) to work with PHP 7.3

I do have access to the later releases of IPS. Would anyone be able to give me a clue as to what exactly is causing the issue with PHP 7.3.. or even better if anyone knows specifically what needs to be patched? Would really appreciate it!! Thanks!

Link to comment
Share on other sites

12 minutes ago, vesperknight said:

I would really like to manually patch my version (4.2.9) to work with PHP 7.3

Why? If you are stuck with an older IPS version, sticking with 7.2 as well makes perfect sense and there is nothing wrong with it for the time being. 

Link to comment
Share on other sites

Because now I have to maintain two servers instead of one, I was planning on taking that 2nd server offline. Especially if it's just a matter of patching a line or two to make it compatible with PHP 7.3. It probably isn't much that's changed.. would appreciate it, if someone knows the guilty lines, if they could let me know which ones they are

Link to comment
Share on other sites

29 minutes ago, vesperknight said:

I am stuck on 4.2.9 because I rely on a plugin that makes use of IPS Connect which is removed as of 4.3

I just migrated a product to a new server and ran into this issue where I started getting the 1S160/2 error after clearing the topic cache. So I am now forced to leave the forum on an older server that runs PHP 7.2.

I would really like to manually patch my version (4.2.9) to work with PHP 7.3

I do have access to the later releases of IPS. Would anyone be able to give me a clue as to what exactly is causing the issue with PHP 7.3.. or even better if anyone knows specifically what needs to be patched? Would really appreciate it!! Thanks!

Is your plugin the SSO for WordPress? 

Link to comment
Share on other sites

14 minutes ago, vesperknight said:

@Joel R yes it is, but not the wordpress version, the standalone php version.. IPBWI. I use it extensively on two of my Laravel projects. I would really like to replace it by something that is actively developed and supports the latest IPS versions, in case you know of such a solution

Can you projects accept oAuth 2? 

Otherwise, you might reach out to her developer of the available WordPress SSO plugin in the Marketplace @stoo2000 to see if he can do something for you.  

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy