Jump to content

Community

batarjal

Patreon Integration

Recommended Posts

Further to my previous post, first thing this morning I got this alert on my site:

Quote

Locked Tasks

The following tasks appear to be locking frequently: UpdatePatreon.
Please run them manually. If you require assistance with any errors shown please contact technical support.
2

Maybe this is related to users' trouble connecting Patreon?

Edited by Kim Werker

Share this post


Link to post
Share on other sites

The patreon redirect URL is the one shown in the ACP that has been used to create the client. It is strange that it works for some users but not for others.

If your forum is accessible from different domains you have to add the 'Connect Patreon Account' URLs for all domains (http://{SITE}/index.php?app=patreonintegration&module=system&controller=patreonconnect) comma separated in the client settings from Patreon. Same with any URL rewrites.

You could ask any user with issues what his URL shows on the Connect Patreon Account page and double check if that's the one configured in the Patreon client settings and add it if needed.

The client settings are here:
https://www.patreon.com/portal/registration/register-clients
And Client > Edit Client

Edited by batarjal

Share this post


Link to post
Share on other sites

@batarjal I'll look into it, though I am also getting an error that UpdatePatreon is regularly failing (it looks like the other Patreon tasks are running just fine):

Quote

 

One of the routine maintenance tasks which run in the background has failed several times, which may indicate a configuration issue.

  • Application/Plugin
    Patreon Integration
  • Task
    UpdatePatreon
  • Last Run
    3 hours ago

You should check the logs for any indication of the issue or attempt to run it manually. If the task does not run successfully you should contact the author of the application/plugin for further assistance.

 

 

 

Share this post


Link to post
Share on other sites

@batarjal I'm not sure what to make of the error, but I have a bunch of these:

uncaught_exception RuntimeException (0) LOCATION_UNKNOWN
#0 /var/www/html/f285358/system/Member/Member.php(153): IPS\_Session::i()
#1 /var/www/html/f285358/system/Text/Parser.php(104): IPS\_Member::loggedIn()
#2 /var/www/html/f285358/system/Text/Parser.php(3773): IPS\Text\_Parser->__construct(false, NULL, NULL, false, true, true, NULL)
#3 /var/www/html/f285358/applications/patreonintegration/sources/Parser.php(103): IPS\Text\_Parser::parseStatic('I'm\xC2\xA0<a href="h...')
#4 /var/www/html/f285358/applications/patreonintegration/sources/Campaign.php(49): IPS\patreonintegration\_Parser->parseCampaign(Array)
#5 /var/www/html/f285358/applications/patreonintegration/sources/Campaign.php(77): IPS\patreonintegration\_Campaign::updateCampaign()
#6 /var/www/html/f285358/applications/patreonintegration/tasks/UpdatePatreon.php(16): IPS\patreonintegration\_Campaign::update()
#7 /var/www/html/f285358/system/Task/Task.php(255): IPS\patreonintegration\tasks\_UpdatePatreon->execute()
#8 /var/www/html/f285358/system/Task/Task.php(224): IPS\_Task->run()
#9 /var/www/html/f285358/applications/core/interface/task/task.php(62): IPS\_Task->runAndLog()
#10 {main}

 

Share this post


Link to post
Share on other sites

Hi again. I have a user who's reporting the Connect Patreon Account option is not appearing on iPhone: https://drive.google.com/file/d/1UeNiA_X8jGYde2BSAQ6NZhGlQVy8wvuj/view

She's since connected using a different device, but received a confounding message on the site: https://drive.google.com/file/d/1fiFysiNy2K2q6tvaRf-gLLmSgsN1lpRC/view

First, Kim is not her name (it's mine). Second, she's for sure a Patron.

Any help ironing this out would be much appreciated. Building this site is a major part of our Patreon campaign. :) Thank you!

Share this post


Link to post
Share on other sites

Hi @batarjal. Checking in to see if you have an idea of when fixes might be pushed out? I'm having to walk a lot of my members through the bugs, both when the connection doesn't work right away, and for people trying to do it on mobile who don't see the option at all. I'd really love to stick with the plugin, but if it doesn't work I'm going to have to work around it, which I'd really like to avoid.

Share this post


Link to post
Share on other sites

I'll have a look into both issues today. I wasn't  able to reproduce the first issue yet though and it would help a lot if you could send me an link to your forum + test account via PM.

Share this post


Link to post
Share on other sites

I uploaded a new version which should help with the problems you mentioned:

Quote
  • Added menu button for mobile devices
  • Fixed an issue with background tasks being run by guests

 

Share this post


Link to post
Share on other sites

Hey there @batarjal

I am facing an issue where no patrons are getting a Tier assigned to them.
I saw that there was a previous issue regarding this, but I ensured that the refresh key was correct.
I not seeing any errors related to this in the logs.

Users are also reporting seeing 

Quote

You are connected with Patreon!
You're not supporting our campaign yet! Become a patron. 

Could you help out here?

Share this post


Link to post
Share on other sites
Posted (edited)

If you send me a link to your forum and a test account I can have a look.

Do you get all the campaign information and current goal in the ACP?

The message looks like the user has no active pledge on Patreon, as soon as he adds one the access rights should be assigned.

Edited by batarjal

Share this post


Link to post
Share on other sites
Posted (edited)
18 hours ago, batarjal said:

If you send me a link to your forum and a test account I can have a look.

Do you get all the campaign information and current goal in the ACP?

The message looks like the user has no active pledge on Patreon, as soon as he adds one the access rights should be assigned.

I managed to find the bug.

Essentially, if you do not name your patron tiers, it will show up as blank in terms of how it views it.
This in turn makes it look like you are not pledged to a tier. I guess the logic for the "connect Patreon account" page is off, because users showed up as verified, and got the group, but it said the above error about not having a pledge.

 

Something else that popped up is the following:

We have Moderators who are patron pledged, but we don't want the patron groups to be their main ones.
Is the only solution to this to add them as administrators without any permissions, to circumvent the patron group override?

Edited by Kitty Davis

Share this post


Link to post
Share on other sites
Posted (edited)

You could assign 'extra groups' instead of main groups, that would be for all users and not just for moderators though. Do you think an "Always use 'extra' groups for the following groups'" setting would resolve your issue? There you could add Moderators and any other group and it would use extra groups instead of the main group for those.

The nameless tier issue will be resolved in the next version.

Edited by batarjal

Share this post


Link to post
Share on other sites

Since buying your product and asking all of our users to link up there patreons we have hit an issue. Our issue is that all of the members are pending under the 'Status' section on the admin CP. Any help would be appreciated? 

Share this post


Link to post
Share on other sites

Can you check if there are any issues on the log page? What happens if you run the Patron update tasks manually in the ACP under 'Tasks'.

Share this post


Link to post
Share on other sites

@batarjal Thank you for replying, After looking into the system log I have found this error.

Quote

array (
  'errors' => 
  array (
    0 => 
    array (
      'code' => 1,
      'code_name' => 'Unauthorized',
      'detail' => 'The server could not verify that you are authorized to access the URL requested.  You either supplied the wrong credentials (e.g. a bad password), or your browser doesn\'t understand how to supply the credentials required.',
      'id' => 'e2e46b91-c97f-48ba-9e0c-f11a92754001',
      'status' => '401',
      'title' => 'Unauthorized',
    ),
  ),
  'url' => 'https://www.patreon.com/api/oauth2/api/campaigns/2610060/pledges?page%5Bcount%5D=100&include=patron.null,reward.null&fields%5Bpledge%5D=amount_cents&fields%5Breward%5D=amount&fields%5Buser%5D=full_name',
)

 

Share this post


Link to post
Share on other sites
Just now, batarjal said:

The access token/client id is not valid anymore. It changes whenever you change anything in the API client settings at patreon, so you might need to update it.

Thank you! Been a great help!

Share this post


Link to post
Share on other sites
Posted (edited)

 @batarjal

I'm back again, Is there any way of changing 'Group Mapping' Ignore perms? Instead of just blocking administrator? 

Edited by UtopiaRP

Share this post


Link to post
Share on other sites

@batarjal

Hey there, we have a number of users with the same issue with Pending.

So far we have tried:
- running the IPB cron
- running the patreon 'update pledges' command
- having them delink/relink their account
-updating the tokens

We have multiple users who are set to pending, who gives no errors at the moment.
We have verified that the refresh token etc is valid.

Any help here would be greatly appreciated.

Share this post


Link to post
Share on other sites

Hi @batarjal.

I'm starting a membership drive tomorrow (https://community.kimwerker.com), and wanted to check in about whether the speed with which a user's permissions change after they connect Patreon can be sped up? Several members have told me it takes several minutes for this to happen, which they interpret as a failed connection since it doesn't give them immediate access to to the Patreon-exclusive site features.

Also, in looking at my list of Patreon members in my AdminCP, every member is listed as status "pending", and their Tier information is not listed. Is it possible to fix this?

Thank you!

Share this post


Link to post
Share on other sites
Posted (edited)

Hello!

@Kim Werker, @Kitty Davis

If you send me a link to your forum and a test account I’ll check what’s going wrong.

The access should be granted right after the account is linked, the task that runs every couple of minutes is only used for updating changed pledges.

Edited by batarjal

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...