Jump to content

Community

Can't get developer mode on


JustHatched
 Share

Recommended Posts

On my test site I have added the developer tools (deleted all but forums, core, nexus, calendar as I do not have them from the files)

Added the constants.php file as described here  and no changes appear to happen for make a plug in

 

After some searching I found this page which says the constants.php needs to have <?php added to it, but when I do that it breaks the site. 

 

What am I missing here?

 

Link to comment
Share on other sites

3 minutes ago, All Astronauts said:

<?php
define( 'IN_DEV', TRUE );

That's it.

I've done that, but then I lose all the css.

 

I appreciate the response, I done some searching before and after posting and it appears I am not the only one who has had the issue. I am going to comb thru thru them to find a solution

Link to comment
Share on other sites

4 hours ago, bfarber said:

Did you upload all of the developer tools?

No, I only have forums, commerce and calender. So I only uploaded those plus core. The CSS breaks when I put the constants.php file in. From looking around for a solution the only thing I have found is it could be server related issue but I am not sure how that would be or what to do to fix it atm

Link to comment
Share on other sites

14 minutes ago, Adriano Faria said:

Bfarber is talking about this: 

Have you uploaded it?

 

13 minutes ago, bfarber said:

You need to upload the developer tools in order for CSS, javascript, etc. to work.

Yes I've done that, what I meant in my reply was I did not upload the files for the stuff I dont have (blogs, downloads, etc..) per this link which say "If you do not have every IPS Community Suite application installed, you should delete the folders you don't need from the Developer Tools folder before copying. The presence of Developer Tools for uninstalled applications may cause errors."

 

 

 

 

Link to comment
Share on other sites

13 minutes ago, Nathan Explosion said:

You uploaded the folders for the Apps you have.....mentioned it a few times. But did you upload the DEV folder that goes in the root of the install too?

 

I did

 

The issue has been solved, it was an issue on my server with suhosin, 2 varibles were not what the system recommended, it's fixed now.

Link to comment
Share on other sites

 

On 10/3/2018 at 4:44 PM, JustHatched said:

I've done that, but then I lose all the css.

Just ran into a similar problem, thought I'd share my solution here.

When enabling IN_DEV, its important the correct boolean method is used.

e.g., in my case:

define('IN_DEV',  1);   = nuked css
define('IN_DEV', TRUE); = works fine

Link to comment
Share on other sites

  • 2 years later...

Hi,

I am also having an issue with enabling dev mode (on local XAMPP). I copied all necessary dev folders (except for apps I don't have).

I set all file permissions correctly.

The software still works BUT as soon as I add the IN_DEV setting to constants I get an error for every page:

Whoops \ Exception \ ErrorException (E_WARNING)
session_name(): Cannot change session name when headers already sent

Any ideas?

Edited by Apfelstrudel
Link to comment
Share on other sites

In your constants.php add this

define( 'DEV_USE_WHOOPS', false );

Refresh the page. Typically the error you are seeing is indicative of something occurring low-level triggering a PHP error (I've hit it locally before attempting to use an unsupported version of PHP for instance, as I have to switch around between different versions of things frequently).

I recommend removing the above constant after confirming the underlying error.

Link to comment
Share on other sites

By adding this constant the site works now BUT ...

  • the entire site is in english now although the english language pack is disabled. I can't switch it to my local language although it is being showed as active.
  • All custom SEO urls don't work although they are all listed and activated.
  • All databases don't work anymore. Error code: 256
    ErrorException: You have used a function (count) that should be called from the root namespace for performance reasons (/forum/system/Theme/Theme.php(4465) : eval()'d code::65). (256)

My technical specs of the local XAMPP system:

  • php: 7.4.14
  • mysql: v5.5.5-10.4.17-MariaDB
  • no plugins or add-ons installed

Any tips?

Edited by Apfelstrudel
Link to comment
Share on other sites

6 minutes ago, Apfelstrudel said:

the entire site is in english now although the english language pack is disabled. I can't switch it to my local language although it is being showed as active.

That's intentional, IN_DEV uses the applications/x/dev/lang.php files

7 minutes ago, Apfelstrudel said:

All custom SEO urls don't work although they are all listed and activated.

You'll have to enable this via the DEV_USE_FURL_CACHE constant

8 minutes ago, Apfelstrudel said:

All databases don't work anymore. Error code: 256
ErrorException: You have used a function (count) that should be called from the root namespace for performance reasons (/forum/system/Theme/Theme.php(4465) : eval()'d code::65). (256)

You an disable this by setting the IN_DEV_STRICT_MODE constant to false.

Link to comment
Share on other sites

Thanks Daniel for the support but adding ...

Quote

define( 'DEV_USE_FURL_CACHE', TRUE );

... to constants.php didn't make it. FURLs are still not available.

Obviously all my template changes are not being used because also this won't work in dev mode.

I guess I don't understand the idea behind dev mode in the way it was made for but I just want to create plugins and test them immediately afterwards in my xampp version. But I can't do this because my xampp version doesn't run regarding look and feel as it does live right now.

Sorry devs, don't hit me. I have to learn how to think like a pro. 😄

Link to comment
Share on other sites

  1. DEV = a newly installed site, no customisations other than the ones you are working on IN_DEV
  2. TEST = either a newly installed site, or a copy of your live site, where you install your customisations created IN_DEV (uses -TESTINSTALL version of license)
  3. PROD = your live site (uses your license)
Edited by Nathan Explosion
Link to comment
Share on other sites

 Share

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy