Jump to content

Sparkpost ending TLS v1.0 support


Recommended Posts

What am I supposed to do about this?

Looks like I am using TLS

How do I know if it's the right version of TLS or not?




You are receiving this operational notification because you have a SparkPost account.

We previously announced that SparkPost will deprecate TLSv1.0 on June 30. We have extended this date to July 9 in order to give some customers additional time to update their injection code to use a newer protocol: TLSv1.1 or TLSv1.2.

We are deprecating TSLv1.0 in order to meet an important industry-wide security standard. Starting on July 9, all API calls made to SparkPost must use TLSv1.1 or higher or they will fail with an authentication error.

In an effort to help our customers with the transition, we’ve set up test endpoints that will reject any API calls that do not use TLSv1.1 or higher. You can use these endpoints to inject email traffic (or make other API calls) using your current software. If it's on TLSv1.0, the traffic will be rejected. If it's on TLSv1.1, the traffic will be accepted. These endpoints are described in this support article.

We are working hard to make sure the transition is a smooth one.

- The SparkPost Team




Link to comment
Share on other sites

The Sparkpost extension did not force a certain version of TLS. The version used will most likely come down to your server configuration (e.g. how openssl is setup, how curl is setup, those sorts of things). Generally speaking, if they stop supporting TLS1.0 then a newer version should be used automatically as part of the SSL/TLS handshake process, assuming your server supports a newer protocol version.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...