Jump to content

Directory Parsing Issues/Advice - SMB Share


Recommended Posts


I'd like to either get some advice if possible, or report a possible bug with IPS 4.2.x with regard to dealing with directories on SMB shares.

I have a test installation located on an SMB share, with the html root of the website located on a share like so:


The problem is, regardless of any variation of the above path I enter into the constants.php for either the Datastore or Temp directory, IPS creates all the files in the wrong location. Specifically, instead of creating the files here:


... it creates it here instead:


of course, this results in a multitude of issues, and ultimately an installation that is very difficult to use given the CSS and Javascript is not located where it is supposed to be. Clearly, IPS is creating the files and directories in the wrong location. And yes, permissions on the SMB share are not a problem.

I have attempted numerous different ways to type it out, including forward-slashes, back-slashes, and every possible combination in between and have been attempting to diagnose this issue for nearly two days-- all to no avail.

At my wits end, I decided to write a quick and small PHP script to test it out myself, just to see if it was some server configuration issue:


$testdir = '\\\\smbserver.domain.net\\web\\ips4\\html\\test\\dir1';
$testfile = 'file.txt';

mkdir( $testdir );
file_put_contents( $testdir . '\\' . $testfile, 'This is a test file.' );

echo "Done.";


The script worked flawlessly, and created the directory and file correctly, as such:


Thus, here I am writing to see if anyone has any advice, or if this is some bug that has any plans to be fixed sometime soon. I've searched everywhere on the forums, and on Google, to no avail as well.

The server is running the 64-bit version of PHP 7.0.21 on Windows 2016 Server Datacenter. I realize there has traditionally been limited support for Windows/IIS installations, but as a developer myself, and knowing how much of a widely-used software that IPS is and how popular Windows and Linux are, the OS shouldn't be such a glaring issue to the point where the software has no way of working properly, so I am hoping there is either some advice someone has, or if this can be noted as a bug and something that is looked at in hopes to be fixed by the release of 4.3.x.



Link to comment
Share on other sites

Never mind-- this can be disregarded as it has been solved.

I previously ran a query through the database to update the file locations to the remote SMB share and for some reason, only NOW did I notice that the path for one of the storage configurations was malarkey--- with a


in the beginning AND in between the remaining path, separating the directories. I updated it to use


in the beginning of the share, and


everywhere else, and now everything appears to function properly.

I am surprised I missed that when I previously checked the DB... but oh well. Now I can finally proceed to test the install on the clustered remote SMB share via iSCSI for high availability.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...