Jump to content

Issues with enabling caching.

Recommended Posts

So I want to enable caching on my site, how do I go about that?

I've installed memcache onto the server and invision now lets me select it as an option for caching but I don't know what server IP to put in. I've tried the VPS IP and other combinations even localhost and it continues to say 'The servers provided are not valid" what can I do??


Link to comment
Share on other sites

Thanks @Nathan Explosion and @DSystem

I FINALLY got it working, turns out it wasn't just a case of installing the memcache module in WHM, I had to use SSH to config the memcached file and set the OPTIONS value to localhost and bumped up the CACHESIZE too. I'm guessing memcache was set up it just wasn't running on localhost or something? But after I did that (after hours of troubleshooting) things finally work.

Thanks again for your help guys! You were right all along Nathan, I just hadn't set it up properly.


Link to comment
Share on other sites

Another reason to use and block the 11211 port at your firewall as Memcached can be abused using the UDP protocol.....

You may also want to use Redis as the latest re work from IPB was great and now it performs a bit better than Memcached :)

More info about the vulnerability can be found here:



Or you can go ahead and upgrade to the latest version that already fix that issue:

Memcached 1.5.6


  • disable UDP port by default
  • systemd instancing support & rpm build improvements
  • fix gcc warnings in beta GCC
  • fix build with clang
  • fix for dtrace compilation on freebsd


All my clients already use that version :)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...