Jump to content

Leaderboard "Days Won" Not Showing Correct Count?


iacas
 Share

Recommended Posts

I had a member who has definitely won many, many days PM me recently to inquire as to why he has, on his profile, only 1 day "won" when he is certain (as am I) that this number was much higher the last time he checked.

I recalculated everyone's reputation, and it remained at 1.

Furthermore, my own total sits at 19, which I know was significantly higher the last time I checked.

------------------------------------------------------------------------------------------------------------------------

It seems as if "days won" counts were reset at the beginning of the new year (January 1, 2018).

Can anyone else speak to this? If so, what the heck?

Link to comment
Share on other sites

7 minutes ago, Adriano Faria said:

Nope, it didn’t reset. You can see here on IPS that the counter is ok.

Recount posts has a bug to be fixed on 4.3, if I’m not mistaken. Not sure about reputation. 

Thanks for the reply.

The "wrong days won" totals were exhibited before I "recounted" reputation. (Plus it was reputation that I recounted, not the posts.)

And yeah, I see here that you have won 214 days… so now I wonder what's gone wrong with my system.

Hmmmm…

  • My "core_reputation_leaderboard_history" table only has 108 entries.
    • The earliest date is *1516813200" (Wednesday, January 24, 2018 5:00:00 PM - I'm GMT+0500).
  • My "core_reputation_index" has about 62,000 entries in it.
    • The first of which is "1296574703" (Tuesday, February 1, 2011 3:38:23 PM).

So is my "core_reputation_leaderboard_history" table messed up? Or does it only go back about a month?

https://thesandtrap.com/leaderboard/?time=year shows me leading with 1,708 reputation and https://thesandtrap.com/leaderboard/?time=oldest shows me leading with 4,846 reputation. So those seem correct.

----------------------------------------------------------------------

So… why aren't the "days won" things showing up correctly?

Link to comment
Share on other sites

11 minutes ago, iacas said:

Yeah, I was hoping to avoid having to do that.

Just curious… how many entries does your "core_reputation_leaderboard_history" table have?

Had the same issue, just had to rebuild leaderboard. It’s in the leaderbord settings

Although this might be a bug if it’s affecting multiple people 

Link to comment
Share on other sites

  • 1 month later...
On ‎21‎.‎02‎.‎2018 at 12:20 AM, David.. said:

Had the same issue, just had to rebuild leaderboard. It’s in the leaderbord settings

Although this might be a bug if it’s affecting multiple people 

 

7 minutes ago, Michael R said:

Was there a solution to this?

There was a bug in 4.2.6 or 4.2.7 I reported and IPS offered a patch.

After the patch was applied I had to rebuild the leaderboard as a second step, as it didn't do this automatically.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...