Jump to content

Community

Track Members


Recommended Posts

  • Replies 152
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

What's New in Version 1.0.2: New feature: Added actions to search: you will be able to know what your members are searching/looking for and thus make decisions regarding your content.

New version today later with a new feature: track Search actions. With this information, you can direct your content to get more interest from members.

Do you need to track the activities of specific members on your forum? Track Members will allow you to track the steps of any member as they interface with your forum and it is highly configurable to

Posted Images

  • 4 weeks later...

Hi Adriano,

We used it extensively on 3.4.x, and only just upgraded to 4.5.4, which was successful. However, when clicking the Install button in the Marketplace from our ACP we unfortunately get the following error message:

"There was an error installing the resource, please submit a support ticket for further assistance."

PHP 7.3, MariaDB 10.2, CentOS 7, IPB 4.5.4

Any suggestions?

Thank you in advance!

Kind regards, Wim

Link to post
Share on other sites

Thank you, Adriano.

I managed to fix it myself. We had a (smallish) database crash, and as a result we upgraded from MariaSB 10.0 to 10.1, which appeared to fix it, so then to 10.2. However, as the ACP then became unavailable we could not deinstall old apps - that seems to have been the problem. I managed by deleting tables, the directory, and the configuration settings manually. Just that I now need to set it up all over, and that we lost historical data.

It is what it is :). At least it is installed now.

Cheerio, Wim

Edited by wimg
Link to post
Share on other sites

@Adriano Faria 

[[Template trackmembers/front/logs/logsRows is throwing an error. This theme may be out of date. Run the support tool in the AdminCP to restore the default theme.]]
 

This is error even on a new create of the default theme.

 

#0 /forums/system/Theme/Theme.php(860) : eval()'d code(926): IPS\Patterns\_ActiveRecord::load(NULL)
#1 /forums/system/Theme/SandboxedTemplate.php(61): IPS\Theme\class_trackmembers_front_logs->logsRows(Object(IPS\Helpers\Table\Db), Array, Array)
#2 /forums/system/Theme/Theme.php(860) : eval()'d code(1268): IPS\Theme\_SandboxedTemplate->__call('logsRows', Array)
#3 /forums/system/Theme/SandboxedTemplate.php(61): IPS\Theme\class_trackmembers_front_logs->logsTable(Object(IPS\Helpers\Table\Db), Array, Array, NULL, true)
#4 /forums/system/Helpers/Table/Table.php(564): IPS\Theme\_SandboxedTemplate->__call('logsTable', Array)
#5 /forums/applications/trackmembers/modules/front/trackmembers/logs.php(126): IPS\Helpers\Table\_Table->__toString()
#6 /forums/system/Dispatcher/Controller.php(101): IPS\trackmembers\modules\front\trackmembers\_logs->manage()
#7 /forums/applications/trackmembers/modules/front/trackmembers/logs.php(30): IPS\Dispatcher\_Controller->execute()
#8 /forums/system/Dispatcher/Dispatcher.php(152): IPS\trackmembers\modules\front\trackmembers\_logs->execute()
#9 /forums/index.php(13): IPS\_Dispatcher->run()
#10 {main}

 

Edited by Afrodude
Link to post
Share on other sites
23 hours ago, Afrodude said:

@Adriano Faria 

[[Template trackmembers/front/logs/logsRows is throwing an error. This theme may be out of date. Run the support tool in the AdminCP to restore the default theme.]]
 

This is error even on a new create of the default theme.

 


#0 /forums/system/Theme/Theme.php(860) : eval()'d code(926): IPS\Patterns\_ActiveRecord::load(NULL)
#1 /forums/system/Theme/SandboxedTemplate.php(61): IPS\Theme\class_trackmembers_front_logs->logsRows(Object(IPS\Helpers\Table\Db), Array, Array)
#2 /forums/system/Theme/Theme.php(860) : eval()'d code(1268): IPS\Theme\_SandboxedTemplate->__call('logsRows', Array)
#3 /forums/system/Theme/SandboxedTemplate.php(61): IPS\Theme\class_trackmembers_front_logs->logsTable(Object(IPS\Helpers\Table\Db), Array, Array, NULL, true)
#4 /forums/system/Helpers/Table/Table.php(564): IPS\Theme\_SandboxedTemplate->__call('logsTable', Array)
#5 /forums/applications/trackmembers/modules/front/trackmembers/logs.php(126): IPS\Helpers\Table\_Table->__toString()
#6 /forums/system/Dispatcher/Controller.php(101): IPS\trackmembers\modules\front\trackmembers\_logs->manage()
#7 /forums/applications/trackmembers/modules/front/trackmembers/logs.php(30): IPS\Dispatcher\_Controller->execute()
#8 /forums/system/Dispatcher/Dispatcher.php(152): IPS\trackmembers\modules\front\trackmembers\_logs->execute()
#9 /forums/index.php(13): IPS\_Dispatcher->run()
#10 {main}

 

You probably deleted a member or a group and it's failing to load it when viewing the logs. I'll add some checks to avoid the error.

EDIT: Please check your message. I have a template fix to test before I update the file on marketplace.

Edited by Adriano Faria
Link to post
Share on other sites
  • 3 weeks later...

Hi Adriano,

I cannot upgrade from the 3.4.8 version to the one for 4.5.4.

I left database tables and software installed intact, in the hope of an upgrade including data.

The error message I received is as follows:

../forum/admin/?app=core&module=marketplace&controller=marketplace&do=install&id=8875&type=install&csrfKey=de5885bca773257391db2887b63864be&confirm=1

Missing: /applications/trackmembers/Application.php

and backtrace:

#0 /home/fpnadmin/public_html/forum/system/Patterns/ActiveRecord.php(148): IPS\_Application::constructFromData(Array)
#1 /home/fpnadmin/public_html/forum/system/Application/Application.php(252): IPS\Patterns\_ActiveRecord::load('trackmembers', 'app_directory', NULL)
#2 /home/fpnadmin/public_html/forum/applications/core/modules/admin/marketplace/marketplace.php(812): IPS\_Application::load('trackmembers')
#3 /home/fpnadmin/public_html/forum/applications/core/modules/admin/marketplace/marketplace.php(240): IPS\core\modules\admin\marketplace\_marketplace->_installApplication(Array, '/tmp/IPSMPFAFPy...')
#4 /home/fpnadmin/public_html/forum/system/Dispatcher/Controller.php(90): IPS\core\modules\admin\marketplace\_marketplace->install()
#5 /home/fpnadmin/public_html/forum/applications/core/modules/admin/marketplace/marketplace.php(40): IPS\Dispatcher\_Controller->execute()
#6 /home/fpnadmin/public_html/forum/system/Dispatcher/Dispatcher.php(152): IPS\core\modules\admin\marketplace\_marketplace->execute()
#7 /home/fpnadmin/public_html/forum/admin/index.php(14): IPS\_Dispatcher->run()
#8 {main}

I have also tried removing the old application, from ../forum/applications_addon/other/ , but that resulted in the Marketplace greying out and no further action.

Could you please tell me how I can go ahead and upgrade to the 4.5.4 version, ideally with the old data intact, or otherwise, if that is not possible, to upgrade at least to the latest version?

Thank you very much in advance!

Kind regards, Wim

Link to post
Share on other sites

Ok, I thought I'd give that a try, regardlkess, without disabling other 3rd party resources.

Essentially I removed the out-of date version from the ACP, next removed the old code from the server, and then installed the new version.

It threw a no permission error. However, when checking the applications, it was there, approximately in the middle of the app-llst, disabled, completely lined up to the left.

Clicking on Permissions allowed me to change permissions, and after saving it disappeared to the uninstalled add-ons section.

I could then install it, and it works!

Lost all data, however,but at least it is installed now, and appears to be working :).

Kind regards, Wim

Link to post
Share on other sites
  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy