Jump to content

"This theme file could not be saved"


Recommended Posts

Trying to make an edit to GlobalTemplate in the theme editor and get the following error:

"This theme file could not be saved".

Assuming a permission issues / chmod issue, but not sure where it's looking that it doesn't have permission. Ran support tool and nothing showing up there. Ideas?

Link to comment
Share on other sites

4 minutes ago, Adlago said:

Use a  Designers' Mode to edit templates that have this issue

This is supposedly the default IPS Theme. Still do this? If I run support tool and have it recreate the default theme (it does it because I have stuff in custom.css) it still has the issue on a totally unmodified theme (and to clarify, my only edit was to put a few things in custom.css which I understood was the upgrade proof way to do things - i've never previously edited any template files).

Link to comment
Share on other sites

2 minutes ago, Adlago said:

I did not encounter such a issue when editing in the Custom CSS.:unsure: I only met this message when editing some templates.

Try clearing your browser cache and then go back to the admin panel.

Oh I should clarify, I think my issue is the same as yours was. I can edit css fine (which is how I even have a custom.css). I just wanted to avert anyone thinking I was working off a custom theme - it's the default IPS Theme with one edit, which is a few non material things added to custom.css. This is the first time I've ever tried to edit a template, and it gave me the theme file could not be saved error.

Thanks for the designers mode suggestion. That worked, although I'm confused why I can't use the manual editor in the ACP. Tried cache clear and all on my own computer and through ACP - nadda.

Link to comment
Share on other sites

Just now, Adlago said:

Some time ago I had such a topic here for edit some templates for which I received the same issue. I checked many things in my installation - no success.
Finally, I decided to use a Designers' Mode and this solved the problem.

Out of curiosity, do you have mod_security running with apache, or use cloudfront with its security enabled? I'm wondering if there is something blocking the edits there.

Link to comment
Share on other sites

  • 8 months later...


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...